build, imagebuilder: Do not require libncurses-dev
authorPaul Spooren <mail@aparcar.org>
Tue, 14 Apr 2020 21:14:47 +0000 (11:14 -1000)
committerPetr Štetiar <ynezz@true.cz>
Wed, 3 Jun 2020 14:49:28 +0000 (16:49 +0200)
The buildroot and SDK both require `libncurses-dev` to be installed on
the system, however the ImageBuilder uses precompiled binaries.

This patch changes the prerequirements checks to skip the
`libncurses-dev` part if running as ImageBuilder.

Signed-off-by: Paul Spooren <mail@aparcar.org>
include/prereq-build.mk

index f4fa592a7f0fcd0bb18588543ec1f30d68ae8f95..83dad0f2dc6e6bad1327f62f398d074d2a2eb0bf 100644 (file)
@@ -51,10 +51,12 @@ $(eval $(call TestHostCommand,working-g++, \
                g++ -x c++ -o $(TMP_DIR)/a.out - -lstdc++ && \
                $(TMP_DIR)/a.out))
 
+ifndef IB
 $(eval $(call TestHostCommand,ncurses, \
        Please install ncurses. (Missing libncurses.so or ncurses.h), \
        echo 'int main(int argc, char **argv) { initscr(); return 0; }' | \
                gcc -include ncurses.h -x c -o $(TMP_DIR)/a.out - -lncurses))
+endif
 
 ifeq ($(HOST_OS),Linux)
   zlib_link_flags := -Wl,-Bstatic -lz -Wl,-Bdynamic