prepare for RouterStation support
authorGabor Juhos <juhosg@openwrt.org>
Mon, 15 Dec 2008 19:18:52 +0000 (19:18 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Mon, 15 Dec 2008 19:18:52 +0000 (19:18 +0000)
SVN-Revision: 13657

target/linux/ar71xx/config-2.6.26
target/linux/ar71xx/config-2.6.27
target/linux/ar71xx/config-2.6.28
target/linux/ar71xx/files-2.6.28/arch/mips/include/asm/mach-ar71xx/ar71xx.h
target/linux/ar71xx/files/arch/mips/ar71xx/Kconfig
target/linux/ar71xx/files/arch/mips/ar71xx/Makefile
target/linux/ar71xx/files/arch/mips/ar71xx/mach-routerstation.c [new file with mode: 0644]
target/linux/ar71xx/files/include/asm-mips/mach-ar71xx/ar71xx.h

index f15de1dc476fe2a40a778c5fbf7e57de41aa148e..f2e2f170f0eabc5aae0aade63b07872c77ae6b6d 100644 (file)
@@ -8,6 +8,7 @@ CONFIG_AR71XX_MACH_AP83=y
 CONFIG_AR71XX_MACH_AW_NR580=y
 CONFIG_AR71XX_MACH_GENERIC=y
 CONFIG_AR71XX_MACH_RB_4XX=y
+CONFIG_AR71XX_MACH_ROUTERSTATION=y
 CONFIG_AR71XX_MACH_TEW_632BRP=y
 CONFIG_AR71XX_MACH_WP543=y
 CONFIG_AR71XX_WDT=y
index 03c73b06d68e58ebe74ea0c6789f287e5a9ae853..b542deb4b078522e21484d4f682156f24e629734 100644 (file)
@@ -8,6 +8,7 @@ CONFIG_AR71XX_MACH_AP83=y
 CONFIG_AR71XX_MACH_AW_NR580=y
 CONFIG_AR71XX_MACH_GENERIC=y
 CONFIG_AR71XX_MACH_RB_4XX=y
+CONFIG_AR71XX_MACH_ROUTERSTATION=y
 CONFIG_AR71XX_MACH_TEW_632BRP=y
 CONFIG_AR71XX_MACH_WP543=y
 CONFIG_AR71XX_WDT=y
index b6133a9a171640e6551fe5991af3434a1a79fd92..c17fe15e7694f90c8a9f857754c488c3aea83a61 100644 (file)
@@ -8,6 +8,7 @@ CONFIG_AR71XX_MACH_AP83=y
 CONFIG_AR71XX_MACH_AW_NR580=y
 CONFIG_AR71XX_MACH_GENERIC=y
 CONFIG_AR71XX_MACH_RB_4XX=y
+CONFIG_AR71XX_MACH_ROUTERSTATION=y
 CONFIG_AR71XX_MACH_TEW_632BRP=y
 CONFIG_AR71XX_MACH_WP543=y
 CONFIG_AR71XX_WDT=y
index 42db7cc2420e3d8304caf536e4c557b83809e7fe..87af166d5e5cf8a59f5cefb0b1ffbb835bd68229 100644 (file)
@@ -114,6 +114,7 @@ extern unsigned long ar71xx_mach_type;
 #define AR71XX_MACH_AW_NR580   6       /* AzureWave AW-NR580 */
 #define AR71XX_MACH_AP83       7       /* Atheros AP83 */
 #define AR71XX_MACH_TEW_632BRP 8       /* TRENDnet TEW-632BRP */
+#define AR71XX_MACH_ROUTERSTATION 9    /* Ubiquiti RouterStation */
 
 /*
  * PLL block
index 7e9b75c5dbee1266e78eaa6b52dc2ef81ee6e054..d16fdb82408c249755829b9f5c2ad663e3923f37 100644 (file)
@@ -31,6 +31,10 @@ config AR71XX_MACH_TEW_632BRP
        bool "TRENDnet TEW-632BRP support"
        default y
 
+config AR71XX_MACH_ROUTERSTATION
+       bool "Ubiquiti RouterStation support"
+       default y
+
 endmenu
 
 endif
index 37a1ebfb4aa29e5fc803756812537337933091a1..f53dc9daf1da3dd90ed5714c4e53b8878b511a18 100644 (file)
@@ -14,5 +14,6 @@ obj-$(CONFIG_AR71XX_MACH_AP83)                += mach-ap83.o
 obj-$(CONFIG_AR71XX_MACH_AW_NR580)     += mach-aw-nr580.o
 obj-$(CONFIG_AR71XX_MACH_GENERIC)      += mach-generic.o
 obj-$(CONFIG_AR71XX_MACH_RB_4XX)       += mach-rb-4xx.o
+obj-$(CONFIG_AR71XX_MACH_ROUTERSTATION)        += mach-routerstation.o
 obj-$(CONFIG_AR71XX_MACH_TEW_632BRP)   += mach-tew-632brp.o
 obj-$(CONFIG_AR71XX_MACH_WP543)                += mach-wp543.o
diff --git a/target/linux/ar71xx/files/arch/mips/ar71xx/mach-routerstation.c b/target/linux/ar71xx/files/arch/mips/ar71xx/mach-routerstation.c
new file mode 100644 (file)
index 0000000..a8de711
--- /dev/null
@@ -0,0 +1,37 @@
+/*
+ *  Ubiquiti RouterStation support
+ *
+ *  Copyright (C) 2008 Gabor Juhos <juhosg@openwrt.org>
+ *  Copyright (C) 2008 Imre Kaloz <kaloz@openwrt.org>
+ *
+ *  This program is free software; you can redistribute it and/or modify it
+ *  under the terms of the GNU General Public License version 2 as published
+ *  by the Free Software Foundation.
+ */
+
+#include <linux/platform_device.h>
+#include <linux/spi/spi.h>
+#include <linux/spi/flash.h>
+
+#include <asm/mips_machine.h>
+#include <asm/mach-ar71xx/ar71xx.h>
+#include <asm/mach-ar71xx/pci.h>
+#include <asm/mach-ar71xx/platform.h>
+
+static struct spi_board_info routerstation_spi_info[] = {
+       {
+               .bus_num        = 0,
+               .chip_select    = 0,
+               .max_speed_hz   = 25000000,
+               .modalias       = "m25p80",
+       }
+};
+
+static void __init routerstation_setup(void)
+{
+       ar71xx_add_device_spi(NULL, routerstation_spi_info,
+                                       ARRAY_SIZE(routerstation_spi_info));
+}
+
+MIPS_MACHINE(AR71XX_MACH_ROUTERSTATION, "Ubiquiti RouterStation",
+                                       routerstation_setup);
index 42db7cc2420e3d8304caf536e4c557b83809e7fe..87af166d5e5cf8a59f5cefb0b1ffbb835bd68229 100644 (file)
@@ -114,6 +114,7 @@ extern unsigned long ar71xx_mach_type;
 #define AR71XX_MACH_AW_NR580   6       /* AzureWave AW-NR580 */
 #define AR71XX_MACH_AP83       7       /* Atheros AP83 */
 #define AR71XX_MACH_TEW_632BRP 8       /* TRENDnet TEW-632BRP */
+#define AR71XX_MACH_ROUTERSTATION 9    /* Ubiquiti RouterStation */
 
 /*
  * PLL block