ar71xx: Image generation for PowerCloud CR5000 Cloud Router
authorFelix Fietkau <nbd@openwrt.org>
Sat, 19 Dec 2015 11:27:52 +0000 (11:27 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 19 Dec 2015 11:27:52 +0000 (11:27 +0000)
Kernel part of support for the PowerCloud Systems CR5000.  The
CR5000 is a dual-band 802.11n wireless router with 8MB flash,
64 MB RAM, (unused in stock firmware) USB 2.0 port, and five
port gigabit ethernet switch.  The CR5000 was sold as hardware for
the Skydog cloud-managed router service.

Signed-off-by: Daniel Dickinson <openwrt@daniel.thecshore.com>
SVN-Revision: 47943

target/linux/ar71xx/generic/profiles/pcs.mk
target/linux/ar71xx/image/Makefile

index b4df1a47128c39b46378c79d8a36859051e8cac6..e48b3bd953f8dbca34ba5049060736d427b77e8e 100644 (file)
@@ -65,3 +65,21 @@ endef
 
 $(eval $(call Profile,CR3000))
 
+define Profile/CR5000
+       NAME:=PowerCloud CR5000 Cloud Router
+       PACKAGES:=uboot-envtools kmod-usb2 kmod-usb-ohci kmod-ledtrig-usbdev kmod-usb-core
+endef
+
+define Profile/CR5000/Description
+       Package set optimized for the PowerCloud Systems CR5000 Cloud Router
+
+       The CR5000 is a device sold by PowerCloud Systems as a hardware
+       option for their Skydog cloud-managed Wifi solution.
+
+       The CR5000 is a dual band GHz 802.11n wireless router with 8MB
+       flash and 64MB RAM, a five port gigabit switch and a USB 2.0
+       port which was unused in the stock firmware.
+endef
+
+$(eval $(call Profile,CR5000))
+
index af9516eaa706fa3dc25d2467b285c660d4f230cf..61c76a342bb221f37430e2e2cd0330e7139f8012 100644 (file)
@@ -427,6 +427,24 @@ endef
 
 TARGET_DEVICES += cr3000-nocloud
 
+define Device/cr5000
+  BOARDNAME := CR5000
+  DEVICE_PROFILE := CR5000
+  IMAGE_SIZE = 7104k
+  MTDPARTS = spi0.0:256k(u-boot),64k(u-boot-env)ro,7104k(firmware),640k(certs),64k(nvram),64k(art)
+endef
+
+TARGET_DEVICES += cr5000
+
+define Device/cr5000-nocloud
+  BOARDNAME := CR5000
+  DEVICE_PROFILE := CR5000
+  IMAGE_SIZE = 7808k
+  MTDPARTS = spi0.0:256k(u-boot),64k(u-boot-env)ro,7808k(firmware),64k(art)
+endef
+
+TARGET_DEVICES += cr5000-nocloud
+
 define Device/antminer-s1
     $(Device/tplink-8mlzma)
     BOARDNAME := ANTMINER-S1