kernel: bump 4.9 to 4.9.117
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Fri, 3 Aug 2018 08:52:28 +0000 (10:52 +0200)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Fri, 3 Aug 2018 14:10:38 +0000 (16:10 +0200)
Refreshed all patches

Compile-tested on: ar71xx
Runtime-tested on: ar71xx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/brcm2708/patches-4.9/950-0031-Add-dwc_otg-driver.patch
target/linux/brcm2708/patches-4.9/950-0139-usb-dwc2-Avoid-suspending-if-we-re-in-gadget-mode-18.patch
target/linux/generic/backport-4.9/050-usb-dwc2-Remove-unnecessary-kfree.patch
target/linux/generic/backport-4.9/500-ext4-fix-check-to-prevent-initializing-reserved-inod.patch
target/linux/generic/hack-4.9/902-debloat_proc.patch
target/linux/generic/pending-4.9/890-uart_optional_sysrq.patch
target/linux/layerscape/patches-4.9/402-mtd-support-layerscape.patch
target/linux/layerscape/patches-4.9/810-iommu-support-layerscape.patch
target/linux/layerscape/patches-4.9/817-usb-support-layerscape.patch

index 631b9785e9f55b53b63bfb19685ff60ac7acdc18..64dd4259b26a7f65df417cc147c98af324f0edac 100644 (file)
@@ -4,13 +4,13 @@ LINUX_RELEASE?=1
 
 LINUX_VERSION-3.18 = .71
 LINUX_VERSION-4.4 = .121
-LINUX_VERSION-4.9 = .116
 LINUX_VERSION-4.14 = .59
+LINUX_VERSION-4.9 = .117
 
 LINUX_KERNEL_HASH-3.18.71 = 5abc9778ad44ce02ed6c8ab52ece8a21c6d20d21f6ed8a19287b4a38a50c1240
 LINUX_KERNEL_HASH-4.4.121 = 44a88268b5088dc326b30c9b9133ac35a9a200b636b7268d08f32abeae6ca729
-LINUX_KERNEL_HASH-4.9.116 = 999e8291bec0bcef2e0b91b6d58d8be5eb5e7c70881df59439364b22b693ff1d
 LINUX_KERNEL_HASH-4.14.59 = 7ec633c661bba941239e340bb35391d356eda541fb4c323d07034d09d05b319b
+LINUX_KERNEL_HASH-4.9.117 = 8232ea326ac5784d71baa09c0cd7806a2674f8449c0be73e2ae341e6880279b0
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index 258299fcf1ad031adf4744ccc0bc22a82a5526ce..1db23d7235d14c5cb2d8d51d616d9fe229d6d152 100644 (file)
@@ -696,7 +696,7 @@ Signed-off-by: Noralf Trønnes <noralf@tronnes.org>
  }
 --- a/drivers/usb/core/hub.c
 +++ b/drivers/usb/core/hub.c
-@@ -5068,7 +5068,7 @@ static void port_event(struct usb_hub *h
+@@ -5072,7 +5072,7 @@ static void port_event(struct usb_hub *h
        if (portchange & USB_PORT_STAT_C_OVERCURRENT) {
                u16 status = 0, unused;
  
index 1bfe34408e4471c0e685c55010168f9952a41d9b..862f322e6d0caf0f242ab47b703520f436dd1333 100644 (file)
@@ -39,7 +39,7 @@ Signed-off-by: Felipe Balbi <felipe.balbi@linux.intel.com>
 
 --- a/drivers/usb/dwc2/hcd.c
 +++ b/drivers/usb/dwc2/hcd.c
-@@ -4381,6 +4381,9 @@ static int _dwc2_hcd_suspend(struct usb_
+@@ -4383,6 +4383,9 @@ static int _dwc2_hcd_suspend(struct usb_
        if (!HCD_HW_ACCESSIBLE(hcd))
                goto unlock;
  
index 69aaa9f84d069dd3bb2c1d39768b139a38455285..346eba92213e6288996517399455cc8ac1148e03 100644 (file)
@@ -14,7 +14,7 @@ Signed-off-by: Felipe Balbi <felipe.balbi@linux.intel.com>
 
 --- a/drivers/usb/dwc2/hcd.c
 +++ b/drivers/usb/dwc2/hcd.c
-@@ -5200,7 +5200,6 @@ error3:
+@@ -5202,7 +5202,6 @@ error3:
  error2:
        usb_put_hcd(hcd);
  error1:
index bcb42d638ac275957a9db4e77be48efcdd18fdf0..914dddf72665322e561344c7076e4fd3cf4a0440 100644 (file)
@@ -33,7 +33,7 @@ Signed-off-by: Theodore Ts'o <tytso@mit.edu>
 
 --- a/fs/ext4/ialloc.c
 +++ b/fs/ext4/ialloc.c
-@@ -1313,7 +1313,10 @@ int ext4_init_inode_table(struct super_b
+@@ -1316,7 +1316,10 @@ int ext4_init_inode_table(struct super_b
                            ext4_itable_unused_count(sb, gdp)),
                            sbi->s_inodes_per_block);
  
index ae2dad61e5d6f53640d428e9997e82ad54e058ba..cab7276d290baab893a756b655c523a336fde7f6 100644 (file)
@@ -232,7 +232,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
                return -ENOMEM;
 --- a/mm/vmalloc.c
 +++ b/mm/vmalloc.c
-@@ -2713,6 +2713,8 @@ static const struct file_operations proc
+@@ -2714,6 +2714,8 @@ static const struct file_operations proc
  
  static int __init proc_vmalloc_init(void)
  {
index 6cb745ee3329b75d0476e4c4fca9890ecefef5de..ff0824d343d07cfcdd102b1562b067e0adde778c 100644 (file)
@@ -15,7 +15,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 
 --- a/include/linux/serial_core.h
 +++ b/include/linux/serial_core.h
-@@ -455,7 +455,7 @@ extern void uart_handle_cts_change(struc
+@@ -456,7 +456,7 @@ extern void uart_handle_cts_change(struc
  extern void uart_insert_char(struct uart_port *port, unsigned int status,
                 unsigned int overrun, unsigned int ch, unsigned int flag);
  
index 6b3485700a5e7c78b5c3daa78952d8cb55303a94..9f44e9e72352983387a3faa4d3f69aefbe222f58 100644 (file)
@@ -358,7 +358,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
        help
 --- a/drivers/mtd/nand/fsl_ifc_nand.c
 +++ b/drivers/mtd/nand/fsl_ifc_nand.c
-@@ -898,7 +898,7 @@ static int fsl_ifc_chip_init(struct fsl_
+@@ -901,7 +901,7 @@ static int fsl_ifc_chip_init(struct fsl_
                chip->ecc.algo = NAND_ECC_HAMMING;
        }
  
index b9faa504b686934110894c2819e71756d1fd92b5..050092905c76591d404d1ad986ea181d18f7d66d 100644 (file)
@@ -1472,7 +1472,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  }
 --- a/include/linux/dma-iommu.h
 +++ b/include/linux/dma-iommu.h
-@@ -27,6 +27,7 @@ int iommu_dma_init(void);
+@@ -28,6 +28,7 @@ int iommu_dma_init(void);
  
  /* Domain management interface for IOMMU drivers */
  int iommu_get_dma_cookie(struct iommu_domain *domain);
@@ -1480,7 +1480,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  void iommu_put_dma_cookie(struct iommu_domain *domain);
  
  /* Setup call for arch DMA mapping code */
-@@ -66,6 +67,7 @@ int iommu_dma_mapping_error(struct devic
+@@ -67,6 +68,7 @@ int iommu_dma_mapping_error(struct devic
  
  /* The DMA API isn't _quite_ the whole story, though... */
  void iommu_dma_map_msi_msg(int irq, struct msi_msg *msg);
@@ -1488,7 +1488,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  
  #else
  
-@@ -82,6 +84,11 @@ static inline int iommu_get_dma_cookie(s
+@@ -83,6 +85,11 @@ static inline int iommu_get_dma_cookie(s
        return -ENODEV;
  }
  
@@ -1500,7 +1500,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  static inline void iommu_put_dma_cookie(struct iommu_domain *domain)
  {
  }
-@@ -90,6 +97,10 @@ static inline void iommu_dma_map_msi_msg
+@@ -91,6 +98,10 @@ static inline void iommu_dma_map_msi_msg
  {
  }
  
index 9225e93c1a5b138c4b86ddc1a5664ed60c3905fd..5af0b088a86f220387be886c02259c4a4fcb4a3b 100644 (file)
@@ -156,7 +156,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
        int ret;
 --- a/drivers/usb/core/hub.c
 +++ b/drivers/usb/core/hub.c
-@@ -4427,6 +4427,14 @@ hub_port_init(struct usb_hub *hub, struc
+@@ -4431,6 +4431,14 @@ hub_port_init(struct usb_hub *hub, struc
        else
                speed = usb_speed_string(udev->speed);