mxs: reinstate rootfs image creation and dtb copy
authorZoltan Herpai <wigyori@uid0.hu>
Fri, 10 Apr 2015 21:36:33 +0000 (21:36 +0000)
committerZoltan Herpai <wigyori@uid0.hu>
Fri, 10 Apr 2015 21:36:33 +0000 (21:36 +0000)
Signed-off-by: Harald Geyer <harald@ccbib.org>
Acked-by: Michael Heimpold <mhei@heimpold.de>
SVN-Revision: 45369

target/linux/mxs/image/Makefile

index 9830a7d616e8374bc6b2c902f047f2e975340196..b5a092e365741fcabdbce007911ca65c5b300443 100644 (file)
@@ -9,6 +9,9 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 include $(INCLUDE_DIR)/host.mk
 
 include $(INCLUDE_DIR)/image.mk
 include $(INCLUDE_DIR)/host.mk
 
+BOARDS:= \
+       imx23-olinuxino \
+       imx28-duckbill
 FAT32_BLOCK_SIZE=1024
 FAT32_BLOCKS=$(shell echo $$(($(CONFIG_MXS_SD_BOOT_PARTSIZE)*1024*1024/$(FAT32_BLOCK_SIZE))))
 
 FAT32_BLOCK_SIZE=1024
 FAT32_BLOCKS=$(shell echo $$(($(CONFIG_MXS_SD_BOOT_PARTSIZE)*1024*1024/$(FAT32_BLOCK_SIZE))))
 
@@ -72,6 +75,7 @@ endef
 define Image/Build
        $(call Image/Build/$(1),$(1))
        $(call Image/Build/Profile/$(PROFILE),$(1))
 define Image/Build
        $(call Image/Build/$(1),$(1))
        $(call Image/Build/Profile/$(PROFILE),$(1))
+       dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-root.$(1) bs=128k conv=sync
 endef
 
 $(eval $(call BuildImage))
 endef
 
 $(eval $(call BuildImage))