wireguard: bump to 20180514
authorKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Wed, 16 May 2018 15:14:15 +0000 (16:14 +0100)
committerHans Dedecker <dedeckeh@gmail.com>
Thu, 17 May 2018 07:47:20 +0000 (09:47 +0200)
52be69b version: bump snapshot
4884b45 ncat-client-server: add wg-quick variant
a333551 wg-quick: add darwin implementation
f5bf84d compat: backport for OpenSUSE 15
fe1ae1b wg-quick: add wg symlink
ecc1c5f wg-quick: add android implementation
3e6bb79 tools: reorganize for multiplatform wg-quick
b289d12 allowedips: Fix graphviz output after endianness patch

Refresh cross compile compatibility patch

Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
package/network/services/wireguard/Makefile
package/network/services/wireguard/patches/100-portability.patch

index 1aa8659124a1cf7d119af33d829b30d046b7dfc1..5ca7b7da57875be022e2fdd38bf48061e8b8a17d 100644 (file)
@@ -11,12 +11,12 @@ include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=wireguard
 
-PKG_VERSION:=0.0.20180513
+PKG_VERSION:=0.0.20180514
 PKG_RELEASE:=1
 
 PKG_SOURCE:=WireGuard-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://git.zx2c4.com/WireGuard/snapshot/
-PKG_HASH:=28a15c59f6710851587ebca76a335f1aaaa077aad052732e0959f2bae9ba8d5c
+PKG_HASH:=e895b65e06e85429403be3d1987577a6967476b069f0ff53caead6f682f466da
 
 PKG_LICENSE:=GPL-2.0 Apache-2.0
 PKG_LICENSE_FILES:=COPYING
index b26d51ebd8a20c30ca5d226d4901d71d15d41df2..33a7373cc7a73dafa6bdbe7c43ed9555d9651cdb 100644 (file)
@@ -7,12 +7,13 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 ---
 --- a/src/tools/Makefile
 +++ b/src/tools/Makefile
-@@ -43,7 +43,7 @@ CFLAGS += -DRUNSTATEDIR="\"$(RUNSTATEDIR
- ifeq ($(DEBUG_TOOLS),y)
- CFLAGS += -g
+@@ -36,6 +36,9 @@ endif
  endif
--ifeq ($(shell uname -s),Linux)
+ PLATFORM ?= $(shell uname -s | tr '[:upper:]' '[:lower:]')
 +ifeq ($(strip $(shell echo __linux__ | $(CC) -E - | grep -v '^\#')),1)
- LIBMNL_CFLAGS := $(shell $(PKG_CONFIG) --cflags libmnl 2>/dev/null)
- LIBMNL_LDLIBS := $(shell $(PKG_CONFIG) --libs libmnl 2>/dev/null || echo -lmnl)
- CFLAGS += $(LIBMNL_CFLAGS)
++PLATFORM := linux
++endif
+ CFLAGS ?= -O3
+ CFLAGS += -std=gnu11 -D_GNU_SOURCE