mac80211: update compat-wireless to 2009-02-02
authorGabor Juhos <juhosg@openwrt.org>
Tue, 3 Feb 2009 09:18:29 +0000 (09:18 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Tue, 3 Feb 2009 09:18:29 +0000 (09:18 +0000)
SVN-Revision: 14385

package/mac80211/Makefile
package/mac80211/patches/403-ath9k-fix-invalid-mac-address-handling.patch

index 0448f0063a6ac1096ef810a8a81f4f39f2425120..0de84a01beb88e0ef8d2cfdec4e74838ad8adc0c 100644 (file)
@@ -9,14 +9,14 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=mac80211
-PKG_RELEASE:=2
+PKG_RELEASE:=1
 
 ifneq ($(CONFIG_LINUX_2_6_27)$(CONFIG_LINUX_2_6_28),)
-  PKG_VERSION:=2009-01-29
+  PKG_VERSION:=2009-02-02
   PKG_SOURCE_URL:= \
-       http://www.orbit-lab.org/kernel/compat-wireless-2.6/2009/01 \
+       http://www.orbit-lab.org/kernel/compat-wireless-2.6/2009/02 \
        http://wireless.kernel.org/download/compat-wireless-2.6
-  PKG_MD5SUM:=7ad466fd68967de744ab41caddff10d9
+  PKG_MD5SUM:=310b08184b16ead8cab3714bf5a57728
 else
   PKG_VERSION:=2008-08-06
   PKG_SOURCE_URL:=http://www.orbit-lab.org/kernel/compat-wireless-2.6/2008/08
index 2a1763a93f0b5a4243dc23f12e92dfa0cb6a334b..4539b30fefafba8ca08faa50c5ce9b486f47f6d9 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/wireless/ath9k/hw.c
 +++ b/drivers/net/wireless/ath9k/hw.c
-@@ -499,11 +499,18 @@ static int ath9k_hw_init_macaddr(struct 
+@@ -500,11 +500,18 @@ static int ath9k_hw_init_macaddr(struct 
                ahp->ah_macaddr[2 * i] = eeval >> 8;
                ahp->ah_macaddr[2 * i + 1] = eeval & 0xff;
        }