firewall: improve ipset support
authorKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Fri, 16 Aug 2019 09:05:12 +0000 (10:05 +0100)
committerKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Fri, 16 Aug 2019 10:27:24 +0000 (11:27 +0100)
Bump to latest git HEAD

509e673 firewall3: Improve ipset support

The enabled option did not work properly for ipsets, as it was not
checked on create/destroy of a set. After this commit, sets are only
created/destroyed if enabled is set to true.

Add support for reloading, or recreating, ipsets on firewall reload.  By
setting "reload_set" to true, the set will be destroyed and then
re-created when the firewall is reloaded.

Add support for the counters and comment extensions. By setting
"counters" or "comment" to true, then counters or comments are added to
the set.

Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
package/network/config/firewall/Makefile

index 9ae45f0db69d954f83989e80c45371e6da0e916c..101e072ae2a1bc84a553199caf93579ee45ad076 100644 (file)
@@ -9,13 +9,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=firewall
-PKG_RELEASE:=2
+PKG_RELEASE:=1
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL=$(PROJECT_GIT)/project/firewall3.git
-PKG_SOURCE_DATE:=2019-06-12
-PKG_SOURCE_VERSION:=de9409762de14b5d909925c5db2e704ec13c754b
-PKG_MIRROR_HASH:=291e390250c9bf5a997a62796afd0b1cf6a08f8a6d9b99fe3ecc49abf491455e
+PKG_SOURCE_DATE:=2019-08-16
+PKG_SOURCE_VERSION:=509e673dab011851ed084ca592c557ee395fddd4
+PKG_MIRROR_HASH:=6c05803bbf6c74a9a90bc1e425a069695490d87a988599e4607d51d2c2acacbb
 PKG_MAINTAINER:=Jo-Philipp Wich <jo@mein.io>
 PKG_LICENSE:=ISC