mdadm: Do not check RUN_DIR
authorFlorian Fainelli <f.fainelli@gmail.com>
Wed, 31 May 2017 21:39:12 +0000 (14:39 -0700)
committerFlorian Fainelli <f.fainelli@gmail.com>
Mon, 5 Jun 2017 19:24:01 +0000 (12:24 -0700)
Fixes build failure on hosts that do not have mdadm
installed/configured:

make[3]: Entering directory
`/local/users/fainelli/openwrt/trunk/build_dir/target-mipsel-linux-gnu_glibc/mdadm-4.0'
***** Parent of /run/mdadm does not exist.  Maybe set different RUN_DIR=
*****  e.g. make RUN_DIR=/dev/.mdadm
***** or set CHECK_RUN_DIR=0
make[3]: *** [check_rundir] Error 1
make[3]: Leaving directory
`/local/users/fainelli/openwrt/trunk/build_dir/target-mipsel-linux-gnu_glibc/mdadm-4.0'
make[2]: ***
[/local/users/fainelli/openwrt/trunk/build_dir/target-mipsel-linux-gnu_glibc/mdadm-4.0/.built]
Error 2
make[2]: Leaving directory
`/local/users/fainelli/openwrt/trunk/package/utils/mdadm'
make[1]: *** [package/utils/mdadm/compile] Error 2
make[1]: Leaving directory `/local/users/fainelli/openwrt/trunk'
make: *** [package/mdadm/compile] Error 2

Fixes: 980c41f8e04f ("utils/mdadm: Update to 4.0")
Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
package/utils/mdadm/Makefile

index c25f34e5117e76a3055a3b1ee25c229f95c8cb69..1ed62d8174f8358893d5669a52b78bb17e5bbced 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mdadm
 PKG_VERSION:=4.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE_URL:=@KERNEL/linux/utils/raid/mdadm
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
@@ -50,6 +50,7 @@ define Build/Compile
                CC="$(TARGET_CC)" \
                CFLAGS="$(TARGET_CFLAGS) -DHAVE_STDINT_H" \
                LDFLAGS="$(TARGET_LDFLAGS)" \
+               CHECK_RUN_DIR=0 \
                mdadm
 endef