ar71xx:add support for E750G v8
author张鹏 <sd20@qxwlan.com>
Tue, 17 Jul 2018 10:14:25 +0000 (18:14 +0800)
committerJohn Crispin <john@phrozen.org>
Mon, 30 Jul 2018 08:43:36 +0000 (10:43 +0200)
Qxwlan E750G v8 is based on Qualcomm QCA9344.

Specification:

 - 560/450/225 MHz (CPU/DDR/AHB)
 - 128 MB of RAM (DDR2)
 - 8/16 MB of FLASH (SPI NOR)
 - 2T2R 2.4G GHz (AR9344)
 - 2x 10/100 Mbps Ethernet (PoE support)
 - 2x 10/100/1000 Mbps Ethernet
 - 7x LED (6 driven by GPIO)
 - 1x button (reset)
 - 1x DC jack for main power input (9-48 V)
 - UART (J23) and LEDs (J2) headers on PCB

Flash instruction (using U-Boot CLI and tftp server):

 - Configure PC with static IP 192.168.1.10 and tftp server.
 - Rename "sysupgrade" filename to "firmware.bin" and place it in tftp
   server directory.
 - Connect PC with one of RJ45 ports, power up the board and press
   "enter" key to access U-Boot CLI.
 - Use the following command to update the device to OpenWrt: "run lfw".

Flash instruction (using U-Boot web-based recovery):

 - Configure PC with static IP 192.168.1.xxx(2-254)/24.
 - Connect PC with one of RJ45 ports, press the reset button, power up
   the board and keep button pressed for around 6-7 seconds, until LEDs
   start flashing.
 - Open your browser and enter 192.168.1.1, select "sysupgrade" image
   and click the upgrade button.

Signed-off-by: 张鹏 <sd20@qxwlan.com>
12 files changed:
target/linux/ar71xx/base-files/etc/board.d/01_leds
target/linux/ar71xx/base-files/etc/board.d/02_network
target/linux/ar71xx/base-files/etc/diag.sh
target/linux/ar71xx/base-files/lib/ar71xx.sh
target/linux/ar71xx/base-files/lib/upgrade/platform.sh
target/linux/ar71xx/config-4.9
target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
target/linux/ar71xx/files/arch/mips/ath79/Makefile
target/linux/ar71xx/files/arch/mips/ath79/mach-e750g-v8.c [new file with mode: 0644]
target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
target/linux/ar71xx/generic/config-default
target/linux/ar71xx/image/generic.mk

index 2b3e8b739c4569d1a4e7cce451abb85aea0cca60..d15cff5111c54e092b5c2041712e2972e6a538d6 100755 (executable)
@@ -67,7 +67,7 @@ cpe870|\
 dr531|\
 e600g-v2|\
 e600gac-v2|\
-e750a-v2)
+e750a-v4)
        ucidef_set_led_netdev "lan" "LAN" "$board:green:lan" "eth0"
        ucidef_set_led_netdev "wan" "WAN" "$board:green:wan" "eth1"
 
@@ -373,7 +373,8 @@ e1700ac-v2)
        ucidef_set_led_usbdev "usb" "USB" "$board:green:usb" "1-1"
        ucidef_set_led_wlan "wlan2g" "WLAN2G" "$board:green:wlan2g" "phy1tpt"
        ;;
-e558-v2)
+e558-v2|\
+e750g-v8)
        ucidef_set_led_wlan "wlan" "WLAN" "$board:green:wlan" "phy0tpt"
        ;;
 esr900)
index be5d9ad95dd5635f2b10cdc2192a61cd1d17e68f..3967dee94b0d6601db2645321aace6cd69e55032 100755 (executable)
@@ -385,6 +385,7 @@ ar71xx_setup_interfaces()
                ucidef_add_switch_attr "switch0" "enable" "false"
                ;;
        e1700ac-v2|\
+       e750g-v8|\
        unifiac-pro|\
        xd3200)
                ucidef_add_switch "switch0" \
index 00b839ef590b1b86fe5a663566422645f408f8bb..45b5d2adbb670c283fbff5bbfa0782685c850356 100644 (file)
@@ -27,6 +27,7 @@ get_status_led() {
        e558-v2|\
        e600gac-v2|\
        e750a-v4|\
+       e750g-v8|\
        eap120|\
        minibox-v1|\
        packet-squirrel|\
index adeffe96a1ef1ee9deafd65897aee2bc1aae9997..27c4bec2805cfdded1d17c85fbbb9876e416dcd1 100755 (executable)
@@ -687,6 +687,9 @@ ar71xx_board_detect() {
        *"E750A v4")
                name="e750a-v4"
                ;;
+       *"E750G v8")
+               name="e750g-v8"
+               ;;
        *"EAP120")
                name="eap120"
                tplink_pharos_board_detect "$(tplink_pharos_get_model_string | tr -d '\r')"
index 7db4899dc784a0efa1f2e8e0eb9704cbc9d43565..5a1f71b431fb7190f4140449bf44ad07dbd83cc1 100755 (executable)
@@ -254,6 +254,7 @@ platform_check_image() {
        e600g-v2|\
        e600gac-v2|\
        e750a-v4|\
+       e750g-v8|\
        ebr-2310-c1|\
        ens202ext|\
        epg5000|\
index 72a91a1f2b28c5900330c607764b13a3a24ff109..a1c6360ef57742c5077f9c551c8688863657b163 100644 (file)
@@ -104,6 +104,7 @@ CONFIG_ATH79=y
 # CONFIG_ATH79_MACH_E558_V2 is not set
 # CONFIG_ATH79_MACH_E600G_V2 is not set
 # CONFIG_ATH79_MACH_E750A_V4 is not set
+# CONFIG_ATH79_MACH_E750G_V8 is not set
 # CONFIG_ATH79_MACH_EAP120 is not set
 # CONFIG_ATH79_MACH_EAP300V2 is not set
 # CONFIG_ATH79_MACH_EAP7660D is not set
index db410b66071ebcc9b6c0c0d2d9fb8659cfe707b3..a6903d2939ce53f8e500d3ab19b7b857ebf822d5 100644 (file)
@@ -744,6 +744,17 @@ config ATH79_MACH_E750A_V4
        select ATH79_DEV_USB
        select ATH79_DEV_WMAC
 
+config ATH79_MACH_E750G_V8
+       bool "Qxwlan E750G v8 support"
+       select SOC_AR934X
+       select ATH79_DEV_AP9X_PCI if PCI
+       select ATH79_DEV_ETH
+       select ATH79_DEV_GPIO_BUTTONS
+       select ATH79_DEV_LEDS_GPIO
+       select ATH79_DEV_M25P80
+       select ATH79_DEV_USB
+       select ATH79_DEV_WMAC
+
 config ATH79_MACH_ESR900
        bool "EnGenius ESR900 board support"
        select SOC_QCA955X
index 4453e369a304ff8fb014f78152a12da53adaa2ff..0a2fc9c17d1f9de7ce5281b712aca03129b19f5e 100644 (file)
@@ -115,6 +115,7 @@ obj-$(CONFIG_ATH79_MACH_E1700AC_V2)         += mach-e1700ac-v2.o
 obj-$(CONFIG_ATH79_MACH_E558_V2)               += mach-e558-v2.o
 obj-$(CONFIG_ATH79_MACH_E600G_V2)              += mach-e600g-v2.o
 obj-$(CONFIG_ATH79_MACH_E750A_V4)              += mach-e750a-v4.o
+obj-$(CONFIG_ATH79_MACH_E750G_V8)              += mach-e750g-v8.o
 obj-$(CONFIG_ATH79_MACH_EAP120)                        += mach-eap120.o
 obj-$(CONFIG_ATH79_MACH_EAP300V2)              += mach-eap300v2.o
 obj-$(CONFIG_ATH79_MACH_EAP7660D)              += mach-eap7660d.o
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/mach-e750g-v8.c b/target/linux/ar71xx/files/arch/mips/ath79/mach-e750g-v8.c
new file mode 100644 (file)
index 0000000..72d1349
--- /dev/null
@@ -0,0 +1,151 @@
+/*
+ *  Qxwlan E750G v8 board support
+ *
+ *  Copyright (C) 2017 Peng Zhang <sd20@qxwlan.com>
+ *
+ *  This program is free software; you can redistribute it and/or modify it
+ *  under the terms of the GNU General Public License version 2 as published
+ *  by the Free Software Foundation.
+ */
+
+#include <linux/phy.h>
+#include <linux/platform_device.h>
+#include <linux/ath9k_platform.h>
+#include <linux/ar8216_platform.h>
+
+#include <asm/mach-ath79/ar71xx_regs.h>
+
+#include "common.h"
+#include "pci.h"
+#include "dev-ap9x-pci.h"
+#include "dev-gpio-buttons.h"
+#include "dev-eth.h"
+#include "dev-usb.h"
+#include "dev-leds-gpio.h"
+#include "dev-m25p80.h"
+#include "dev-spi.h"
+#include "dev-wmac.h"
+#include "machtypes.h"
+
+#define E750G_V8_GPIO_LED_SYS  14
+#define E750G_V8_GPIO_LED_DS20 15
+#define E750G_V8_GPIO_LED_DS10 20
+#define E750G_V8_GPIO_LED_WLAN 21
+
+#define E750G_V8_GPIO_BTN_RESET        12
+
+#define E750G_V8_KEYS_POLL_INTERVAL    20      /* msecs */
+#define E750G_V8_KEYS_DEBOUNCE_INTERVAL        (3 * E750G_V8_KEYS_POLL_INTERVAL)
+
+static struct gpio_led e750g_v8_leds_gpio[] __initdata = {
+       {
+               .name           = "e750g-v8:green:system",
+               .gpio           = E750G_V8_GPIO_LED_SYS,
+               .active_low     = 1,
+       },
+       {
+               .name           = "e750g-v8:green:ds10",
+               .gpio           = E750G_V8_GPIO_LED_DS10,
+               .active_low     = 1,
+       },
+       {
+               .name           = "e750g-v8:green:ds20",
+               .gpio           = E750G_V8_GPIO_LED_DS20,
+               .active_low     = 1,
+       },
+       {
+               .name           = "e750g-v8:green:wlan",
+               .gpio           = E750G_V8_GPIO_LED_WLAN,
+               .active_low     = 1,
+       },
+};
+
+static struct gpio_keys_button e750g_v8_gpio_keys[] __initdata = {
+       {
+               .desc           = "reset",
+               .type           = EV_KEY,
+               .code           = KEY_RESTART,
+               .debounce_interval = E750G_V8_KEYS_DEBOUNCE_INTERVAL,
+               .gpio           = E750G_V8_GPIO_BTN_RESET,
+               .active_low     = 1,
+       },
+};
+
+static const struct ar8327_led_info e750g_v8_leds_qca8334[] = {
+       AR8327_LED_INFO(PHY1_0, HW, "e750g-v8:green:lan"),
+       AR8327_LED_INFO(PHY2_0, HW, "e750g-v8:green:wan"),
+};
+
+static struct ar8327_pad_cfg e750g_v8_ar8327_pad0_cfg = {
+       .mode = AR8327_PAD_MAC_RGMII,
+       .txclk_delay_en = true,
+       .rxclk_delay_en = true,
+       .txclk_delay_sel = AR8327_CLK_DELAY_SEL1,
+       .rxclk_delay_sel = AR8327_CLK_DELAY_SEL2,
+       .mac06_exchange_dis = true,
+};
+
+static struct ar8327_led_cfg e750g_v8_ar8327_led_cfg = {
+       .led_ctrl0 = 0x00000000,
+       .led_ctrl1 = 0xc737c737,
+       .led_ctrl2 = 0x00000000,
+       .led_ctrl3 = 0x00c30c00,
+       .open_drain = true,
+};
+
+static struct ar8327_platform_data e750g_v8_ar8327_data = {
+       .pad0_cfg = &e750g_v8_ar8327_pad0_cfg,
+       .port0_cfg = {
+               .force_link = 1,
+               .speed = AR8327_PORT_SPEED_1000,
+               .duplex = 1,
+               .txpause = 1,
+               .rxpause = 1,
+       },
+       .led_cfg = &e750g_v8_ar8327_led_cfg,
+       .leds = e750g_v8_leds_qca8334,
+       .num_leds = ARRAY_SIZE(e750g_v8_leds_qca8334),
+};
+
+static struct mdio_board_info e750g_v8_mdio0_info[] = {
+       {
+               .bus_id = "ag71xx-mdio.0",
+               .phy_addr = 0,
+               .platform_data = &e750g_v8_ar8327_data,
+       },
+};
+
+static void __init e750g_v8_setup(void)
+{
+       u8 *mac = (u8 *) KSEG1ADDR(0x1f050400);
+       u8 *art = (u8 *) KSEG1ADDR(0x1f061000);
+
+       ath79_register_m25p80(NULL);
+       ath79_register_leds_gpio(-1, ARRAY_SIZE(e750g_v8_leds_gpio),
+                                e750g_v8_leds_gpio);
+       ath79_register_gpio_keys_polled(-1, E750G_V8_KEYS_POLL_INTERVAL,
+                                       ARRAY_SIZE(e750g_v8_gpio_keys),
+                                       e750g_v8_gpio_keys);
+
+       mdiobus_register_board_info(e750g_v8_mdio0_info,
+                                       ARRAY_SIZE(e750g_v8_mdio0_info));
+
+       ath79_register_mdio(0, 0x0);
+       ath79_setup_ar934x_eth_cfg(AR934X_ETH_CFG_RGMII_GMAC0 |
+                                  AR934X_ETH_CFG_SW_ONLY_MODE);
+
+       /* GMAC0 is connected to an AR8327 switch */
+       ath79_eth0_data.phy_if_mode = PHY_INTERFACE_MODE_RGMII;
+       ath79_eth0_data.phy_mask = BIT(0);
+       ath79_eth0_data.mii_bus_dev = &ath79_mdio0_device.dev;
+       ath79_eth0_pll_data.pll_1000 = 0x06000000;
+       ath79_init_mac(ath79_eth0_data.mac_addr, mac, 0);
+       ath79_register_eth(0);
+
+       ath79_register_pci();
+       ath79_register_usb();
+       ath79_register_wmac(art, NULL);
+}
+
+MIPS_MACHINE(ATH79_MACH_E750G_V8, "E750G-V8", "Qxwlan E750G v8",
+               e750g_v8_setup);
index d304b9eb80b2f4c97c91732a583b1710202e8efa..8328a6febc9c4245f53b59c601d9cae463547d2a 100644 (file)
@@ -109,6 +109,7 @@ enum ath79_mach_type {
        ATH79_MACH_E600G_V2,                    /* Qxwlan E600G v2 */
        ATH79_MACH_E600GAC_V2,                  /* Qxwlan E600GAC v2 */
        ATH79_MACH_E750A_V4,                    /* Qxwlan E750A v4 */
+       ATH79_MACH_E750G_V8,                    /* Qxwlan E750G v8 */
        ATH79_MACH_EAP120,                      /* TP-LINK EAP120 */
        ATH79_MACH_EAP300V2,                    /* EnGenius EAP300 v2 */
        ATH79_MACH_EAP7660D,                    /* Senao EAP7660D */
index 9559794d1d0ace8a62656b9f17ab2855e4e29256..89024c1c743e7ff871587f462ae8e1a6b95b72ba 100644 (file)
@@ -76,6 +76,7 @@ CONFIG_ATH79_MACH_E2100L=y
 CONFIG_ATH79_MACH_E558_V2=y
 CONFIG_ATH79_MACH_E600G_V2=y
 CONFIG_ATH79_MACH_E750A_V4=y
+CONFIG_ATH79_MACH_E750G_V8=y
 CONFIG_ATH79_MACH_EAP120=y
 CONFIG_ATH79_MACH_EAP300V2=y
 CONFIG_ATH79_MACH_EAP7660D=y
index d9da3be78279dd3564f921a15d9315ee85108c80..2a9c42f9996cb8c6ea1300441d55fa922f680491 100644 (file)
@@ -403,6 +403,25 @@ define Device/e750a-v4-8M
 endef
 TARGET_DEVICES += e750a-v4-8M
 
+define Device/e750g-v8-16M
+  DEVICE_TITLE := Qxwlan E750G v8 (16MB flash)
+  DEVICE_PACKAGES := kmod-usb-core kmod-usb2 -swconfig
+  BOARDNAME := E750G-V8
+  SUPPORTED_DEVICES := e750g-v8
+  IMAGE_SIZE := 15936k
+  MTDPARTS := spi0.0:256k(u-boot)ro,64k(u-boot-env),64k(pri-data)ro,64k(art),-(firmware)
+  IMAGE/sysupgrade.bin := append-kernel | pad-to $$$$(BLOCKSIZE) |\
+       append-rootfs | pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
+endef
+TARGET_DEVICES += e750g-v8-16M
+
+define Device/e750g-v8-8M
+  $(Device/e750g-v8-16M)
+  DEVICE_TITLE := Qxwlan E750G v8 (8MB flash)
+  IMAGE_SIZE := 7744k
+endef
+TARGET_DEVICES += e750g-v8-8M
+
 define Device/ew-balin
   DEVICE_TITLE := Embedded Wireless Balin Platform
   DEVICE_PACKAGES := kmod-usb-core kmod-usb-chipidea