kernel: let kmod-rtl8366-smi conditionally depend on kmod-of-mdio
authorJo-Philipp Wich <jo@mein.io>
Sun, 13 May 2018 16:21:59 +0000 (18:21 +0200)
committerJo-Philipp Wich <jo@mein.io>
Sun, 13 May 2018 16:24:38 +0000 (18:24 +0200)
We cannot depend on CONFIG_OF in the module definition context as this symbol
is not defined for OpenWrt menuconfig. Depend on the targets that appear to
need the kmod-of-mdio module instead.

The target dependency list may not be complete, it is based on the build
failures encountered by the build bots.

Fixes: dc629d9cf5 ("kernel: fix kmod-switch-rtl8366-smi dependency")
Signed-off-by: Jo-Philipp Wich <jo@mein.io>
package/kernel/linux/modules/netdevices.mk

index f5e6d3d6f02cbca2fe7efb8f31e0c90c92a5b5be..0da8bcdf5679c1805fbc131e0349836eec099224 100644 (file)
@@ -209,7 +209,7 @@ $(eval $(call KernelPackage,switch-ip17xx))
 define KernelPackage/switch-rtl8366-smi
   SUBMENU:=$(NETWORK_DEVICES_MENU)
   TITLE:=Realtek RTL8366 SMI switch interface support
-  DEPENDS:=@GPIO_SUPPORT +kmod-swconfig +CONFIG_OF:kmod-of-mdio
+  DEPENDS:=@GPIO_SUPPORT +kmod-swconfig +(TARGET_armvirt||TARGET_brcm2708_bcm2708):kmod-of-mdio
   KCONFIG:=CONFIG_RTL8366_SMI
   FILES:=$(LINUX_DIR)/drivers/net/phy/rtl8366_smi.ko
   AUTOLOAD:=$(call AutoLoad,42,rtl8366_smi)