tools: make all tools depend on xz
authorJo-Philipp Wich <jo@mein.io>
Thu, 6 Oct 2016 11:15:14 +0000 (13:15 +0200)
committerJo-Philipp Wich <jo@mein.io>
Thu, 6 Oct 2016 12:12:46 +0000 (14:12 +0200)
Make all tools except tar (which is required to bootstrap xz-utils) and XZ
itself depend on XZ, in order to be able to handle .tar.xz downloads.

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
tools/Makefile

index 1708c9a5b0d5b05d86092d6e6b142036dc09ea74..186c6c4645b4bd1d4d10641adbb9429a343b6d5c 100644 (file)
@@ -97,6 +97,9 @@ endif
 # dependency for tools which have patches directory
 $(foreach tool, $(tools-y), $(if $(wildcard $(curdir)/$(tool)/patches),$(eval $(curdir)/$(tool)/compile += $(curdir)/patch/install)))
 
+# make any tool (except xz itself) depend on XZ to ensure that *.tar.xz source archives can be unpacked
+$(foreach tool, $(filter-out xz,$(tools-y)), $(eval $(curdir)/$(tool)/compile += $(curdir)/xz/install))
+
 $(foreach tool, $(tools-y), $(eval $(curdir)/$(tool)/compile += $(curdir)/tar/install))
 tools-y += tar