map: shorten autogenerated sub-interface names to account for limits
authorSteven Barth <cyrus@openwrt.org>
Thu, 30 Apr 2015 12:43:46 +0000 (12:43 +0000)
committerSteven Barth <cyrus@openwrt.org>
Thu, 30 Apr 2015 12:43:46 +0000 (12:43 +0000)
Signed-off-by: Steven Barth <steven@midlink.org>
SVN-Revision: 45590

package/network/ipv6/map/Makefile
package/network/ipv6/map/files/map.sh

index ed358defacc96c9d6ca2abcfd9ef62afcafc9422..2a029f8fe8cbd021665054dc9347c665787411db 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=map
 PKG_VERSION:=3
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 PKG_LICENSE:=GPL-2.0
 
 include $(INCLUDE_DIR)/package.mk
index 10789f07ca30d229b4387c79515929d19e11d675..5e37aa25b30cec4108542948d8c707bce5b8adf5 100755 (executable)
@@ -176,7 +176,7 @@ proto_map_setup() {
 
        if [ "$type" = "lw4o6" -o "$type" = "map-e" ]; then
                json_init
-               json_add_string name "${cfg}_local"
+               json_add_string name "${cfg}_"
                json_add_string ifname "@$(eval "echo \$RULE_${k}_PD6IFACE")"
                json_add_string proto "static"
                json_add_array ip6addr
@@ -189,7 +189,7 @@ proto_map_setup() {
 
 proto_map_teardown() {
        local cfg="$1"
-       ifdown "${cfg}_local"
+       ifdown "${cfg}_"
        rm -f /tmp/map-$cfg.rules
 }