ar71xx: add support for the TP-LINK TL-MR3220 v1 board
authorGabor Juhos <juhosg@openwrt.org>
Fri, 10 Dec 2010 17:57:48 +0000 (17:57 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Fri, 10 Dec 2010 17:57:48 +0000 (17:57 +0000)
SVN-Revision: 24439

14 files changed:
target/linux/ar71xx/base-files/etc/defconfig/tl-mr3220/network [new file with mode: 0644]
target/linux/ar71xx/base-files/etc/diag.sh
target/linux/ar71xx/base-files/lib/ar71xx.sh
target/linux/ar71xx/base-files/lib/upgrade/platform.sh
target/linux/ar71xx/config-2.6.32
target/linux/ar71xx/config-2.6.36
target/linux/ar71xx/config-2.6.37
target/linux/ar71xx/files/arch/mips/ar71xx/Kconfig
target/linux/ar71xx/files/arch/mips/ar71xx/Makefile
target/linux/ar71xx/files/arch/mips/ar71xx/mach-tl-mr3420.c [deleted file]
target/linux/ar71xx/files/arch/mips/ar71xx/mach-tl-mr3x20.c [new file with mode: 0644]
target/linux/ar71xx/files/arch/mips/ar71xx/machtype.h
target/linux/ar71xx/generic/profiles/tp-link.mk
target/linux/ar71xx/image/Makefile

diff --git a/target/linux/ar71xx/base-files/etc/defconfig/tl-mr3220/network b/target/linux/ar71xx/base-files/etc/defconfig/tl-mr3220/network
new file mode 100644 (file)
index 0000000..de201bf
--- /dev/null
@@ -0,0 +1,24 @@
+config interface loopback
+       option ifname   lo
+       option proto    static
+       option ipaddr   127.0.0.1
+       option netmask  255.0.0.0
+
+config interface lan
+       option ifname   eth0
+       option type     bridge
+       option proto    static
+       option ipaddr   192.168.1.1
+       option netmask  255.255.255.0
+
+config interface wan
+       option ifname   eth1
+       option proto    dhcp
+
+config switch eth0
+       option enable_vlan      1
+
+config switch_vlan
+       option device   eth0
+       option vlan     1
+       option ports    "0 1 2 3 4"
index a89ede94932986feaf96a1b341c307c724dccaac..7abedc0a2ffe9e668becd9198b49bf9031e01e24 100755 (executable)
@@ -81,8 +81,8 @@ get_status_led() {
        tew-632brp)
                status_led="tew-632brp:green:status"
                ;;
-       tl-mr3420)
-               status_led="tl-mr3420:green:system"
+       tl-mr3220 | tl-mr3420)
+               status_led="tl-mr3x20:green:system"
                ;;
        tl-wa901nd)
                status_led="tl-wa901nd:green:system"
index ec3aa5b62abdf8da17b1beaf7148e7ef70259475..ae50a23c52df633cbf1387ca19573824ee8413f4 100755 (executable)
@@ -100,6 +100,9 @@ ar71xx_board_name() {
        *"DIR-615 rev. C1")
                name="dir-615-c1"
                ;;
+       *TL-MR3220)
+               name="tl-mr3220"
+               ;;
        *TL-MR3420)
                name="tl-mr3420"
                ;;
index 36e2b2146f526eb990ba02c06f092633bcbf71b4..1cbde8bc66872b608d748aee4f9019a926e3fd8a 100755 (executable)
@@ -75,7 +75,7 @@ platform_check_image() {
                }
                return 0
                ;;
-       tl-mr3420 | tl-wa901nd | tl-wr741nd | tl-wr841n-v1 | tl-wr941nd | tl-wr1043nd)
+       tl-mr3220 | tl-mr3420 | tl-wa901nd | tl-wr741nd | tl-wr841n-v1 | tl-wr941nd | tl-wr1043nd)
                [ "$magic" != "0100" ] && {
                        echo "Invalid image type."
                        return 1
index 5d21acfaac07e93a92a84adbbd42d638275445c3..559c800221c05962728c32fd821235555e4aaa7f 100644 (file)
@@ -34,7 +34,7 @@ CONFIG_AR71XX_MACH_PB92=y
 CONFIG_AR71XX_MACH_RB4XX=y
 CONFIG_AR71XX_MACH_RB750=y
 CONFIG_AR71XX_MACH_TEW_632BRP=y
-CONFIG_AR71XX_MACH_TL_MR3420=y
+CONFIG_AR71XX_MACH_TL_MR3X20=y
 CONFIG_AR71XX_MACH_TL_WA901ND=y
 CONFIG_AR71XX_MACH_TL_WR1043ND=y
 CONFIG_AR71XX_MACH_TL_WR741ND=y
index b2c3cd7b3bfb6fc6bc00dd34c4200dd86661053b..108855f14c7036b49d56b9fbc2df4e23c62a42f9 100644 (file)
@@ -30,7 +30,7 @@ CONFIG_AR71XX_MACH_PB92=y
 CONFIG_AR71XX_MACH_RB4XX=y
 CONFIG_AR71XX_MACH_RB750=y
 CONFIG_AR71XX_MACH_TEW_632BRP=y
-CONFIG_AR71XX_MACH_TL_MR3420=y
+CONFIG_AR71XX_MACH_TL_MR3X20=y
 CONFIG_AR71XX_MACH_TL_WA901ND=y
 CONFIG_AR71XX_MACH_TL_WR1043ND=y
 CONFIG_AR71XX_MACH_TL_WR741ND=y
index b2c3cd7b3bfb6fc6bc00dd34c4200dd86661053b..108855f14c7036b49d56b9fbc2df4e23c62a42f9 100644 (file)
@@ -30,7 +30,7 @@ CONFIG_AR71XX_MACH_PB92=y
 CONFIG_AR71XX_MACH_RB4XX=y
 CONFIG_AR71XX_MACH_RB750=y
 CONFIG_AR71XX_MACH_TEW_632BRP=y
-CONFIG_AR71XX_MACH_TL_MR3420=y
+CONFIG_AR71XX_MACH_TL_MR3X20=y
 CONFIG_AR71XX_MACH_TL_WA901ND=y
 CONFIG_AR71XX_MACH_TL_WR1043ND=y
 CONFIG_AR71XX_MACH_TL_WR741ND=y
index 87c59046cc72926052afd20a71c3b6aae7082f35..3524dfe6b82707c40f978e99a89c9c7aeedb98af 100644 (file)
@@ -183,8 +183,8 @@ config AR71XX_MACH_NBG460N
        select AR71XX_DEV_LEDS_GPIO
        default n
 
-config AR71XX_MACH_TL_MR3420
-       bool "TP-LINK TL-MR3420 support"
+config AR71XX_MACH_TL_MR3X20
+       bool "TP-LINK TL-MR3220/3420 support"
        select AR71XX_DEV_M25P80
        select AR71XX_DEV_AP91_PCI if PCI
        select AR71XX_DEV_GPIO_BUTTONS
index f6ceb0a98f581ebae60e79bc6ae2e5e177c9323f..b5b971a7811c29c0753b62f43e0b7292cdeb9344 100644 (file)
@@ -45,7 +45,7 @@ obj-$(CONFIG_AR71XX_MACH_PB92)                += mach-pb92.o
 obj-$(CONFIG_AR71XX_MACH_RB4XX)                += mach-rb4xx.o
 obj-$(CONFIG_AR71XX_MACH_RB750)                += mach-rb750.o
 obj-$(CONFIG_AR71XX_MACH_TEW_632BRP)   += mach-tew-632brp.o
-obj-$(CONFIG_AR71XX_MACH_TL_MR3420)    += mach-tl-mr3420.o
+obj-$(CONFIG_AR71XX_MACH_TL_MR3X20)    += mach-tl-mr3x20.o
 obj-$(CONFIG_AR71XX_MACH_TL_WA901ND)   += mach-tl-wa901nd.o
 obj-$(CONFIG_AR71XX_MACH_TL_WR741ND)   += mach-tl-wr741nd.o
 obj-$(CONFIG_AR71XX_MACH_TL_WR841N_V1) += mach-tl-wr841n.o
diff --git a/target/linux/ar71xx/files/arch/mips/ar71xx/mach-tl-mr3420.c b/target/linux/ar71xx/files/arch/mips/ar71xx/mach-tl-mr3420.c
deleted file mode 100644 (file)
index c1888ca..0000000
+++ /dev/null
@@ -1,148 +0,0 @@
-/*
- *  TP-LINK TL-MR3420 board support
- *
- *  Copyright (C) 2010 Gabor Juhos <juhosg@openwrt.org>
- *
- *  This program is free software; you can redistribute it and/or modify it
- *  under the terms of the GNU General Public License version 2 as published
- *  by the Free Software Foundation.
- */
-
-#include <linux/gpio.h>
-#include <linux/mtd/mtd.h>
-#include <linux/mtd/partitions.h>
-
-#include <asm/mach-ar71xx/ar71xx.h>
-
-#include "machtype.h"
-#include "devices.h"
-#include "dev-m25p80.h"
-#include "dev-ap91-pci.h"
-#include "dev-gpio-buttons.h"
-#include "dev-leds-gpio.h"
-#include "dev-usb.h"
-
-#define TL_MR3420_GPIO_LED_QSS         0
-#define TL_MR3420_GPIO_LED_SYSTEM      1
-#define TL_MR3420_GPIO_LED_3G          8
-
-#define TL_MR3420_GPIO_BTN_RESET       11
-#define TL_MR3420_GPIO_BTN_QSS         12
-
-#define TL_MR3420_GPIO_USB_POWER       6
-
-#define TL_MR3420_BUTTONS_POLL_INTERVAL        20
-
-#ifdef CONFIG_MTD_PARTITIONS
-static struct mtd_partition tl_mr3420_partitions[] = {
-       {
-               .name           = "u-boot",
-               .offset         = 0,
-               .size           = 0x020000,
-               .mask_flags     = MTD_WRITEABLE,
-       }, {
-               .name           = "kernel",
-               .offset         = 0x020000,
-               .size           = 0x140000,
-       }, {
-               .name           = "rootfs",
-               .offset         = 0x160000,
-               .size           = 0x290000,
-       }, {
-               .name           = "art",
-               .offset         = 0x3f0000,
-               .size           = 0x010000,
-               .mask_flags     = MTD_WRITEABLE,
-       }, {
-               .name           = "firmware",
-               .offset         = 0x020000,
-               .size           = 0x3d0000,
-       }
-};
-#define tl_mr3420_num_partitions       ARRAY_SIZE(tl_mr3420_partitions)
-#else
-#define tl_mr3420_partitions           NULL
-#define tl_mr3420_num_partitions       0
-#endif /* CONFIG_MTD_PARTITIONS */
-
-static struct flash_platform_data tl_mr3420_flash_data = {
-       .parts          = tl_mr3420_partitions,
-       .nr_parts       = tl_mr3420_num_partitions,
-};
-
-static struct gpio_led tl_mr3420_leds_gpio[] __initdata = {
-       {
-               .name           = "tl-mr3420:green:system",
-               .gpio           = TL_MR3420_GPIO_LED_SYSTEM,
-               .active_low     = 1,
-       }, {
-               .name           = "tl-mr3420:green:qss",
-               .gpio           = TL_MR3420_GPIO_LED_QSS,
-               .active_low     = 1,
-       }, {
-               .name           = "tl-mr3420:green:3g",
-               .gpio           = TL_MR3420_GPIO_LED_3G,
-               .active_low     = 1,
-       }
-};
-
-static struct gpio_button tl_mr3420_gpio_buttons[] __initdata = {
-       {
-               .desc           = "reset",
-               .type           = EV_KEY,
-               .code           = KEY_RESTART,
-               .threshold      = 3,
-               .gpio           = TL_MR3420_GPIO_BTN_RESET,
-               .active_low     = 1,
-       }, {
-               .desc           = "qss",
-               .type           = EV_KEY,
-               .code           = KEY_WPS_BUTTON,
-               .threshold      = 3,
-               .gpio           = TL_MR3420_GPIO_BTN_QSS,
-               .active_low     = 1,
-       }
-};
-
-static void __init tl_mr3420_setup(void)
-{
-       u8 *mac = (u8 *) KSEG1ADDR(0x1f01fc00);
-       u8 *ee = (u8 *) KSEG1ADDR(0x1fff1000);
-
-       /* enable power for the USB port */
-       gpio_request(TL_MR3420_GPIO_USB_POWER, "USB power");
-       gpio_direction_output(TL_MR3420_GPIO_USB_POWER, 1);
-
-       ar71xx_add_device_m25p80(&tl_mr3420_flash_data);
-
-       ar71xx_add_device_leds_gpio(-1, ARRAY_SIZE(tl_mr3420_leds_gpio),
-                                       tl_mr3420_leds_gpio);
-
-       ar71xx_add_device_gpio_buttons(-1, TL_MR3420_BUTTONS_POLL_INTERVAL,
-                                       ARRAY_SIZE(tl_mr3420_gpio_buttons),
-                                       tl_mr3420_gpio_buttons);
-
-       ar71xx_eth1_data.has_ar7240_switch = 1;
-       ar71xx_init_mac(ar71xx_eth0_data.mac_addr, mac, 0);
-       ar71xx_init_mac(ar71xx_eth1_data.mac_addr, mac, 1);
-
-       /* WAN port */
-       ar71xx_eth0_data.phy_if_mode = PHY_INTERFACE_MODE_RMII;
-       ar71xx_eth0_data.speed = SPEED_100;
-       ar71xx_eth0_data.duplex = DUPLEX_FULL;
-
-       /* LAN ports */
-       ar71xx_eth1_data.phy_if_mode = PHY_INTERFACE_MODE_RMII;
-       ar71xx_eth1_data.speed = SPEED_1000;
-       ar71xx_eth1_data.duplex = DUPLEX_FULL;
-
-       ar71xx_add_device_mdio(0x0);
-       ar71xx_add_device_eth(1);
-       ar71xx_add_device_eth(0);
-
-       ar71xx_add_device_usb();
-
-       ap91_pci_init(ee, mac);
-}
-MIPS_MACHINE(AR71XX_MACH_TL_MR3420, "TL-MR3420", "TP-LINK TL-MR3420",
-            tl_mr3420_setup);
diff --git a/target/linux/ar71xx/files/arch/mips/ar71xx/mach-tl-mr3x20.c b/target/linux/ar71xx/files/arch/mips/ar71xx/mach-tl-mr3x20.c
new file mode 100644 (file)
index 0000000..db41559
--- /dev/null
@@ -0,0 +1,151 @@
+/*
+ *  TP-LINK TL-MR3220/3420 board support
+ *
+ *  Copyright (C) 2010 Gabor Juhos <juhosg@openwrt.org>
+ *
+ *  This program is free software; you can redistribute it and/or modify it
+ *  under the terms of the GNU General Public License version 2 as published
+ *  by the Free Software Foundation.
+ */
+
+#include <linux/gpio.h>
+#include <linux/mtd/mtd.h>
+#include <linux/mtd/partitions.h>
+
+#include <asm/mach-ar71xx/ar71xx.h>
+
+#include "machtype.h"
+#include "devices.h"
+#include "dev-m25p80.h"
+#include "dev-ap91-pci.h"
+#include "dev-gpio-buttons.h"
+#include "dev-leds-gpio.h"
+#include "dev-usb.h"
+
+#define TL_MR3X20_GPIO_LED_QSS         0
+#define TL_MR3X20_GPIO_LED_SYSTEM      1
+#define TL_MR3X20_GPIO_LED_3G          8
+
+#define TL_MR3X20_GPIO_BTN_RESET       11
+#define TL_MR3X20_GPIO_BTN_QSS         12
+
+#define TL_MR3X20_GPIO_USB_POWER       6
+
+#define TL_MR3X20_BUTTONS_POLL_INTERVAL        20
+
+#ifdef CONFIG_MTD_PARTITIONS
+static struct mtd_partition tl_mr3x20_partitions[] = {
+       {
+               .name           = "u-boot",
+               .offset         = 0,
+               .size           = 0x020000,
+               .mask_flags     = MTD_WRITEABLE,
+       }, {
+               .name           = "kernel",
+               .offset         = 0x020000,
+               .size           = 0x140000,
+       }, {
+               .name           = "rootfs",
+               .offset         = 0x160000,
+               .size           = 0x290000,
+       }, {
+               .name           = "art",
+               .offset         = 0x3f0000,
+               .size           = 0x010000,
+               .mask_flags     = MTD_WRITEABLE,
+       }, {
+               .name           = "firmware",
+               .offset         = 0x020000,
+               .size           = 0x3d0000,
+       }
+};
+#define tl_mr3x20_num_partitions       ARRAY_SIZE(tl_mr3x20_partitions)
+#else
+#define tl_mr3x20_partitions           NULL
+#define tl_mr3x20_num_partitions       0
+#endif /* CONFIG_MTD_PARTITIONS */
+
+static struct flash_platform_data tl_mr3x20_flash_data = {
+       .parts          = tl_mr3x20_partitions,
+       .nr_parts       = tl_mr3x20_num_partitions,
+};
+
+static struct gpio_led tl_mr3x20_leds_gpio[] __initdata = {
+       {
+               .name           = "tl-mr3x20:green:system",
+               .gpio           = TL_MR3X20_GPIO_LED_SYSTEM,
+               .active_low     = 1,
+       }, {
+               .name           = "tl-mr3x20:green:qss",
+               .gpio           = TL_MR3X20_GPIO_LED_QSS,
+               .active_low     = 1,
+       }, {
+               .name           = "tl-mr3x20:green:3g",
+               .gpio           = TL_MR3X20_GPIO_LED_3G,
+               .active_low     = 1,
+       }
+};
+
+static struct gpio_button tl_mr3x20_gpio_buttons[] __initdata = {
+       {
+               .desc           = "reset",
+               .type           = EV_KEY,
+               .code           = KEY_RESTART,
+               .threshold      = 3,
+               .gpio           = TL_MR3X20_GPIO_BTN_RESET,
+               .active_low     = 1,
+       }, {
+               .desc           = "qss",
+               .type           = EV_KEY,
+               .code           = KEY_WPS_BUTTON,
+               .threshold      = 3,
+               .gpio           = TL_MR3X20_GPIO_BTN_QSS,
+               .active_low     = 1,
+       }
+};
+
+static void __init tl_mr3x20_setup(void)
+{
+       u8 *mac = (u8 *) KSEG1ADDR(0x1f01fc00);
+       u8 *ee = (u8 *) KSEG1ADDR(0x1fff1000);
+
+       /* enable power for the USB port */
+       gpio_request(TL_MR3X20_GPIO_USB_POWER, "USB power");
+       gpio_direction_output(TL_MR3X20_GPIO_USB_POWER, 1);
+
+       ar71xx_add_device_m25p80(&tl_mr3x20_flash_data);
+
+       ar71xx_add_device_leds_gpio(-1, ARRAY_SIZE(tl_mr3x20_leds_gpio),
+                                       tl_mr3x20_leds_gpio);
+
+       ar71xx_add_device_gpio_buttons(-1, TL_MR3X20_BUTTONS_POLL_INTERVAL,
+                                       ARRAY_SIZE(tl_mr3x20_gpio_buttons),
+                                       tl_mr3x20_gpio_buttons);
+
+       ar71xx_eth1_data.has_ar7240_switch = 1;
+       ar71xx_init_mac(ar71xx_eth0_data.mac_addr, mac, 0);
+       ar71xx_init_mac(ar71xx_eth1_data.mac_addr, mac, 1);
+
+       /* WAN port */
+       ar71xx_eth0_data.phy_if_mode = PHY_INTERFACE_MODE_RMII;
+       ar71xx_eth0_data.speed = SPEED_100;
+       ar71xx_eth0_data.duplex = DUPLEX_FULL;
+
+       /* LAN ports */
+       ar71xx_eth1_data.phy_if_mode = PHY_INTERFACE_MODE_RMII;
+       ar71xx_eth1_data.speed = SPEED_1000;
+       ar71xx_eth1_data.duplex = DUPLEX_FULL;
+
+       ar71xx_add_device_mdio(0x0);
+       ar71xx_add_device_eth(1);
+       ar71xx_add_device_eth(0);
+
+       ar71xx_add_device_usb();
+
+       ap91_pci_init(ee, mac);
+}
+MIPS_MACHINE(AR71XX_MACH_TL_MR3420, "TL-MR3420", "TP-LINK TL-MR3420",
+            tl_mr3x20_setup);
+
+MIPS_MACHINE(AR71XX_MACH_TL_MR3220, "TL-MR3220", "TP-LINK TL-MR3220",
+            tl_mr3x20_setup);
index ec35677be2ebf69b27d73d02a0411796ee109e51..620e0096770f4b3ab3492ac302350be5c1695a91 100644 (file)
@@ -38,6 +38,7 @@ enum ar71xx_mach_type {
        AR71XX_MACH_MZK_W300NH, /* Planex MZK-W300NH */
        AR71XX_MACH_NBG460N,    /* Zyxel NBG460N/550N/550NH */
        AR71XX_MACH_TEW_632BRP, /* TRENDnet TEW-632BRP */
+       AR71XX_MACH_TL_MR3220,  /* TP-LINK TL-MR3220 */
        AR71XX_MACH_TL_MR3420,  /* TP-LINK TL-MR3420 */
        AR71XX_MACH_TL_WA901ND, /* TP-LINK TL-WA901ND */
        AR71XX_MACH_TL_WR741ND, /* TP-LINK TL-WR741ND */
index 890e4b28a857c0765f1ac85b9cc234c4ea27b4a2..a36e1756f6f353267ee087577e7de962cc3ed54a 100644 (file)
@@ -5,6 +5,17 @@
 # See /LICENSE for more information.
 #
 
+define Profile/TLMR3220V1
+       NAME:=TP-LINK TL-MR3220 v1
+       PACKAGES:=kmod-ath9k wpad-mini kmod-usb-core kmod-usb2
+endef
+
+define Profile/TLMR3220V1/Description
+       Package set optimized for the TP-LINK TL-MR3220 v1.
+endef
+
+$(eval $(call Profile,TLMR3220V1))
+
 define Profile/TLMR3420V1
        NAME:=TP-LINK TL-MR3420 v1
        PACKAGES:=kmod-ath9k wpad-mini kmod-usb-core kmod-usb2
index 44c030e4e07c040acfb477d5ee6937ed6e2a6720..66be14b48fdc80cca87f1e4aa576af4f18c16572 100644 (file)
@@ -570,6 +570,10 @@ define Image/Build/Profile/NBG_460N_550N_550NH
        $(call Image/Build/Template/$(fs_64k)/$(1),ZyXEL,nbg460n_550n_550nh,board=NBG460N,NBG-460N)
 endef
 
+define Image/Build/Profile/TLMR3220V1
+       $(call Image/Build/Template/$(fs_4k)/$(1),TPLINK,tl-mr3220-v1,board=TL-MR3220,TL-MR3220v1)
+endef
+
 define Image/Build/Profile/TLMR3420V1
        $(call Image/Build/Template/$(fs_4k)/$(1),TPLINK,tl-mr3420-v1,board=TL-MR3420,TL-MR3420v1)
 endef
@@ -664,6 +668,7 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/PB92,$(1))
        $(call Image/Build/Profile/TEW632BRP,$(1))
        $(call Image/Build/Profile/TEW652BRP,$(1))
+       $(call Image/Build/Profile/TLMR3220V1,$(1))
        $(call Image/Build/Profile/TLMR3420V1,$(1))
        $(call Image/Build/Profile/TLWA901NDV1,$(1))
        $(call Image/Build/Profile/TLWR741NDV1,$(1))