kernel: ifb: set default numifbs to 0
authorKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Wed, 22 Jan 2020 22:03:56 +0000 (22:03 +0000)
committerKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Fri, 13 Mar 2020 09:46:55 +0000 (09:46 +0000)
By default on module load, 2 ifb interfaces are created and typically
remain unused, cluttering 'ip link' outputs and generally confusing
things.  sqm-scripts for example, creates its own ifb interface/s
instead of using these 2 defaults ifbs.

Tell the ifb module to not create any default ifbs on load via the
numifbs parameter.

Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
package/kernel/linux/modules/netdevices.mk

index 5fae027417991bd3fb9184024fdee6dc3172f7ee..4b421233392208c67b031858d3a33d2daedb06bd 100644 (file)
@@ -927,6 +927,7 @@ define KernelPackage/ifb
        CONFIG_NET_CLS=y
   FILES:=$(LINUX_DIR)/drivers/net/ifb.ko
   AUTOLOAD:=$(call AutoLoad,34,ifb)
+  MODPARAMS.ifb:=numifbs=0
 endef
 
 define KernelPackage/ifb/description