perf: prevent build from within the sdk and mark as nonshared
authorFelix Fietkau <nbd@nbd.name>
Sun, 31 Jul 2016 10:15:07 +0000 (12:15 +0200)
committerFelix Fietkau <nbd@nbd.name>
Sun, 31 Jul 2016 10:25:25 +0000 (12:25 +0200)
Signed-off-by: Felix Fietkau <nbd@nbd.name>
package/devel/perf/Makefile

index 0ec2bba3e2d57674398eda6e633dd6c50aba8fbd..8ff9bfa5e2d5a554b007971effb51e20c77ff94c 100644 (file)
@@ -15,6 +15,7 @@ PKG_RELEASE:=2
 PKG_USE_MIPS16:=0
 PKG_BUILD_PARALLEL:=1
 PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
+PKG_FLAGS:=nonshared
 
 # Perf's makefile and headers are not relocatable and must be built from the
 # Linux sources directory
@@ -25,7 +26,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/perf
   SECTION:=devel
   CATEGORY:=Development
-  DEPENDS:= +libelf1 +libdw +libpthread +librt +objdump @!LINUX_3_18
+  DEPENDS:= +libelf1 +libdw +libpthread +librt +objdump @!LINUX_3_18 @!IN_SDK
   TITLE:=Linux performance monitoring tool
   VERSION:=$(LINUX_VERSION)-$(PKG_RELEASE)
   URL:=http://www.kernel.org