brcm63xx: add missing bcm96329bhr profile and dts
authorJonas Gorski <jogo@openwrt.org>
Tue, 21 Apr 2015 16:43:46 +0000 (16:43 +0000)
committerJonas Gorski <jogo@openwrt.org>
Tue, 21 Apr 2015 16:43:46 +0000 (16:43 +0000)
Hopefully the last missing board.

Signed-off-by: Jonas Gorski <jogo@openwrt.org>
SVN-Revision: 45557

17 files changed:
target/linux/brcm63xx/base-files/lib/brcm63xx.sh
target/linux/brcm63xx/dts/bcm963269bhr.dts [new file with mode: 0644]
target/linux/brcm63xx/image/Makefile
target/linux/brcm63xx/patches-3.18/557-board_bcm963269bhr.patch
target/linux/brcm63xx/patches-3.18/558-board_AR1004G.patch
target/linux/brcm63xx/patches-3.18/559-board_vw6339gu.patch
target/linux/brcm63xx/patches-3.18/560-board_963268gu_p300.patch
target/linux/brcm63xx/patches-3.18/561-board_WAP-5813n.patch
target/linux/brcm63xx/patches-3.18/562-board_VR-3025u.patch
target/linux/brcm63xx/patches-3.18/563-board_VR-3025un.patch
target/linux/brcm63xx/patches-3.18/564-board_P870HW-51a_v2.patch
target/linux/brcm63xx/patches-3.18/565-board_hw520.patch
target/linux/brcm63xx/patches-3.18/566-board_A4001N.patch
target/linux/brcm63xx/patches-3.18/567-board_dsl-2751b_e1.patch
target/linux/brcm63xx/patches-3.18/568-board_DGND3700v1_3800B.patch
target/linux/brcm63xx/patches-3.18/569-board_homehub2a.patch
target/linux/brcm63xx/profiles/broadcom.mk

index 13406552c312e703ee02f404caeeaefc98841905..5cb390f061d575e61987285722316237106d89c1 100755 (executable)
@@ -39,6 +39,9 @@ brcm63xx_dt_detect() {
        "Broadcom BCM963268BU_P300 reference board")
                board_name="bcm963268bu_p300"
                ;;
+       "Broadcom BCM963269BHR reference board")
+               board_name="bcm963269bhr"
+               ;;
        "Broadcom bcm963281TAN reference board")
                board_name="bcm963281tan"
                ;;
diff --git a/target/linux/brcm63xx/dts/bcm963269bhr.dts b/target/linux/brcm63xx/dts/bcm963269bhr.dts
new file mode 100644 (file)
index 0000000..84f6554
--- /dev/null
@@ -0,0 +1,36 @@
+/dts-v1/;
+
+/include/ "bcm63268.dtsi"
+
+/ {
+       model = "Broadcom BCM963269BHR reference board";
+       compatible = "brcm,bcm963269bhr", "brcm,bcm63268";
+
+       gpio-keys-polled {
+               compatible = "gpio-keys-polled";
+               #address-cells = <1>;
+               #size-cells = <0>;
+               poll-interval = <20>;
+               debounce-interval = <60>;
+
+               reset {
+                       label = "reset";
+                       gpios = <&gpio1 0 0>;
+                       linux,code = <0x198>;
+               };
+        };
+
+       gpio-leds {
+               compatible = "gpio-leds";
+
+               usb1 {
+                       label = "963629BHR:green:usb1";
+                       gpios = <&gpio0 9 1>;
+               };
+
+               usb12 {
+                       label = "963629BHR:green:usb1";
+                       gpios = <&gpio0 9 1>;
+               };
+       };
+};
index cc9d265945e656ac7854201f77686450b7a66f9e..e98011d56f0c45fbfb55bc417b57325dc32a4cdb 100755 (executable)
@@ -301,6 +301,8 @@ $(eval $(call ImageDTB,Dummy,BCM96318REF,BCM96318REF,bcm96318ref,96318REF,6318))
 $(eval $(call ImageDTB,Dummy,BCM96318REF_P300,BCM96318ref_P300,bcm96318ref_p300,96318REF_P300,6318))
 # Broadcom BCM963268BU_P300
 $(eval $(call ImageDTB,Dummy,BCM963268BU_P300,BCM963268BU_P300,bcm963268bu_p300,963268BU_P300,63268))
+# Broadcom BCM963269BHR
+$(eval $(call ImageDTB,Dummy,BCM963269BHR,BCM963269BHR,bcm963269bhr,963269BHR,63268))
 # BT Home Hub 2.0 A
 $(eval $(call ImageDTB,CFEDTB,BTHOMEHUB2A,HomeHub2A,homehub2a,HOMEHUB2A,6358,--image-offset 0x20000 --block-size 0x20000))
 # BT Voyager V2110, V2110_AA, V2110_ROI
index a2f45290f871bf5f007458a28354a639e672de3c..1dcfea8d6e02f93a8722e635cc4be869a447aa6f 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -1702,6 +1702,75 @@ static struct board_info __initdata boar
+@@ -1702,6 +1702,52 @@ static struct board_info __initdata boar
  #endif /* CONFIG_BCM63XX_CPU_6368 */
  
  /*
 +                      },
 +              },
 +      },
-+
-+      .leds = {
-+              {
-+                      .name           = "963629BHR:green:usb1",
-+                      .gpio           = 9,
-+                      .active_low     = 1,
-+              },
-+              {
-+                      .name           = "963629BHR:green:usb2",
-+                      .gpio           = 10,
-+                      .active_low     = 1,
-+              },
-+      },
-+
-+      .buttons = {
-+              {
-+                      .desc           = "reset",
-+                      .gpio           = 32,
-+                      .type           = EV_KEY,
-+                      .code           = KEY_RESTART,
-+                      .debounce_interval = BCM963XX_KEYS_DEBOUNCE_INTERVAL,
-+              },
-+      },
 +};
 +#endif /* CONFIG_BCM63XX_CPU_63268 */
 +
@@ -76,7 +53,7 @@
   * all boards
   */
  static const struct board_info __initconst *bcm963xx_boards[] = {
-@@ -1782,6 +1851,9 @@ static const struct board_info __initcon
+@@ -1782,6 +1828,9 @@ static const struct board_info __initcon
        &board_96368mvwg,
        &board_96368mvngr,
  #endif
  };
  
  static struct of_device_id const bcm963xx_boards_dt[] = {
+@@ -1869,6 +1918,7 @@ static struct of_device_id const bcm963x
+       { .compatible = "brcm,bcm96368mvwg", .data = &board_96368mvwg, },
+ #endif
+ #ifdef CONFIG_BCM63XX_CPU_63268
++      { .compatible = "brcm,bcm963269bhr", .data = &board_963269bhr, },
+ #endif
+ #endif /* CONFIG_OF */
+       { },
index 2a7bc901d4e4c38a87eac0c69d5c6d1e5d4da086..29d57838dbb49c44598e0aa9ece7981eb66206d6 100644 (file)
@@ -31,7 +31,7 @@ Signed-off-by: Adrian Feliks <mexit@o2.pl>
  
  /* BT Voyager 2110 */
  static struct board_info __initdata board_V2110 = {
-@@ -1822,6 +1838,7 @@ static const struct board_info __initcon
+@@ -1799,6 +1815,7 @@ static const struct board_info __initcon
        &board_96348A_122,
        &board_CPVA502plus,
        &board_96348W3,
@@ -39,7 +39,7 @@ Signed-off-by: Adrian Feliks <mexit@o2.pl>
  #endif
  
  #ifdef CONFIG_BCM63XX_CPU_6358
-@@ -1886,6 +1903,7 @@ static struct of_device_id const bcm963x
+@@ -1863,6 +1880,7 @@ static struct of_device_id const bcm963x
        { .compatible = "dynalink,rta770w", .data = &board_rta770w, },
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6348
index be0e0178806068aa7571ff3b588a59dc6c107374..3a38540666dac1be2d55b80ff5830b992117611c 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -1784,6 +1784,53 @@ static struct board_info __initdata boar
+@@ -1761,6 +1761,53 @@ static struct board_info __initdata boar
                },
        },
  };
@@ -54,7 +54,7 @@
  #endif /* CONFIG_BCM63XX_CPU_63268 */
  
  /*
-@@ -1870,6 +1917,7 @@ static const struct board_info __initcon
+@@ -1847,6 +1894,7 @@ static const struct board_info __initcon
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
        &board_963269bhr,
  #endif
  };
  
-@@ -1959,6 +2007,7 @@ static struct of_device_id const bcm963x
-       { .compatible = "brcm,bcm96368mvwg", .data = &board_96368mvwg, },
+@@ -1937,6 +1985,7 @@ static struct of_device_id const bcm963x
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
+       { .compatible = "brcm,bcm963269bhr", .data = &board_963269bhr, },
 +      { .compatible = "inteno,vg50", .data = &board_vw6339gu, },
  #endif
  #endif /* CONFIG_OF */
index 9c0f7b77d918105563b11088e93b77d08b7bdf44..494328b864fa04f9a2636c32030dc23056b76497 100644 (file)
@@ -67,7 +67,7 @@
  static struct board_info __initdata board_963269bhr = {
        .name                           = "963269BHR",
        .expected_cpu_id                = 0x63268,
-@@ -1916,6 +1976,7 @@ static const struct board_info __initcon
+@@ -1893,6 +1953,7 @@ static const struct board_info __initcon
        &board_96368mvngr,
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
        &board_963269bhr,
        &board_vw6339gu,
  #endif
-@@ -2007,6 +2068,7 @@ static struct of_device_id const bcm963x
+@@ -1984,6 +2045,7 @@ static struct of_device_id const bcm963x
        { .compatible = "brcm,bcm96368mvwg", .data = &board_96368mvwg, },
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
 +      { .compatible = "brcm,bcm963268bu_p300", .data = &board_963268bu_p300, },
+       { .compatible = "brcm,bcm963269bhr", .data = &board_963269bhr, },
        { .compatible = "inteno,vg50", .data = &board_vw6339gu, },
  #endif
- #endif /* CONFIG_OF */
index 2be009166f207b6f3a4ce779dbd2fac37f96af3b..b695b2b44b1fb5cec1d837ff27294e11b3bbafbc 100644 (file)
@@ -76,7 +76,7 @@
  #endif /* CONFIG_BCM63XX_CPU_6368 */
  
  /*
-@@ -1974,6 +2035,7 @@ static const struct board_info __initcon
+@@ -1951,6 +2012,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6368
        &board_96368mvwg,
        &board_96368mvngr,
@@ -84,7 +84,7 @@
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
        &board_963268bu_p300,
-@@ -2066,6 +2128,7 @@ static struct of_device_id const bcm963x
+@@ -2043,6 +2105,7 @@ static struct of_device_id const bcm963x
  #ifdef CONFIG_BCM63XX_CPU_6368
        { .compatible = "brcm,bcm96368mvngr", .data = &board_96368mvngr, },
        { .compatible = "brcm,bcm96368mvwg", .data = &board_96368mvwg, },
index 1d23af14ce55ce3194938a088d1e25f83d1f39a9..13a2dc9e4af376312d9b30d4fce7bdcc05439905 100644 (file)
@@ -61,7 +61,7 @@
  static struct b53_platform_data WAP5813n_b53_pdata = {
        .alias = "eth0",
  };
-@@ -2035,6 +2089,7 @@ static const struct board_info __initcon
+@@ -2012,6 +2066,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6368
        &board_96368mvwg,
        &board_96368mvngr,
@@ -69,7 +69,7 @@
        &board_WAP5813n,
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
-@@ -2128,6 +2183,7 @@ static struct of_device_id const bcm963x
+@@ -2105,6 +2160,7 @@ static struct of_device_id const bcm963x
  #ifdef CONFIG_BCM63XX_CPU_6368
        { .compatible = "brcm,bcm96368mvngr", .data = &board_96368mvngr, },
        { .compatible = "brcm,bcm96368mvwg", .data = &board_96368mvwg, },
index c48ef642d6d7172e15d3400b844ffd95e2e80ee1..f194a889a0f3247fe993b99e9792c1eb7038126b 100644 (file)
@@ -61,7 +61,7 @@
  static struct b53_platform_data WAP5813n_b53_pdata = {
        .alias = "eth0",
  };
-@@ -2090,6 +2144,7 @@ static const struct board_info __initcon
+@@ -2067,6 +2121,7 @@ static const struct board_info __initcon
        &board_96368mvwg,
        &board_96368mvngr,
        &board_VR3025u,
@@ -69,7 +69,7 @@
        &board_WAP5813n,
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
-@@ -2184,6 +2239,7 @@ static struct of_device_id const bcm963x
+@@ -2161,6 +2216,7 @@ static struct of_device_id const bcm963x
        { .compatible = "brcm,bcm96368mvngr", .data = &board_96368mvngr, },
        { .compatible = "brcm,bcm96368mvwg", .data = &board_96368mvwg, },
        { .compatible = "comtrend,vr-3025u", .data = &board_VR3025u, },
index 8ffc8428739aa922dc62c7b23843f171a335d582..8ccba3a62425c147d51aa15994f90dc6502ea08e 100644 (file)
@@ -50,7 +50,7 @@
  static struct board_info __initdata board_VR3025u = {
        .name                                   = "96368M-1541N",
        .expected_cpu_id                = 0x6368,
-@@ -2143,6 +2186,7 @@ static const struct board_info __initcon
+@@ -2120,6 +2163,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6368
        &board_96368mvwg,
        &board_96368mvngr,
@@ -58,7 +58,7 @@
        &board_VR3025u,
        &board_VR3025un,
        &board_WAP5813n,
-@@ -2241,6 +2285,7 @@ static struct of_device_id const bcm963x
+@@ -2218,6 +2262,7 @@ static struct of_device_id const bcm963x
        { .compatible = "comtrend,vr-3025u", .data = &board_VR3025u, },
        { .compatible = "comtrend,vr-3025un", .data = &board_VR3025un, },
        { .compatible = "comtrend,wap-5813n", .data = &board_WAP5813n, },
index a10d33cca3f50f0172db75c7fa064b29cb1f3fb6..8f40612831373b75b7ae29967e09ca3294fdca24 100644 (file)
@@ -38,7 +38,7 @@
  static struct board_info __initdata board_HW553 = {
        .name                           = "HW553",
        .expected_cpu_id                = 0x6358,
-@@ -2170,6 +2201,7 @@ static const struct board_info __initcon
+@@ -2147,6 +2178,7 @@ static const struct board_info __initcon
        &board_nb4_ser_r0,
        &board_nb4_fxc_r1,
        &board_ct6373_1,
@@ -46,7 +46,7 @@
        &board_HW553,
        &board_HW556_A,
        &board_HW556_B,
-@@ -2262,6 +2294,7 @@ static struct of_device_id const bcm963x
+@@ -2239,6 +2271,7 @@ static struct of_device_id const bcm963x
        { .compatible = "d-link,dsl-274xb-c2", .data = &board_dsl_274xb_rev_c, },
        { .compatible = "d-link,dsl-2650u", .data = &board_96358vw2, },
        { .compatible = "d-link,dva-g3810bn/tl", .data = &board_DVAG3810BN, },
index a9385ea1c591572f684efe60ba13163737fd83b5..f8a95e5f3cc09958d5072e92e7c91c6fc46a6305 100644 (file)
@@ -51,7 +51,7 @@
  static struct board_info __initdata board_A4001N1 = {
        .name                                   = "963281T_TEF",
        .expected_cpu_id                        = 0x6328,
-@@ -2152,6 +2196,7 @@ static const struct board_info __initcon
+@@ -2129,6 +2173,7 @@ static const struct board_info __initcon
        &board_AR5381u,
        &board_AR5387un,
        &board_963281TAN,
@@ -59,7 +59,7 @@
        &board_A4001N1,
        &board_dsl_274xb_f1,
        &board_FAST2704V2,
-@@ -2240,6 +2285,7 @@ static struct of_device_id const bcm963x
+@@ -2217,6 +2262,7 @@ static struct of_device_id const bcm963x
        { .compatible = "brcm,bcm96318ref_p300", .data = &board_96318ref_p300, },
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6328
index dc2fcc3481e8383e4c688f27e806481b1811e62d..af22c2bce805e7a33bc03498b1da88baae4259f2 100644 (file)
@@ -76,7 +76,7 @@
  #endif /* CONFIG_BCM63XX_CPU_6318 */
  
  /*
-@@ -2190,6 +2259,7 @@ static const struct board_info __initcon
+@@ -2167,6 +2236,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6318
        &board_96318ref,
        &board_96318ref_p300,
@@ -84,7 +84,7 @@
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6328
        &board_96328avng,
-@@ -2283,6 +2353,7 @@ static struct of_device_id const bcm963x
+@@ -2260,6 +2330,7 @@ static struct of_device_id const bcm963x
  #ifdef CONFIG_BCM63XX_CPU_6318
        { .compatible = "brcm,bcm96318ref", .data = &board_96318ref, },
        { .compatible = "brcm,bcm96318ref_p300", .data = &board_96318ref_p300, },
index 250359b0174289132263ba6c7efffd336cc88044..97e65d3be906baafc4acc0fedcd8a2b1c93585ac 100644 (file)
@@ -49,7 +49,7 @@
  static struct sprom_fixup __initdata vr3025u_fixups[] = {
        { .offset = 97, .value = 0xfeb3 },
        { .offset = 98, .value = 0x1618 },
-@@ -2333,6 +2375,7 @@ static const struct board_info __initcon
+@@ -2310,6 +2352,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6368
        &board_96368mvwg,
        &board_96368mvngr,
@@ -57,7 +57,7 @@
        &board_P870HW51A_V2,
        &board_VR3025u,
        &board_VR3025un,
-@@ -2435,6 +2478,7 @@ static struct of_device_id const bcm963x
+@@ -2412,6 +2455,7 @@ static struct of_device_id const bcm963x
        { .compatible = "comtrend,vr-3025u", .data = &board_VR3025u, },
        { .compatible = "comtrend,vr-3025un", .data = &board_VR3025un, },
        { .compatible = "comtrend,wap-5813n", .data = &board_WAP5813n, },
index 83f3b53fba57e9e26c0c5119933b9f47ed11aa2d..e7678a95ae1959a3ca41143cad598e8857ec2853 100644 (file)
@@ -33,7 +33,7 @@
  static struct board_info __initdata board_HW520 = {
        .name                           = "HW6358GW_B",
        .expected_cpu_id                = 0x6358,
-@@ -2358,6 +2384,7 @@ static const struct board_info __initcon
+@@ -2335,6 +2361,7 @@ static const struct board_info __initcon
        &board_nb4_ser_r0,
        &board_nb4_fxc_r1,
        &board_ct6373_1,
@@ -41,7 +41,7 @@
        &board_HW520,
        &board_HW553,
        &board_HW556_A,
-@@ -2467,6 +2494,7 @@ static struct of_device_id const bcm963x
+@@ -2444,6 +2471,7 @@ static struct of_device_id const bcm963x
        { .compatible = "sfr,nb4-fxc-r1", .data = &board_nb4_fxc_r1, },
        { .compatible = "t-com,spw303v", .data = &board_spw303v, },
        { .compatible = "telsey,cpva642", .data = &board_CPVA642, },
index 8a06a2db0b731dace8df322d35cff861e8a64ea4..520a676184f60845749e56c7f77bf95763e64c8f 100644 (file)
@@ -28,6 +28,15 @@ define Profile/BCM963268BU_P300
   PACKAGES:= kmod-usb-ohci kmod-usb2 kmod-bcm63xx-udc
 endef
 define Profile/BCM963268BU_P300/Description
-  Package set optimized for the Broadcom BCM963268BU_P300 reference boar.
+  Package set optimized for the Broadcom BCM963268BU_P300 reference board.
 endef
 $(eval $(call Profile,BCM963268BU_P300))
+
+define Profile/BCM963269BHR
+  NAME:=Broadcom BCM963269BHR reference board
+  PACKAGES:= kmod-usb-ohci kmod-usb2 kmod-bcm63xx-udc
+endef
+define Profile/BCM963269BHR/Description
+  Package set optimized for the Broadcom BCM963269BHR reference board.
+endef
+$(eval $(call Profile,BCM963269BHR))