upgrade Linaro GCC 4.8 to 2014.01
authorImre Kaloz <kaloz@openwrt.org>
Thu, 6 Feb 2014 10:28:45 +0000 (10:28 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Thu, 6 Feb 2014 10:28:45 +0000 (10:28 +0000)
Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
SVN-Revision: 39501

toolchain/gcc/common.mk
toolchain/gcc/patches/4.8-linaro/910-mbsd_multi.patch
toolchain/gcc/patches/4.8-linaro/920-specs_nonfatal_getenv.patch

index ec324ea159e9f6b9671190cb73cc381f5925e4df..446e9934bc11401700547419543a7141e8f2b258 100644 (file)
@@ -2,7 +2,7 @@
 # Copyright (C) 2002-2003 Erik Andersen <andersen@uclibc.org>
 # Copyright (C) 2004 Manuel Novoa III <mjn3@uclibc.org>
 # Copyright (C) 2005-2006 Felix Fietkau <nbd@openwrt.org>
-# Copyright (C) 2006-2013 OpenWrt.org
+# Copyright (C) 2006-2014 OpenWrt.org
 #
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
@@ -34,10 +34,10 @@ ifeq ($(findstring linaro, $(CONFIG_GCC_VERSION)),linaro)
       PKG_COMP:=bz2
     endif
     ifeq ($(CONFIG_GCC_VERSION),"4.8-linaro")
-      PKG_REV:=4.8-2013.12
+      PKG_REV:=4.8-2014.01
       PKG_VERSION:=4.8.3
       PKG_VERSION_MAJOR:=4.8
-      PKG_MD5SUM:=bd7a22ff4d1b6bb4824ef908e07bde66
+      PKG_MD5SUM:=b8bc08b05ff079dcdc020336a67ca4e1
       PKG_COMP:=xz
     endif
     PKG_SOURCE_URL:=http://launchpad.net/gcc-linaro/$(PKG_VERSION_MAJOR)/$(PKG_REV)/+download/
index eb9a7c6c750459623943390e3ef566ac6850c6cb..645dc43c5bd053f90a522f6d703bb444725a3488 100644 (file)
  -Wfatal-errors  -Wfloat-equal  -Wformat  -Wformat=2 @gol
  -Wno-format-contains-nul -Wno-format-extra-args -Wformat-nonliteral @gol
  -Wformat-security  -Wformat-y2k @gol
-@@ -4809,6 +4809,22 @@ This option is only supported for C and
+@@ -4817,6 +4817,22 @@ This option is only supported for C and
  @option{-Wall} and by @option{-Wpedantic}, which can be disabled with
  @option{-Wno-pointer-sign}.
  
  @item -Wstack-protector
  @opindex Wstack-protector
  @opindex Wno-stack-protector
-@@ -6920,7 +6936,7 @@ so, the first branch is redirected to ei
+@@ -6928,7 +6944,7 @@ so, the first branch is redirected to ei
  second branch or a point immediately following it, depending on whether
  the condition is known to be true or false.
  
index 8698eda5f2ea09071dd875e7b16084dedd615b13..09768f525bc885eb243b0a05b710c82e282c199b 100644 (file)
@@ -1,6 +1,6 @@
 --- a/gcc/gcc.c
 +++ b/gcc/gcc.c
-@@ -8004,7 +8004,10 @@ getenv_spec_function (int argc, const ch
+@@ -8029,7 +8029,10 @@ getenv_spec_function (int argc, const ch
  
    value = getenv (argv[0]);
    if (!value)