upgrade kernel versions to the latest stable ones
authorImre Kaloz <kaloz@openwrt.org>
Mon, 4 Oct 2010 10:40:41 +0000 (10:40 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Mon, 4 Oct 2010 10:40:41 +0000 (10:40 +0000)
SVN-Revision: 23219

26 files changed:
include/kernel-version.mk
target/linux/adm5120/Makefile
target/linux/ar7/Makefile
target/linux/ar71xx/Makefile
target/linux/at91/Makefile
target/linux/atheros/Makefile
target/linux/au1000/Makefile
target/linux/avr32/Makefile
target/linux/brcm47xx/Makefile
target/linux/cobalt/Makefile
target/linux/etrax/Makefile
target/linux/gemini/Makefile
target/linux/imx21/Makefile
target/linux/iop32x/Makefile
target/linux/ixp4xx/Makefile
target/linux/omap35xx/Makefile
target/linux/orion/Makefile
target/linux/ppc40x/Makefile
target/linux/ppc44x/Makefile
target/linux/pxa/Makefile
target/linux/ramips/Makefile
target/linux/rb532/Makefile
target/linux/rdc/Makefile
target/linux/sibyte/Makefile
target/linux/uml/Makefile
target/linux/x86/Makefile

index ed68cfdfb86fef8d17df774aa925841c3e66fd6d..ad8a0137e4ae9da615c051df527150ec9f0d9015 100644 (file)
@@ -11,14 +11,14 @@ endif
 ifeq ($(LINUX_VERSION),2.6.31.14)
   LINUX_KERNEL_MD5SUM:=3e7feb224197d8e174a90dd3759979fd
 endif
-ifeq ($(LINUX_VERSION),2.6.32.20)
-  LINUX_KERNEL_MD5SUM:=c254831e3f59b9fef14e61871e5f4738
+ifeq ($(LINUX_VERSION),2.6.32.24)
+  LINUX_KERNEL_MD5SUM:=bcd2f2b3d6974a9232b9becee8196634
 endif
 ifeq ($(LINUX_VERSION),2.6.33.7)
   LINUX_KERNEL_MD5SUM:=2cea51deeaa0620a07d005ec3b148f06
 endif
-ifeq ($(LINUX_VERSION),2.6.34.5)
-  LINUX_KERNEL_MD5SUM:=d280b596b32f7497bbe9dd54669c99d6
+ifeq ($(LINUX_VERSION),2.6.34.7)
+  LINUX_KERNEL_MD5SUM:=8964e26120e84844998a673464a980ea
 endif
 ifeq ($(LINUX_VERSION),2.6.35.7)
   LINUX_KERNEL_MD5SUM:=f741879bcd3a5366a1bbe0ad5cdb7935
index 4a7e111858527cd54fd291bb8a155cbcaa9c7d3c..f7ca62225d27f9436f2eeb5bf1cd0f2563c6adbe 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 BOARD:=adm5120
 BOARDNAME:=Infineon/ADMtek ADM5120
-LINUX_VERSION:=2.6.32.20
+LINUX_VERSION:=2.6.32.24
 SUBTARGETS:=router_le router_be
 INITRAMFS_EXTRA_FILES:=
 
index facd3ba98680b5461f5dc8f6c8e0e217892646d8..9ecac5a8eb34db68ecef171bc082fa757e1d918f 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=ar7
 BOARDNAME:=TI AR7
 FEATURES:=squashfs jffs2 atm
 
-LINUX_VERSION:=2.6.32.20
+LINUX_VERSION:=2.6.32.24
 
 include $(INCLUDE_DIR)/target.mk
 
index f14019fb268fa07b25194ca2a26355d6bace3e6e..8eecd94d723482c6fafb152c2c2c368b1ed0acba 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs jffs2 targz
 CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
 SUBTARGETS:=generic nand
 
-LINUX_VERSION:=2.6.32.20
+LINUX_VERSION:=2.6.32.24
 
 include $(INCLUDE_DIR)/target.mk
 
index 074a68f9e5cb4c46ce6d1acf7fb761117088bd2f..446de340555899dd6fbcf8402b5376e50a78a768 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Atmel AT91
 FEATURES:=squashfs jffs2 targz
 CFLAGS:=-Os -pipe -march=armv5te -mtune=arm926ej-s -funit-at-a-time
 
-LINUX_VERSION:=2.6.34.5
+LINUX_VERSION:=2.6.34.7
 DEVICE_TYPE=
 
 include $(INCLUDE_DIR)/target.mk
index d8786ed8ceeb564535e663bc900b83080b89ce83..67417a091411fce587f4ac450e961ae279a298f7 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=atheros
 BOARDNAME:=Atheros AR231x/AR5312
 FEATURES:=squashfs jffs2
 
-LINUX_VERSION:=2.6.32.20
+LINUX_VERSION:=2.6.32.24
 
 include $(INCLUDE_DIR)/target.mk
 
index b2633bed1ae5f7607cac8f1def393337e230d2d8..87fd74005d53fee6cd192600f92dd50f94337a10 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=RMI/AMD AU1x00
 FEATURES:=jffs2 usb pci
 SUBTARGETS=au1500 au1550
 
-LINUX_VERSION:=2.6.35.4
+LINUX_VERSION:=2.6.35.7
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += wpad-mini yamonenv
index 76536acdeb16605d998a4071631d9b58551f8462..3527f6fcfe55942450729e161455ffd5da8044b2 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=avr32
 BOARD:=avr32
 BOARDNAME:=Atmel AVR32
 FEATURES:=squashfs
-LINUX_VERSION:=2.6.32.20
+LINUX_VERSION:=2.6.32.24
 
 include $(INCLUDE_DIR)/target.mk
 
index 5b2862ef0ac7425e45f8b3119b7cc4be06a6461c..8a587da1e9ada6a4fc5d36058b8c09d798625a9f 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=brcm47xx
 BOARDNAME:=Broadcom BCM947xx/953xx
 FEATURES:=squashfs usb pcmcia
 
-LINUX_VERSION:=2.6.34.5
+LINUX_VERSION:=2.6.34.7
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += wpad-mini kmod-switch kmod-diag nvram
index 0167b61bd557cf62312333be336492083eecf2fb..3082f4bde69bc28b6109b7289692562a28dc2ae6 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Cobalt Microservers
 FEATURES:=targz pci ext2
 CFLAGS:=-O2 -pipe -mtune=r5000 -funit-at-a-time
 
-LINUX_VERSION:=2.6.32.20
+LINUX_VERSION:=2.6.32.24
 
 include $(INCLUDE_DIR)/target.mk
 
index 469fa44147bcafcdc7d39a1e49e5ca989ffc3a40..6a01af6d195ab3e1ba02a540f7ea1dd41d552600 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=cris
 BOARD:=etrax
 BOARDNAME:=Axis ETRAX 100LX
 FEATURES:=squashfs jffs2 usb
-LINUX_VERSION:=2.6.32.20
+LINUX_VERSION:=2.6.32.24
 DEVICE_TYPE=
 
 include $(INCLUDE_DIR)/target.mk
index 885169bab417d7b0793428dc830f2aea09ea40d7..0f0ecd3872f546b0a2e15fd0a5c4b15cec6dc1d4 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Cortina Systems CS351x
 FEATURES:=squashfs
 CFLAGS:=-Os -pipe -march=armv4 -mtune=arm9tdmi -funit-at-a-time
 
-LINUX_VERSION:=2.6.32.20
+LINUX_VERSION:=2.6.32.24
 
 include $(INCLUDE_DIR)/target.mk
 
index 4e63ffdb0be30c48549be398973a0989943fe87d..db508f8c9d9e2f09b970288927c7ff73d6193208 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Freescale i.MX21
 FEATURES:=jffs2
 CFLAGS:=-Os -pipe -march=armv5te -mtune=arm926ej-s -funit-at-a-time
 
-LINUX_VERSION:=2.6.34.5
+LINUX_VERSION:=2.6.34.7
 
 DEVICE_TYPE=phone
 
index 8f0bdc2b67c861942257250179e06efc24e25267..792917000b1aec080815d4f6e90af5ee38fbdd0f 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=iop32x
 BOARDNAME:=Intel IOP32x
 FEATURES:=squashfs
 
-LINUX_VERSION:=2.6.32.20
+LINUX_VERSION:=2.6.32.24
 
 include $(INCLUDE_DIR)/target.mk
 
index 3704c8d7244021a0fb552204ef38b34df44046eb..00b90b16821ee9fa4fc233f6117deefd691fda5e 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Intel IXP4xx
 FEATURES:=squashfs
 SUBTARGETS=generic harddisk
 
-LINUX_VERSION:=2.6.32.20
+LINUX_VERSION:=2.6.32.24
 
 include $(INCLUDE_DIR)/target.mk
 
index ddd31a62a9c538e987bfbc4b97355c62edca7f62..c28c21b299977c1259a8117d1bc681df9bbf07f0 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=TI OMAP35xx
 FEATURES:=broken
 SUBTARGETS=beagleboard gumstix
 
-LINUX_VERSION:=2.6.32.20
+LINUX_VERSION:=2.6.32.24
 KERNELNAME:="uImage"
 
 DEVICE_TYPE=developerboard
index ff0f6556fa1ef4eeaf9404741b82a14e3403f2fa..0c58c7bd3c11229373459d45f7a87aa94143a724 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs
 SUBTARGETS=generic harddisk
 CFLAGS=-Os -pipe -march=armv5t -mtune=xscale -funit-at-a-time
 
-LINUX_VERSION:=2.6.34.5
+LINUX_VERSION:=2.6.34.7
 
 include $(INCLUDE_DIR)/target.mk
 
index aaf395de6742ca0f512b8a16bb587fb04e71d2fb..715eeba2f9ab6089b099a3894210ee8eebb1fe2a 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=AMCC/IBM PPC40x
 FEATURES:=squashfs
 CFLAGS:=-Os -pipe -funit-at-a-time -mcpu=405
 
-LINUX_VERSION:=2.6.32.20
+LINUX_VERSION:=2.6.32.24
 
 include $(INCLUDE_DIR)/target.mk
 
index c0e0f601a140b382fb32c5c7009e9efdef101944..32a198f2d8ff7ea5e4a390653d685046bc0ed98c 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=AMCC/IBM PPC44x
 FEATURES:=squashfs
 CFLAGS:=-Os -pipe -funit-at-a-time -mcpu=440
 
-LINUX_VERSION:=2.6.32.20
+LINUX_VERSION:=2.6.32.24
 
 include $(INCLUDE_DIR)/target.mk
 
index dcfeafa6ede69c6092d45b0fe93a4c75dfb75c6f..e4c57b05c9354a0631682649111cee7e07039303 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=pxa
 BOARDNAME:=Marvell/Intel PXA2xx
 FEATURES:=squashfs
 
-LINUX_VERSION:=2.6.32.20
+LINUX_VERSION:=2.6.32.24
 
 include $(INCLUDE_DIR)/target.mk
 
index daaf218229ab8f19e2dac897f16e9cee002249fc..08e6e23ba7a94073c9488b88e4898a893989e344 100644 (file)
@@ -13,7 +13,7 @@ SUBTARGETS:=rt288x rt305x
 CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
 FEATURES:=squashfs
 
-LINUX_VERSION:=2.6.34.5
+LINUX_VERSION:=2.6.34.7
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES+=kmod-leds-gpio wpad-mini
index 3953c546d119679612b51005892878365d7dbe77..7d73d60a301155f16c807ae5a1ccfc2bf73d9509 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=rb532
 BOARDNAME:=Mikrotik RouterBoard 532
 FEATURES:=jffs2 pci targz
 
-LINUX_VERSION:=2.6.32.20
+LINUX_VERSION:=2.6.32.24
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += wpad-mini kmod-madwifi kmod-input-rb532
index a49f16d427ce48c87666ecc102409411fde75798..b8adae28672902151fcd12e9c0d0ac344e12e3d2 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=RDC 321x
 FEATURES:=squashfs jffs2 pci usb pcmcia
 CFLAGS:=-Os -pipe -march=i486 -mtune=i486 -funit-at-a-time
 
-LINUX_VERSION:=2.6.32.20
+LINUX_VERSION:=2.6.32.24
 
 include $(INCLUDE_DIR)/target.mk
 
index dab43957b7f659307d368c04d957461795c1bcbf..57a50e138bd2d4eb542acdee55bbdcdf669a9350 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Broadcom/SiByte SB-1
 FEATURES:=fpu
 CFLAGS:=-Os -pipe -march=sb1 -funit-at-a-time
 
-LINUX_VERSION:=2.6.32.20
+LINUX_VERSION:=2.6.32.24
 
 include $(INCLUDE_DIR)/target.mk
 
index 95262b82ddbc4d41a7d25a23831cf5a9e5b432de..dd3dc9722576461420ce74e20ebc41fe1b996093 100644 (file)
@@ -23,7 +23,7 @@ BOARDNAME:=User Mode Linux
 FEATURES:=ext2 audio
 LINUX_CONFIG:=$(CURDIR)/config/$(ARCH)
 
-LINUX_VERSION:=2.6.32.20
+LINUX_VERSION:=2.6.32.24
 
 include $(INCLUDE_DIR)/target.mk
 
index dd71d3a51aa8479e748826857658a01bb04dde65..a1d7ec6255b7ad2965de469b5e3b55e322668150 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=x86
 FEATURES:=squashfs jffs2 ext2 vdi vmdk pcmcia targz
 SUBTARGETS=generic olpc xen_domu ep80579 net5501 kvm_guest
 
-LINUX_VERSION:=2.6.32.20
+LINUX_VERSION:=2.6.32.24
 
 include $(INCLUDE_DIR)/target.mk