procd: work around a event race
authorJohn Crispin <john@openwrt.org>
Wed, 3 Jun 2015 13:59:08 +0000 (13:59 +0000)
committerJohn Crispin <john@openwrt.org>
Wed, 3 Jun 2015 13:59:08 +0000 (13:59 +0000)
there is a conceptual design flaw in our interface events. workaround this by
disabling duplicate message supression in procd. we need to fix this properly
for the next release

Signed-off-by: John Crispin <blogic@openwrt.org>
SVN-Revision: 45883

package/system/procd/Makefile
package/system/procd/files/procd.sh

index 44a836c4aa07e4ef161ee50b5614354eab783d57..9d66b0def5c3c7a2d5669361918c352a9565b82a 100644 (file)
@@ -8,14 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=procd
-PKG_VERSION:=2015-05-23
+PKG_VERSION:=2015-06-03
 
 PKG_RELEASE=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=git://nbd.name/luci2/procd.git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=a771644fd3a3ac055ec0c62fbe434aed0df002fe
+PKG_SOURCE_VERSION:=94e7ea8b88cb01192a6fb1f1f6a68ada1356763f
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
 CMAKE_INSTALL:=1
 
index f3c7e48e50423807c571acc3a9e567a009735e24..0e798a00257235922c276f690ef8138e01098aa0 100644 (file)
@@ -222,8 +222,6 @@ _procd_add_interface_trigger() {
        json_close_array
 
        json_close_array
-
-       _procd_add_array_data "10000"
        json_close_array
 }