openwrt: honour gcc extra configuration flags
authorFelix Fietkau <nbd@openwrt.org>
Tue, 23 Oct 2007 06:23:17 +0000 (06:23 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Tue, 23 Oct 2007 06:23:17 +0000 (06:23 +0000)
Although the CONFIG_EXTRA_GCC_OPTIONS flag is available, it isn't used
anywhere.

This change adds the extra flag to both gcc configure stages.

Signed-off-by: Jeremy Kerr <jk@ozlabs.org>
SVN-Revision: 9406

toolchain/gcc/Makefile

index a326bb716f13cb3a0c04ae9cbd64449b9f3f0bac..d9e34af0bd03716ce9ed3d7d2257937b5a6461c0 100644 (file)
@@ -60,6 +60,7 @@ define Stage1/Configure
                --disable-nls \
                --disable-libmudflap \
                --disable-multilib \
+               $(call qstrip,$(CONFIG_EXTRA_GCC_CONFIG_OPTIONS)) \
        );
 endef
 define Stage1/Compile
@@ -91,6 +92,7 @@ define Stage2/Configure
                --disable-nls \
                --disable-libmudflap \
                --disable-multilib \
+               $(call qstrip,$(CONFIG_EXTRA_GCC_CONFIG_OPTIONS)) \
        );
 endef