librpc: do not build if external or native toolchains are used
authorJo-Philipp Wich <jow@openwrt.org>
Thu, 8 Dec 2011 16:49:45 +0000 (16:49 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Thu, 8 Dec 2011 16:49:45 +0000 (16:49 +0000)
SVN-Revision: 29484

package/librpc/Makefile

index 3cfb4c122704dc7a40ae6fe1c7e4015110845ca4..5a469211643c9a2cb5107964ff7d6adef0c7f326 100644 (file)
@@ -9,7 +9,16 @@ PKG_SOURCE_URL:=git://nbd.name/uclibc-rpc.git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE_VERSION:=0a2179bbc0844928f2a0ec01dba93d9b5d6d41a7
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
-ifdef CONFIG_USE_UCLIBC
+
+ifndef CONFIG_NATIVE_TOOLCHAIN
+ ifndef CONFIG_EXTERNAL_TOOLCHAIN
+  ifdef CONFIG_USE_UCLIBC
+    BUILD_LIBRPC=1
+  endif
+ endif
+endif
+
+ifdef BUILD_LIBRPC
   CMAKE_INSTALL:=1
 endif
 
@@ -23,11 +32,27 @@ define Package/librpc
   MDEPENDS:=@USE_UCLIBC
 endef
 
-ifdef CONFIG_USE_UCLIBC
+ifdef BUILD_LIBRPC
   define Package/librpc/install
        $(INSTALL_DIR) $(1)/lib/
        $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/librpc.so $(1)/lib/
   endef
+else
+  define Build/Prepare
+  endef
+
+  define Build/Configure
+  endef
+
+  define Build/Compile
+  endef
+
+  define Build/Install
+  endef
+
+  define Package/librpc/install
+       true
+  endef
 endif
 
 $(eval $(call BuildPackage,librpc))