grub: Natively build grub only on x86 linux hosts, cross compile everywhere else...
authorAndy Boyett <agb@openwrt.org>
Fri, 20 Jun 2008 01:43:20 +0000 (01:43 +0000)
committerAndy Boyett <agb@openwrt.org>
Fri, 20 Jun 2008 01:43:20 +0000 (01:43 +0000)
SVN-Revision: 11542

package/grub/Makefile

index 98bb68b564714be2ab1eeeed9f39be608a1512d5..7dfd1429d209dc8002792d7f1a44f25afa69c51e 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -30,7 +30,13 @@ define Package/grub
   URL:=http://www.gnu.org/software/grub/
 endef
 
-ifeq ($(HOST_ARCH),x86_64)
+ifeq ($(HOST_OS),Linux)
+  NATIVEGRUB-i386:=1
+  NATIVEGRUB-i686:=1
+  NATIVEGRUB:=$(NATIVEGRUB-$(HOST_ARCH))
+endif
+
+ifeq ($(NATIVEGRUB),)
 CONFIGURE_FLAGS:= \
        --target=$(GNU_TARGET_NAME) \
        --host=$(GNU_TARGET_NAME) \
@@ -62,7 +68,7 @@ define Build/Configure
 endef
 
 #
-# ./configure detects whether the host compiler supports 
+# ./configure detects whether the host compiler supports
 # -fno-stack-protector but only sets STAGE2_CFLAGS accordingly
 #
 define Build/Compile