dropbear: disable MD5 HMAC and switch to sha1 fingerprints
authorMartin Schiller <ms@dev.tdt.de>
Wed, 22 Nov 2017 12:39:51 +0000 (13:39 +0100)
committerHans Dedecker <dedeckeh@gmail.com>
Tue, 12 Dec 2017 21:24:17 +0000 (22:24 +0100)
As MD5 is known weak for many years and more and more
penetration test tools complain about enabled MD5 HMAC
I think it's time to drop it.

By disabling the MD5 HMAC support dropbear  will also
automatically use SHA1 for fingerprints.
This shouldn't be a problem too.

Signed-off-by: Martin Schiller <ms@dev.tdt.de>
package/network/services/dropbear/Makefile
package/network/services/dropbear/patches/120-openwrt_options.patch

index 133fa4ebb4c34581c5ac849aecf8e86639453082..21ac09f72452e6093a2149d31df307c1d8dbe87c 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dropbear
 PKG_VERSION:=2017.75
-PKG_RELEASE:=4
+PKG_RELEASE:=5
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:= \
index b49a95ce93d9565ea0f22d3536d1abbe685f2024..7f47a74304791ae6d073157ecc0716c1e2c3dba6 100644 (file)
@@ -39,7 +39,7 @@
  
  /* Enable "Counter Mode" for ciphers. This is more secure than normal
   * CBC mode against certain attacks. It is recommended for security
-@@ -131,9 +131,9 @@ If you test it please contact the Dropbe
+@@ -131,10 +131,10 @@ If you test it please contact the Dropbe
   * If you disable MD5, Dropbear will fall back to SHA1 fingerprints,
   * which are not the standard form. */
  #define DROPBEAR_SHA1_HMAC
 +/*#define DROPBEAR_SHA1_96_HMAC*/
  #define DROPBEAR_SHA2_256_HMAC
 -#define DROPBEAR_SHA2_512_HMAC
+-#define DROPBEAR_MD5_HMAC
 +/*#define DROPBEAR_SHA2_512_HMAC*/
- #define DROPBEAR_MD5_HMAC
++/*#define DROPBEAR_MD5_HMAC*/
  
  /* You can also disable integrity. Don't bother disabling this if you're
+  * still using a cipher, it's relatively cheap. If you disable this it's dead
 @@ -146,7 +146,7 @@ If you test it please contact the Dropbe
   * Removing either of these won't save very much space.
   * SSH2 RFC Draft requires dss, recommends rsa */