kernel: add kmod-ata-sis (#8259)
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 18 Mar 2012 18:44:30 +0000 (18:44 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 18 Mar 2012 18:44:30 +0000 (18:44 +0000)
SVN-Revision: 30978

package/kernel/modules/block.mk

index a3a44b200c15f62d054840f2a95d1790cb290d99..357f5fd2eba5502dc1d4be0cc8ca3f06b6c39bf2 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -166,6 +166,20 @@ endef
 $(eval $(call KernelPackage,ata-sil24))
 
 
+define KernelPackage/ata-sis
+  TITLE:=SIS SATA support
+  KCONFIG:=CONFIG_SATA_SIS
+  FILES:=$(LINUX_DIR)/drivers/ata/sata_sis.ko
+  AUTOLOAD:=$(call AutoLoad,41,sata_sis,1)
+endef
+
+define KernelPackage/ata-sis/description
+ Support for SIS Serial ATA controllers.
+endef
+
+$(eval $(call KernelPackage,ata-sis))
+
+
 define KernelPackage/ata-via-sata
   TITLE:=VIA SATA support
   KCONFIG:=CONFIG_SATA_VIA