procd: add direct dependencies on libblobmsg-json and libjson-c
authorJo-Philipp Wich <jo@mein.io>
Thu, 20 Jun 2019 10:54:02 +0000 (12:54 +0200)
committerJo-Philipp Wich <jo@mein.io>
Thu, 20 Jun 2019 12:13:01 +0000 (14:13 +0200)
The OpenWrt buildroot ABI version rebuild tracker does not handle
transient dependencies, therefor add all libraries linked by procd
as direct dependencies to the corresponding binary package definition.

This ensures that procd is automatically rebuilt and relinked
if any of these libraries has its ABI_VERSION updated in the
future.

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
package/system/procd/Makefile

index 437751aadf8f92a904115f73c3cb9d64313d5827..a58e4491556a245fe6e19f9ed4fad7813ea6a228 100644 (file)
@@ -43,7 +43,7 @@ TARGET_LDFLAGS += -flto
 define Package/procd
   SECTION:=base
   CATEGORY:=Base system
-  DEPENDS:=+ubusd +ubus +libjson-script +ubox +USE_GLIBC:librt +libubox +libubus
+  DEPENDS:=+ubusd +ubus +libjson-script +ubox +USE_GLIBC:librt +libubox +libubus +libblobmsg-json +libjson-c
   TITLE:=OpenWrt system process manager
   USERID:=:dialout=20 :audio=29
 endef