ramips: Add support for ZBT-CPE102
authorCezary Jackiewicz <cezary.jackiewicz@gmail.com>
Sun, 25 Sep 2016 19:09:31 +0000 (21:09 +0200)
committerJohn Crispin <john@phrozen.org>
Tue, 27 Sep 2016 15:50:21 +0000 (17:50 +0200)
- CPU: MT7620N 580MHz
- Flash: 8MB
- RAM: 64MB
- build-in minipcie slot for modem 3G/4G
- one ethernet port 10/100Mbps

Signed-off-by: Cezary Jackiewicz <cezary@eko.one.pl>
target/linux/ramips/base-files/etc/board.d/01_leds
target/linux/ramips/base-files/etc/board.d/02_network
target/linux/ramips/base-files/etc/diag.sh
target/linux/ramips/base-files/lib/ramips.sh
target/linux/ramips/base-files/lib/upgrade/platform.sh
target/linux/ramips/dts/ZBT-CPE102.dts [new file with mode: 0644]
target/linux/ramips/image/mt7620.mk

index 97c405d3fd07d7a6dc8c94fccf3cda4eeefcd557..29bba0b26d89f4e417156685f187ebfa60f569bb 100755 (executable)
@@ -318,6 +318,9 @@ zbt-ape522ii)
        ucidef_set_led_netdev "sys1" "wlan1" "$board:green:sys1" "wlan1" "tx rx"
        ucidef_set_led_netdev "sys2" "wlan0" "$board:green:sys2" "wlan0" "tx rx"
        ;;
+zbt-cpe102)
+       ucidef_set_led_default "power" "power" "$board:green:4g-0" "0"
+       ;;
 zbt-wa05)
        ucidef_set_led_default "power" "power" "$board:blue:power" "1"
        set_wifi_led "$board:blue:air"
index 675dcc98323ea82aa9632ec0fddb624714697013..e757acb6ab67a09aa0153d5e919765dd2bee38d7 100755 (executable)
@@ -53,6 +53,7 @@ ramips_setup_interfaces()
        w150m|\
        widora-neo|\
        wnce2001|\
+       zbt-cpe102|\
        zte-q7)
                ucidef_add_switch "switch0"
                ucidef_add_switch_attr "switch0" "enable" "false"
index 969594d8a60fcb33e18b8e348e584669bd9a55d6..1eb4036aabb64cff47fbfa2f56f54ab3ac4570d8 100644 (file)
@@ -208,6 +208,9 @@ get_status_led() {
        wrtnode)
                status_led="wrtnode:blue:indicator"
                ;;
+       zbt-cpe102)
+               status_led="$board:green:4g-0"
+               ;;
        esac
 }
 
index 98bc68c39732452b9d7c2b2bcac402b3fda176d3..3a72835dbd7762fd15b3bfe48de77911992dcf8f 100755 (executable)
@@ -541,6 +541,9 @@ ramips_board_detect() {
        *"ZBT-APE522II")
                name="zbt-ape522ii"
                ;;
+       *"ZBT-CPE102")
+               name="zbt-cpe102"
+               ;;
        *"ZBT-WA05")
                name="zbt-wa05"
                ;;
index e3a74e092814c71293c2a491d32144023f7e8169..a71d806a782bcd76a68b4c1cbd02c8d05330bd09 100755 (executable)
@@ -160,6 +160,7 @@ platform_check_image() {
        y1|\
        y1s|\
        zbt-ape522ii|\
+       zbt-cpe102|\
        zbt-wa05|\
        zbt-we826|\
        zbt-wg2626|\
diff --git a/target/linux/ramips/dts/ZBT-CPE102.dts b/target/linux/ramips/dts/ZBT-CPE102.dts
new file mode 100644 (file)
index 0000000..b93e585
--- /dev/null
@@ -0,0 +1,118 @@
+/dts-v1/;
+
+#include "mt7620n.dtsi"
+
+/ {
+       compatible = "zbtlink,zbt-cpe102", "ralink,mt7620n-soc";
+       model = "Zbtlink ZBT-CPE102";
+
+       chosen {
+               bootargs = "console=ttyS0,115200";
+       };
+
+       gpio-leds {
+               compatible = "gpio-leds";
+
+               4g-0 {
+                       label = "zbt-cpe102:green:4g-0";
+                       gpios = <&gpio1 14 1>;
+               };
+
+               4g-1 {
+                       label = "zbt-cpe102:green:4g-1";
+                       gpios = <&gpio0 2 1>;
+               };
+
+               4g-2 {
+                       label = "zbt-cpe102:green:4g-2";
+                       gpios = <&gpio1 15 1>;
+               };
+       };
+
+       gpio-keys-polled {
+               compatible = "gpio-keys-polled";
+               #address-cells = <1>;
+               #size-cells = <0>;
+               poll-interval = <20>;
+
+               reset {
+                       label = "reset";
+                       gpios = <&gpio0 1 1>;
+                       linux,code = <0x198>;
+               };
+       };
+};
+
+&gpio1 {
+       status = "okay";
+};
+
+&gpio2 {
+       status = "okay";
+};
+
+&gpio3 {
+       status = "okay";
+};
+
+&spi0 {
+       status = "okay";
+
+       en25q64@0 {
+               #address-cells = <1>;
+               #size-cells = <1>;
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               linux,modalias = "m25p80";
+               spi-max-frequency = <10000000>;
+
+               partition@0 {
+                       label = "u-boot";
+                       reg = <0x0 0x30000>;
+                       read-only;
+               };
+
+               partition@30000 {
+                       label = "u-boot-env";
+                       reg = <0x30000 0x10000>;
+                       read-only;
+               };
+
+               factory: partition@40000 {
+                       label = "factory";
+                       reg = <0x40000 0x10000>;
+                       read-only;
+               };
+
+               partition@50000 {
+                       label = "firmware";
+                       reg = <0x50000 0x760000>;
+               };
+       };
+};
+
+&ehci {
+       status = "okay";
+};
+
+&ohci {
+       status = "okay";
+};
+
+&ethernet {
+       mtd-mac-address = <&factory 0x4>;
+       mediatek,portmap = "wllll";
+};
+
+&wmac {
+       ralink,mtd-eeprom = <&factory 0>;
+};
+
+&pinctrl {
+       state_default: pinctrl0 {
+               default {
+                       ralink,group = "i2c", "spi refclk", "wled";
+                       ralink,function = "gpio";
+               };
+       };
+};
index 003fc7021072e4e6211a4bdee843358d01849152..28b5f3e16095a774d03f075ead652002fc4c8ff7 100644 (file)
@@ -358,6 +358,13 @@ define Device/zbt-ape522ii
 endef
 TARGET_DEVICES += zbt-ape522ii
 
+define Device/zbt-cpe102
+  DTS := ZBT-CPE102
+  DEVICE_TITLE := Zbtlink ZBT-CPE102
+  DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci
+endef
+TARGET_DEVICES += zbt-cpe102
+
 define Device/zbt-wa05
   DTS := ZBT-WA05
   DEVICE_TITLE := Zbtlink ZBT-WA05