ramips: rt305x: fix wr512n image generation
authorGabor Juhos <juhosg@openwrt.org>
Fri, 19 Aug 2011 15:55:11 +0000 (15:55 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Fri, 19 Aug 2011 15:55:11 +0000 (15:55 +0000)
SVN-Revision: 28053

target/linux/ramips/image/Makefile

index 46108a80541796d33f073376a96b97c391fe6b6a..6cdb55c72440a6cc4a16e9a4b40eaa8b3bc8a0b0 100644 (file)
@@ -146,16 +146,6 @@ define Image/Build/Template/RTG32B1
        $(call BuildFirmware/Generic,$(1),$(2),board=$(3),mtdlayout_rtg32b1,$(mtd_rtg32b1_kernel_part_size),$(mtd_rtg32b1_rootfs_part_size))
 endef
 
-mtdlayout_wr5123gn=mtdparts=physmap-flash.0:192k(u-boot)ro,64k(u-boot-env)ro,64k(factory)ro,832k(kernel),2944k(rootfs),3776k@0x50000(firmware)
-mtdlayout_wr5123gn8m=mtdparts=physmap-flash.0:192k(u-boot)ro,64k(u-boot-env)ro,64k(factory)ro,832k(kernel),7040k(rootfs),7872k@0x50000(firmware)
-define Image/Build/Template/WR5123GN
-       $(call BuildFirmware/Generic,$(1),$(2),board=$(3),mtdlayout_wr5123gn,851968,3014656)
-endef
-
-define Image/Build/Template/WR5123GN8M
-       $(call BuildFirmware/Generic,$(1),$(2),board=$(3),mtdlayout_wr5123gn8m,851968,3014656)
-endef
-
 define Image/Build/Profile/RTG32B1
        $(call Image/Build/Template/RTG32B1,$(1),rt-g32-b1,RT-G32-B1)
 endef
@@ -231,8 +221,12 @@ define Image/Build/Profile/F5D8235V2
        $(call Image/Build/Template/F5D8235V2,$(1),f5d8235v2,F5D8235_V2)
 endef
 
+
+mtdlayout_wr5123gn=mtdparts=physmap-flash.0:192k(u-boot)ro,64k(u-boot-env)ro,64k(factory)ro,832k(kernel),2944k(rootfs),3776k@0x50000(firmware)
+mtdlayout_wr5123gn8m=mtdparts=physmap-flash.0:192k(u-boot)ro,64k(u-boot-env)ro,64k(factory)ro,832k(kernel),7040k(rootfs),7872k@0x50000(firmware)
 define Image/Build/Profile/WR5123GN
-$(call Image/Build/Template/WR5123GN,$(1),wr512-3gn,WR512-3GN)
+       $(call BuildFirmware/Generic,$(1),wr512-3gn-4M,board="WR512-3GN",mtdlayout_wr5123gn,851968,3014656)
+       $(call BuildFirmware/Generic,$(1),wr512-3gn-8M,board="WR512-3GN",mtdlayout_wr5123gn8m,851968,7208960)
 endef
 
 
@@ -251,7 +245,6 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/HW5503G,$(1))
        $(call Image/Build/Profile/MOFI35003GN,$(1))
        $(call Image/Build/Profile/WR5123GN,$(1))
-       $(call Image/Build/Profile/WR5123GN8M,$(1))
 endef
 endif