Remove zd1211 now we have zd1211rw which is in the kernel source
authorFlorian Fainelli <florian@openwrt.org>
Fri, 1 Jun 2007 14:10:14 +0000 (14:10 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Fri, 1 Jun 2007 14:10:14 +0000 (14:10 +0000)
SVN-Revision: 7433

package/zd1211/Makefile [deleted file]
package/zd1211/patches/101-linux_2.6.19_changes.patch [deleted file]

diff --git a/package/zd1211/Makefile b/package/zd1211/Makefile
deleted file mode 100644 (file)
index b797c85..0000000
+++ /dev/null
@@ -1,67 +0,0 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-# $Id$
-
-include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/kernel.mk
-
-PKG_NAME:=zd1211
-PKG_VERSION:=r83
-PKG_RELEASE:=1
-
-PKG_SOURCE:=$(PKG_NAME)-driver-$(PKG_VERSION).tgz
-PKG_SOURCE_URL:=http://zd1211.ath.cx/download/
-PKG_MD5SUM:=a5751f0e6f1f368689077fa7758a4932
-
-PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_NAME)-driver-$(PKG_VERSION)
-
-include $(INCLUDE_DIR)/package.mk
-
-#FIXME: add proper dependency handling on kmod-usb-core packages
-define KernelPackage/zd1211
-  SUBMENU:=Wireless Drivers
-  DEPENDS:=@LINUX_2_6&&!LINUX_2_6_UML
-  TITLE:=Driver for Zydas 1211 based USB devices
-  DESCRIPTION:=\
-       This package contains a Linux driver for the ZyDAS ZD1211 802.11b/g \\\
-       USB-WLAN-Chip.\\\
-       Initially contributed by ZyDAS, this driver is actively maintained by the \\\
-       open source community.
-  VERSION:=$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(PKG_RELEASE)
-  FILES:=$(PKG_BUILD_DIR)/zd1211.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,60,zd1211) 
-endef
-
-define Package/zd1211-utils
-  SECTION:=utils
-  CATEGORY:=Utilities
-  TITLE:=zd1211 user-space utilities
-  DESCRIPTION:=zd1211 user-space utilities : apdbg, zd1211-sta
-endef
-
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               ARCH="$(LINUX_KARCH)" \
-               CROSS_COMPILE="$(TARGET_CROSS)" \
-               CC="$(TARGET_CC)" \
-               CPP="$(TARGET_CC)" \
-               LD="$(TARGET_CROSS)ld" \
-               KERNELVERSION="$(KERNEL)" \
-               KERNEL_SOURCE="$(LINUX_DIR)" \
-               KDIR="$(LINUX_DIR)" \
-               all
-       $(TARGET_CC) $(PKG_BUILD_DIR)/apdbg.c -o $(PKG_BUILD_DIR)/apdbg
-endef
-
-define Package/zd1211-utils/install
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_BUILD_DIR)/apdbg $(1)/usr/sbin/
-       $(CP) $(PKG_BUILD_DIR)/sta $(1)/usr/sbin/$(PKG_NAME)-sta
-endef
-
-$(eval $(call Package,zd1211-utils))
-$(eval $(call KernelPackage,zd1211))
diff --git a/package/zd1211/patches/101-linux_2.6.19_changes.patch b/package/zd1211/patches/101-linux_2.6.19_changes.patch
deleted file mode 100644 (file)
index 7d80c8c..0000000
+++ /dev/null
@@ -1,46 +0,0 @@
-diff -bruN zd1211-driver-r69-old/src/zd1205.c zd1211-driver-r69-new/src/zd1205.c
---- zd1211-driver-r69-old/src/zd1205.c 2006-03-18 12:14:33.000000000 +0100
-+++ zd1211-driver-r69-new/src/zd1205.c 2006-12-15 19:03:55.000000000 +0100
-@@ -31,7 +31,7 @@
- * -------------------------------------------------------------------- */
- #define __KERNEL_SYSCALLS__
--#include <linux/config.h>
-+#include <linux/autoconf.h>
- #include <net/checksum.h>
- #include <linux/tcp.h>
- #include <linux/udp.h>
-diff -bruN zd1211-driver-r69-old/src/zd1205_proc.c zd1211-driver-r69-new/src/zd1205_proc.c
---- zd1211-driver-r69-old/src/zd1205_proc.c    2006-02-13 13:50:12.000000000 +0100
-+++ zd1211-driver-r69-new/src/zd1205_proc.c    2006-12-15 19:04:02.000000000 +0100
-@@ -30,7 +30,7 @@
- *
- * -------------------------------------------------------------------- */
--#include <linux/config.h>
-+#include <linux/autoconf.h>
- #ifdef CONFIG_PROC_FS
- #include "zd1205.h"
-diff -bruN zd1211-driver-r69-old/src/zd1211.c zd1211-driver-r69-new/src/zd1211.c
---- zd1211-driver-r69-old/src/zd1211.c 2006-02-16 22:33:51.000000000 +0100
-+++ zd1211-driver-r69-new/src/zd1211.c 2006-12-15 19:03:16.000000000 +0100
-@@ -30,7 +30,7 @@
- *
- * -------------------------------------------------------------------- */
--#include <linux/config.h>
-+#include <linux/autoconf.h>
- #include <net/checksum.h>
- #include <linux/tcp.h>
- #include <linux/udp.h>
-@@ -1878,7 +1878,9 @@
-         dev->get_stats = zd1205_get_stats;
- #if ZDCONF_WE_STAT_SUPPORT == 1
-+# if WIRELESS_EXT < 21
-         dev->get_wireless_stats = zd1205_iw_getstats;
-+# endif
- #elif !defined(ZDCONF_WE_STAT_SUPPORT)
-       #error "Undefine ZDCONF_WE_STAT_SUPPORT"
- #endif