kernel: bump 4.19 to 4.19.65
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Wed, 7 Aug 2019 12:21:39 +0000 (14:21 +0200)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Fri, 9 Aug 2019 16:30:33 +0000 (18:30 +0200)
Refreshed all patches.

Compile-tested on: cns3xxx
Runtime-tested on: cns3xxx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/brcm2708/patches-4.19/950-0129-gpiolib-Don-t-prevent-IRQ-usage-of-output-GPIOs.patch
target/linux/generic/backport-4.19/011-kbuild-export-SUBARCH.patch
target/linux/generic/hack-4.19/207-disable-modorder.patch
target/linux/generic/hack-4.19/220-gc_sections.patch
target/linux/generic/pending-4.19/201-extra_optimization.patch
target/linux/generic/pending-4.19/220-optimize_inlining.patch
target/linux/generic/pending-4.19/332-arc-add-OWRTDTB-section.patch

index 8a604844b34bf6739690d65f29706334e21d928f..97188d875bf4dbe5a6ffda806beef2706966982e 100644 (file)
@@ -8,11 +8,11 @@ endif
 
 LINUX_VERSION-4.9 = .188
 LINUX_VERSION-4.14 = .137
-LINUX_VERSION-4.19 = .64
+LINUX_VERSION-4.19 = .65
 
 LINUX_KERNEL_HASH-4.9.188 = 27539853b25d1830fe81b108f39249c6ddf8b47257cdba09404ba0949863e222
 LINUX_KERNEL_HASH-4.14.137 = 93f8e91329300f325a5b4dd9de1f51c0b1bf9591dfd2274044c2f70f96bae228
-LINUX_KERNEL_HASH-4.19.64 = 7a6f8be33df3bef763495e8dde7a2fd7cdad71d7b952cd740b68eaac1bab5abd
+LINUX_KERNEL_HASH-4.19.65 = e59939186916c0286289c5bf78b83fac0d71a807241c6b1899bfe7a84486dedf
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index d251129a2ea823f3fb499effec5ee2ae2390d3e0..1905c71bdd676135acf7a17662b01d9ce6ea3632 100644 (file)
@@ -26,7 +26,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
  /* Device and char device-related information */
  static DEFINE_IDA(gpio_ida);
  static dev_t gpio_devt;
-@@ -2624,7 +2626,7 @@ int gpiod_direction_output(struct gpio_d
+@@ -2626,7 +2628,7 @@ int gpiod_direction_output(struct gpio_d
                value = !!value;
  
        /* GPIOs used for IRQs shall not be set as output */
@@ -35,7 +35,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
                gpiod_err(desc,
                          "%s: tried to set a GPIO tied to an IRQ as output\n",
                          __func__);
-@@ -3312,7 +3314,7 @@ int gpiochip_lock_as_irq(struct gpio_chi
+@@ -3314,7 +3316,7 @@ int gpiochip_lock_as_irq(struct gpio_chi
                }
        }
  
index b5f654906a78766757f9ae21e02645a4d57d89b1..a42c72044622a812cf3229f59ebfc75d902ad21c 100644 (file)
@@ -10,9 +10,9 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 
 --- a/Makefile
 +++ b/Makefile
-@@ -431,8 +431,8 @@ KBUILD_LDFLAGS_MODULE := -T $(srctree)/s
- KBUILD_LDFLAGS :=
+@@ -432,8 +432,8 @@ KBUILD_LDFLAGS :=
  GCC_PLUGINS_CFLAGS :=
+ CLANG_FLAGS :=
  
 -export ARCH SRCARCH CONFIG_SHELL HOSTCC KBUILD_HOSTCFLAGS CROSS_COMPILE AS LD CC
 -export CPP AR NM STRIP OBJCOPY OBJDUMP KBUILD_HOSTLDFLAGS KBUILD_HOSTLDLIBS
index f19d36c3de45dab555ae13555d58b4120b0061b8..942c0255639a72e85dce0e32888b6901d0333489 100644 (file)
@@ -15,7 +15,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 
 --- a/Makefile
 +++ b/Makefile
-@@ -1225,7 +1225,6 @@ all: modules
+@@ -1226,7 +1226,6 @@ all: modules
  
  PHONY += modules
  modules: $(vmlinux-dirs) $(if $(KBUILD_BUILTIN),vmlinux) modules.builtin
@@ -23,7 +23,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        @$(kecho) '  Building modules, stage 2.';
        $(Q)$(MAKE) -f $(srctree)/scripts/Makefile.modpost
  
-@@ -1254,7 +1253,6 @@ _modinst_:
+@@ -1255,7 +1254,6 @@ _modinst_:
                rm -f $(MODLIB)/build ; \
                ln -s $(CURDIR) $(MODLIB)/build ; \
        fi
index 1ca28990998c3be6206d94835a66369fc3151d01..77422e821bd715688f89d9441d47050cbd7a7f5e 100644 (file)
@@ -33,7 +33,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
  # Read KERNELRELEASE from include/config/kernel.release (if it exists)
  KERNELRELEASE = $(shell cat include/config/kernel.release 2> /dev/null)
  KERNELVERSION = $(VERSION)$(if $(PATCHLEVEL),.$(PATCHLEVEL)$(if $(SUBLEVEL),.$(SUBLEVEL)))$(EXTRAVERSION)
-@@ -781,11 +786,6 @@ ifdef CONFIG_DEBUG_SECTION_MISMATCH
+@@ -782,11 +787,6 @@ ifdef CONFIG_DEBUG_SECTION_MISMATCH
  KBUILD_CFLAGS += $(call cc-option, -fno-inline-functions-called-once)
  endif
  
index 8091543976358df69ad23e62c8b6444fdecee0a7..cafccd42c93bdf54ba4722f5c38362d49b1973ab 100644 (file)
@@ -14,7 +14,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 
 --- a/Makefile
 +++ b/Makefile
-@@ -656,12 +656,12 @@ KBUILD_CFLAGS    += $(call cc-disable-warni
+@@ -657,12 +657,12 @@ KBUILD_CFLAGS    += $(call cc-disable-warni
  KBUILD_CFLAGS += $(call cc-disable-warning, address-of-packed-member)
  
  ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
index c493742eeeaa808711f49a6da3df3b0d86d17af4..1cb0a1d485dae8fd27f3924537ab73ab0609e462 100644 (file)
@@ -11,7 +11,7 @@
        early_print("no ATAGS support: can't continue\n");
 --- a/arch/arm64/include/asm/cpufeature.h
 +++ b/arch/arm64/include/asm/cpufeature.h
-@@ -365,7 +365,7 @@ static inline bool cpu_have_feature(unsi
+@@ -366,7 +366,7 @@ static inline bool cpu_have_feature(unsi
  }
  
  /* System capability check for constant caps */
@@ -20,7 +20,7 @@
  {
        if (num >= ARM64_NCAPS)
                return false;
-@@ -379,7 +379,7 @@ static inline bool cpus_have_cap(unsigne
+@@ -380,7 +380,7 @@ static inline bool cpus_have_cap(unsigne
        return test_bit(num, cpu_hwcaps);
  }
  
index 6fea6f0b666e361244cb77923b190bfdd2f3c11a..ec89547726e4ca77832d59a45e2dc00569628074 100644 (file)
@@ -42,8 +42,8 @@ Signed-off-by: Evgeniy Didin <Evgeniy.Didin@synopsys.com>
  ;----------------------------------------------------------------
 --- a/arch/arc/kernel/setup.c
 +++ b/arch/arc/kernel/setup.c
-@@ -528,7 +528,7 @@ ignore_uboot_args:
- #endif
+@@ -526,7 +526,7 @@ void __init handle_uboot_args(void)
+ ignore_uboot_args:
  
        if (use_embedded_dtb) {
 -              machine_desc = setup_machine_fdt(__dtb_start);
@@ -51,7 +51,7 @@ Signed-off-by: Evgeniy Didin <Evgeniy.Didin@synopsys.com>
                if (!machine_desc)
                        panic("Embedded DT invalid\n");
        }
-@@ -544,6 +544,8 @@ ignore_uboot_args:
+@@ -542,6 +542,8 @@ ignore_uboot_args:
        }
  }