Generate gzipped package lists - Can be used by changing the src line in /etc/ipkg...
authorAndy Boyett <agb@openwrt.org>
Tue, 29 Jul 2008 03:36:11 +0000 (03:36 +0000)
committerAndy Boyett <agb@openwrt.org>
Tue, 29 Jul 2008 03:36:11 +0000 (03:36 +0000)
SVN-Revision: 11981

package/Makefile
target/imagebuilder/files/Makefile

index a1f20b0b1633ddd119d440b8844b3cd06c72633b..2a3354cf0adeb28650b2909ad42e608bd1c71c3c 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006-2007 OpenWrt.org
+#
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -45,7 +45,9 @@ $(curdir)/rootfs-prepare: $(TMP_DIR)/.build
        $(if $(CONFIG_CLEAN_IPKG),rm -rf $(TARGET_DIR)/usr/lib/ipkg)
 
 $(curdir)/index: FORCE
-       @(cd $(PACKAGE_DIR); $(SCRIPT_DIR)/ipkg-make-index.sh . > Packages)
+       @(cd $(PACKAGE_DIR); $(SCRIPT_DIR)/ipkg-make-index.sh . > Packages && \
+               gzip -9c Packages > Packages.gz \
+       )
 
 $(curdir)/flags-install:= -j1
 
index aa5b97150d052d0b5f252024dbe82c626eb48cea..27a6c94f9db24a380d866ba0d1b5f2937295789f 100644 (file)
@@ -1,6 +1,6 @@
 # Makefile for OpenWrt
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -112,7 +112,9 @@ endif
 package_index: $(TOPDIR)/tmp/ipkg.conf FORCE
        @echo
        @echo Building package index...
-       (cd $(PACKAGE_DIR); $(SCRIPT_DIR)/ipkg-make-index.sh . > Packages) >/dev/null 2>/dev/null
+       (cd $(PACKAGE_DIR); $(SCRIPT_DIR)/ipkg-make-index.sh . > Packages && \
+               gzip -9c Packages > Packages.gz \
+       ) >/dev/null 2>/dev/null
        $(IPKG) update
 
 package_install: FORCE