ramips: fix DCH-M225 support
authorMathias Kresin <dev@kresin.me>
Sat, 18 Nov 2017 10:59:22 +0000 (11:59 +0100)
committerMathias Kresin <dev@kresin.me>
Wed, 22 Nov 2017 07:19:37 +0000 (08:19 +0100)
Setting the pins of the uartf group to gpio+i2s at the time the i2c
driver loads is to late for the WPS gpio button.

The gpio-keys driver fails to load since the pin used by the WPS button
is not yet set to GPIO. The WPS button with the rfkill keycode is
essential for this wifi only board.

Add the missing sound and i2c kernel modules corresponding to the
device nodes.

Signed-off-by: Mathias Kresin <dev@kresin.me>
target/linux/ramips/dts/DCH-M225.dts
target/linux/ramips/image/mt7620.mk

index 3465c70ad0e04edfe9af21ab3640cf8d2268883c..3c269a5c015bbe2534189789e3fc67f35c5509a8 100644 (file)
@@ -89,7 +89,7 @@
        #sound-dai-cells = <0>;
        status = "okay";
        pinctrl-names = "default";
-       pinctrl-0 = <&gpio_i2s_pins>, <&wm8960_mclk_pins>;
+       pinctrl-0 = <&wm8960_mclk_pins>;
 };
 
 &spi0 {
                        ralink,function = "gpio";
                };
 
+               gpio_i2s {
+                       ralink,group = "uartf";
+                       ralink,function = "gpio i2s";
+               };
+
                pa {
                        ralink,group = "pa";
                        ralink,function = "pa";
index 1736d9f48045c49cc1528c0c58efb1c6e60e53cd..af1bda4a9d26b90a92ccf45f977afe92a1f089f9 100644 (file)
@@ -445,7 +445,7 @@ define Device/dch-m225
        seama-seal -m "signature=wapn22_dlink.2013gui_dap1320b" | \
        check-size $$$$(IMAGE_SIZE)
   DEVICE_TITLE := D-Link DCH-M225
-  DEVICE_PACKAGES := kmod-mt76
+  DEVICE_PACKAGES := kmod-mt76 kmod-sound-core kmod-sound-mt7620 kmod-i2c-ralink
 endef
 TARGET_DEVICES += dch-m225