GRE: Tos support
authorSteven Barth <cyrus@openwrt.org>
Mon, 29 Sep 2014 18:00:02 +0000 (18:00 +0000)
committerSteven Barth <cyrus@openwrt.org>
Mon, 29 Sep 2014 18:00:02 +0000 (18:00 +0000)
Tos support is added as a generic grev4/grev6 parameter which can have the following values :
     -inherit (outer header inherits the tos value of the inner header)
     -hex value

Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>
SVN-Revision: 42700

package/network/config/gre/Makefile
package/network/config/gre/files/gre.sh

index 9f5135e5a5472464039719709f27536b17051303..9c5c13f1691f837db2d0ffe6a868fe4b24cff330 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gre
 PKG_VERSION:=1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 include $(INCLUDE_DIR)/package.mk
 
index 1728b01fcca702d5e3b64a1af39c44f34fd55fe7..4483a087871126c2a6e524e58f12871ea9ef6d28 100755 (executable)
@@ -13,8 +13,8 @@ gre_generic_setup() {
        local local="$3"
        local remote="$4"
        local link="$5"
-       local mtu ttl zone ikey okey icsum ocsum iseqno oseqno
-       json_get_vars mtu ttl zone ikey okey icsum ocsum iseqno oseqno
+       local mtu ttl tos zone ikey okey icsum ocsum iseqno oseqno
+       json_get_vars mtu ttl tos zone ikey okey icsum ocsum iseqno oseqno
 
        [ -z "$zone" ] && zone="wan"
 
@@ -25,6 +25,7 @@ gre_generic_setup() {
        json_add_int mtu "${mtu:-1280}"
        [ -n "$df" ] && json_add_boolean df "$df"
        json_add_int ttl "${ttl:-64}"
+       [ -n "$tos" ] && json_add_string tos "$tos"
        json_add_string local "$local"
        json_add_string remote "$remote"
        [ -n "$tunlink" ] && json_add_string link "$tunlink"
@@ -193,6 +194,7 @@ gre_generic_init_config() {
 
        proto_config_add_int "mtu"
        proto_config_add_int "ttl"
+       proto_config_add_string "tos"
        proto_config_add_string "tunlink"
        proto_config_add_string "zone"
        proto_config_add_int "ikey"