add missing makefile in previous commit
authorJo-Philipp Wich <jow@openwrt.org>
Wed, 22 Dec 2010 00:03:15 +0000 (00:03 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Wed, 22 Dec 2010 00:03:15 +0000 (00:03 +0000)
SVN-Revision: 24755

tools/mm-macros/Makefile [new file with mode: 0644]

diff --git a/tools/mm-macros/Makefile b/tools/mm-macros/Makefile
new file mode 100644 (file)
index 0000000..60dcde6
--- /dev/null
@@ -0,0 +1,31 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=mm-macros
+PKG_VERSION:=0.9.2
+
+PKG_SOURCE_URL:=http://ftp.gnome.org/pub/GNOME/sources/mm-common/0.9
+PKG_SOURCE:=mm-common-$(PKG_VERSION).tar.bz2
+PKG_MD5SUM:=8cdc5620bd864d1a17e353398e8ec1ab
+
+HOST_BUILD_DIR:=$(BUILD_DIR)/mm-common-$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Host/Install
+       $(INSTALL_DIR) $(STAGING_DIR_HOST)/share/aclocal
+       $(INSTALL_DATA) $(HOST_BUILD_DIR)/macros/*.m4 $(STAGING_DIR_HOST)/share/aclocal/
+endef
+
+define Host/Clean
+       -$(MAKE) -C $(HOST_BUILD_DIR) uninstall
+       $(call Host/Clean/Default)
+endef
+
+$(eval $(call HostBuild))