add kmod-usb-serial-ipw module
authorFlorian Fainelli <florian@openwrt.org>
Sat, 4 Sep 2010 16:03:26 +0000 (16:03 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 4 Sep 2010 16:03:26 +0000 (16:03 +0000)
This patch adds support to compile kmod-usb-serial-ipw module. It is
used by USB IPWireless communication devices used for 3G.

Signed-off-by: Lukas macura <macura@opf.slu.cz>
SVN-Revision: 22891

package/kernel/modules/usb.mk

index 4e441915f12fd958923b085ed2bbb7dc4feb0379..fe69ed500e73cc0ead31d2e9b3c7cde769aaca4e 100644 (file)
@@ -318,6 +318,17 @@ endef
 $(eval $(call KernelPackage,usb-serial-ftdi))
 
 
+define KernelPackage/usb-serial-ipw
+  TITLE:=Support for IPWireless 3G devices
+  KCONFIG:=CONFIG_USB_SERIAL_IPW
+  FILES:=$(LINUX_DIR)/drivers/usb/serial/ipw.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,65,ipw)
+  $(call AddDepends/usb-serial)
+endef
+
+$(eval $(call KernelPackage,usb-serial-ipw))
+
+
 define KernelPackage/usb-serial-mct
   TITLE:=Support for Magic Control Tech. devices
   KCONFIG:=CONFIG_USB_SERIAL_MCT_U232