ramips: fix Omnima models, images and profiles names
authorJohn Crispin <john@openwrt.org>
Mon, 17 Aug 2015 06:00:11 +0000 (06:00 +0000)
committerJohn Crispin <john@openwrt.org>
Mon, 17 Aug 2015 06:00:11 +0000 (06:00 +0000)
Official names for supported Omnima products are (as on website):
 * Omnima HPM
 * Omnima MiniEMBWiFi
 * Omnima MiniEMBPlug

This patch changes:
 * board names
 * dts filenames
 * profile names
 * image filenames
 * LED names

for Omnima devices, for consistency.

Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
SVN-Revision: 46627

13 files changed:
target/linux/ramips/base-files/etc/board.d/01_leds
target/linux/ramips/base-files/etc/board.d/02_network
target/linux/ramips/base-files/etc/diag.sh
target/linux/ramips/base-files/lib/ramips.sh
target/linux/ramips/base-files/lib/upgrade/platform.sh
target/linux/ramips/dts/HPM.dts [new file with mode: 0644]
target/linux/ramips/dts/MINIEMBPLUG.dts [new file with mode: 0644]
target/linux/ramips/dts/MINIEMBWIFI.dts [new file with mode: 0644]
target/linux/ramips/dts/OMNI-EMB-HPM.dts [deleted file]
target/linux/ramips/dts/OMNI-EMB.dts [deleted file]
target/linux/ramips/dts/OMNI-PLUG.dts [deleted file]
target/linux/ramips/image/Makefile
target/linux/ramips/rt3883/profiles/omnima.mk

index 1ae4510b4c2145a55672c3f9a48ca2d60f5086af..19e79a8875e6c21722e82861fca60ef35d93eb6a 100755 (executable)
@@ -166,14 +166,14 @@ case $board in
                set_wifi_led "m2m:blue:wifi"
                ucidef_set_led_netdev "eth" "Ethernet" "m2m:green:wan" "eth0"
                ;;
-       omni-emb-hpm)
-               ucidef_set_led_default "power" "POWER" "emb:orange:power" "1"
-               ucidef_set_led_netdev "eth" "ETH" "emb:green:eth" "eth0"
-               set_wifi_led "emb:green:wifi"
-               ;;
-       omni-plug)
-               set_wifi_led "miniplug:green:wlan"
-               set_usb_led "miniplug:green:mobile"
+       hpm)
+               ucidef_set_led_default "power" "POWER" "hpm:orange:power" "1"
+               ucidef_set_led_netdev "eth" "ETH" "hpm:green:eth" "eth0"
+               set_wifi_led "hpm:green:wifi"
+               ;;
+       miniembplug)
+               set_wifi_led "miniembplug:green:wlan"
+               set_usb_led "miniembplug:green:mobile"
                ;;
        px4885)
                set_wifi_led "7links:orange:wifi"
index 8f6c813b20732aded32e9261da563ddec158504c..0fab232aa94019d57ee8a22942b1bdb9c25b1486 100755 (executable)
@@ -243,7 +243,7 @@ ramips_setup_interfaces()
                ;;
        d105 | \
        na930 | \
-       omni-emb-hpm|\
+       hpm|\
        wli-tx4-ag300n)
                ucidef_set_interface_lan "eth0"
                ;;
index 712e93cdbdfded4ed01e6a272328c5f248c6ab0b..e7499a896794b402951edfcc03e56e5b2c44fb02 100644 (file)
@@ -119,9 +119,11 @@ get_status_led() {
        nw718)
                status_led="nw718:amber:cpu"
                ;;
-       omni-emb|\
-       omni-emb-hpm)
-               status_led="emb:green:status"
+       miniembwifi)
+               status_led="miniembwifi:green:status"
+               ;;
+       hpm)
+               status_led="hpm:green:status"
                ;;
        pbr-m1)
                status_led="pbr-m1:green:sys"
index 36ba3f2a8bf22c614b975a222c5af7ebbf53475c..9b37ce6854616578a81fa917f3defc25181869ad 100755 (executable)
@@ -238,14 +238,14 @@ ramips_board_detect() {
        *"Intenso Memory 2 Move")
                name="m2m"
                ;;
-       *"Omnima EMB HPM")
-               name="omni-emb-hpm"
+       *"Omnima HPM")
+               name="hpm"
                ;;
        *"Omnima MiniEMBWiFi")
-               name="omni-emb"
+               name="miniembwifi"
                ;;
-       *"Omnima MiniPlug")
-               name="omni-plug"
+       *"Omnima MiniEMBPlug")
+               name="miniembplug"
                ;;
        *"Olimex RT5350F-OLinuXino")
                name="rt5350f-olinuxino"
index 5242e46bf969c01ce8b8e6c67819b6242161214b..7249005594f930d05d3dc0d43a3a7f48944c413b 100755 (executable)
@@ -74,9 +74,9 @@ platform_check_image() {
        mzk-dp150n | \
        nbg-419n | \
        nw718 | \
-       omni-emb | \
-       omni-emb-hpm | \
-       omni-plug | \
+       miniembwifi | \
+       hpm | \
+       miniembplug | \
        rt5350f-olinuxino | \
        rt5350f-olinuxino-evb | \
        psr-680w | \
diff --git a/target/linux/ramips/dts/HPM.dts b/target/linux/ramips/dts/HPM.dts
new file mode 100644 (file)
index 0000000..03bf710
--- /dev/null
@@ -0,0 +1,149 @@
+/dts-v1/;
+
+/include/ "rt3883.dtsi"
+
+/ {
+       compatible = "HPM", "ralink,rt3883-soc";
+       model = "Omnima HPM";
+
+       chosen {
+               bootargs = "console=ttyS0,115200";
+       };
+
+       palmbus@10000000 {
+               spi@b00 {
+                       status = "okay";
+
+                       m25p80@0 {
+                               compatible = "macronix,mx25l12805d";
+                               spi-max-frequency = <25000000>;
+                               reg = <0>;
+                               #address-cells = <1>;
+                               #size-cells = <1>;
+
+                               partition@0 {
+                                       reg = <0x0 0x0030000>;
+                                       label = "u-boot";
+                                       read-only;
+                               };
+
+                               partition@30000 {
+                                       reg = <0x00030000 0x00010000>;
+                                       label = "config";
+                                       read-only;
+                               };
+
+                               factory: partition@40000 {
+                                       reg = <0x00040000 0x00010000>;
+                                       label = "factory";
+                                       read-only;
+                               };
+
+                               partition@50000 {
+                                       reg = <0x00050000 0x00fb0000>;
+                                       label = "firmware";
+                               };
+                       };
+               };
+       };
+
+       pinctrl {
+               state_default: pinctrl0 {
+                       gpio {
+                               ralink,group = "i2c", "jtag", "uartf";
+                               ralink,function = "gpio";
+                       };
+               };
+       };
+
+       ethernet@10100000 {
+               phy-handle = <&phy0>;
+               phy-mode = "rgmii";
+               mtd-mac-address = <&factory 0x28>;
+
+               mdio-bus {
+                       status = "okay";
+
+                       phy0: ethernet-phy@4 {
+                               reg = <4>;
+                       };
+               };
+       };
+
+       wmac@10180000 {
+               ralink,mtd-eeprom = <&factory 0>;
+       };
+
+       ehci@101c0000 {
+               status = "okay";
+       };
+
+       ohci@101c1000 {
+               status = "okay";
+       };
+
+       gpio-keys-polled {
+               compatible = "gpio-keys-polled";
+               #address-cells = <1>;
+               #size-cells = <0>;
+               poll-interval = <100>;
+
+               reset {
+                       label = "reset";
+                       gpios = <&gpio0 14 0>;
+                       linux,code = <0x198>;
+               };
+       };
+
+       gpio-leds {
+               compatible = "gpio-leds";
+
+               power {
+                       label = "hpm:orange:power";
+                       gpios = <&gpio0 7 1>;
+               };
+
+               status {
+                       label = "hpm:green:status";
+                       gpios = <&gpio0 21 1>;
+               };
+
+               eth {
+                       label = "hpm:green:eth";
+                       gpios = <&gpio0 20 1>;
+               };
+
+               eth2 {
+                       label = "hpm:red:eth";
+                       gpios = <&gpio0 18 1>;
+               };
+
+               wifi {
+                       label = "hpm:green:wifi";
+                       gpios = <&gpio0 17 1>;
+               };
+
+               wifi2 {
+                       label = "hpm:red:wifi";
+                       gpios = <&gpio0 19 1>;
+               };
+       };
+
+       gpio_export {
+               compatible = "gpio-export";
+               #size-cells = <0>;
+               /* gpio 12 and 13 handle the OC input */
+
+               usb0 {
+                       gpio-export,name = "usb0";
+                       gpio-export,output = <1>;
+                       gpios = <&gpio0 2 0>;
+               };
+
+               usb1 {
+                       gpio-export,name = "usb1";
+                       gpio-export,output = <1>;
+                       gpios = <&gpio0 1 0>;
+               };
+       };
+};
diff --git a/target/linux/ramips/dts/MINIEMBPLUG.dts b/target/linux/ramips/dts/MINIEMBPLUG.dts
new file mode 100644 (file)
index 0000000..c94c3aa
--- /dev/null
@@ -0,0 +1,120 @@
+/dts-v1/;
+
+/include/ "rt5350.dtsi"
+
+/ {
+       compatible = "MINIEMBPLUG", "ralink,rt5350-soc";
+       model = "Omnima MiniEMBPlug";
+
+       pinctrl {
+               state_default: pinctrl0 {
+                       gpio {
+                               ralink,group = "i2c", "jtag", "uartf";
+                               ralink,function = "gpio";
+                       };
+               };
+       };
+
+       gpio-leds {
+               compatible = "gpio-leds";
+
+               wlan {
+                       label = "miniembplug:red:wlan";
+                       gpios = <&gpio0 9 0>;
+               };
+
+               mobile {
+                       label = "miniembplug:green:mobile";
+                       gpios = <&gpio0 13 1>;
+               };
+       };
+
+       gpio-keys-polled {
+               compatible = "gpio-keys-polled";
+               #address-cells = <1>;
+               #size-cells = <0>;
+               poll-interval = <20>;
+
+               wps {
+                       label = "wps";
+                       gpios = <&gpio0 0 1>;
+                       linux,code = <0x211>;
+               };
+
+               reset {
+                       label = "reset";
+                       gpios = <&gpio0 10 1>;
+                       linux,code = <0x211>;
+               };
+
+               mode-one {
+                       label = "mode1";
+                       gpios = <&gpio0 11 1>;
+                       linux,code = <0x211>;
+               };
+
+               mode-two {
+                       label = "mode2";
+                       gpios = <&gpio0 12 1>;
+                       linux,code = <0x211>;
+               };
+       };
+
+       palmbus@10000000 {
+               gpio0: gpio@600 {
+                       status = "okay";
+               };
+
+               spi@b00 {
+                       status = "okay";
+
+                       m25p80@0 {
+                               #address-cells = <1>;
+                               #size-cells = <1>;
+                               compatible = "mx25l6405d";
+                               reg = <0 0>;
+                               linux,modalias = "m25p80", "mx25l6405d";
+                               spi-max-frequency = <10000000>;
+
+                               partition@0 {
+                                       label = "u-boot";
+                                       reg = <0x0 0x30000>;
+                                       read-only;
+                               };
+
+                               partition@30000 {
+                                       label = "u-boot-env";
+                                       reg = <0x30000 0x10000>;
+                                       read-only;
+                               };
+
+                               factory: partition@40000 {
+                                       label = "factory";
+                                       reg = <0x40000 0x10000>;
+                                       read-only;
+                               };
+
+                               partition@50000 {
+                                       label = "firmware";
+                                       reg = <0x50000 0x7b0000>;
+                               };
+                       };
+               };
+       };
+
+       ethernet@10100000 {
+               mtd-mac-address = <&factory 0x4>;
+       };
+
+       esw@10110000 {
+               ralink,portmap = <0x2f>;
+       };
+
+       wmac@10180000 {
+               ralink,mtd-eeprom = <&factory 0>;
+       };
+
+       otg@101c0000 {
+               status = "okay";
+       };
+};
diff --git a/target/linux/ramips/dts/MINIEMBWIFI.dts b/target/linux/ramips/dts/MINIEMBWIFI.dts
new file mode 100644 (file)
index 0000000..b026f0c
--- /dev/null
@@ -0,0 +1,92 @@
+/dts-v1/;
+
+/include/ "rt3050.dtsi"
+
+/ {
+       compatible = "MINIEMBWIFI", "ralink,rt3052-soc";
+       model = "Omnima MiniEMBWiFi";
+
+       pinctrl {
+               state_default: pinctrl0 {
+                       gpio {
+                               ralink,group = "spi", "i2c", "jtag", "rgmii", "mdio", "uartf";
+                               ralink,function = "gpio";
+                       };
+               };
+       };
+
+       gpio-leds {
+               compatible = "gpio-leds";
+
+               status {
+                       label = "miniembwifi:green:status";
+                       gpios = <&gpio0 9 1>;
+               };
+
+               wlan {
+                       label = "miniembwifi:green:wlan";
+                       gpios = <&gpio0 14 1>;
+               };
+       };
+
+       gpio-keys-polled {
+               compatible = "gpio-keys-polled";
+               #address-cells = <1>;
+               #size-cells = <0>;
+               poll-interval = <20>;
+
+               reset {
+                       label = "reset";
+                       gpios = <&gpio0 12 1>;
+                       linux,code = <0x198>;
+               };
+       };
+
+       cfi@1f000000 {
+               compatible = "cfi-flash";
+               reg = <0x1f000000 0x800000>;
+               bank-width = <2>;
+               device-width = <2>;
+               #address-cells = <1>;
+               #size-cells = <1>;
+
+               partition@0 {
+                       label = "u-boot";
+                       reg = <0x0 0x30000>;
+                       read-only;
+               };
+
+               partition@30000 {
+                       label = "u-boot-env";
+                       reg = <0x30000 0x10000>;
+                       read-only;
+               };
+
+               factory: partition@40000 {
+                       label = "factory";
+                       reg = <0x40000 0x10000>;
+                       read-only;
+               };
+
+               partition@50000 {
+                       label = "firmware";
+                       reg = <0x50000 0x7b0000>;
+               };
+       };
+
+       ethernet@10100000 {
+               mtd-mac-address = <&factory 0x28>;
+       };
+
+       esw@10110000 {
+               ralink,portmap = <0x2f>;
+       };
+
+       wmac@10180000 {
+               ralink,mtd-eeprom = <&factory 0>;
+       };
+
+       otg@101c0000 {
+               status = "okay";
+       };
+};
diff --git a/target/linux/ramips/dts/OMNI-EMB-HPM.dts b/target/linux/ramips/dts/OMNI-EMB-HPM.dts
deleted file mode 100644 (file)
index 9540f4f..0000000
+++ /dev/null
@@ -1,149 +0,0 @@
-/dts-v1/;
-
-/include/ "rt3883.dtsi"
-
-/ {
-       compatible = "OMNI-EMB-HPM", "ralink,rt3883-soc";
-       model = "Omnima EMB HPM";
-
-       chosen {
-               bootargs = "console=ttyS0,115200";
-       };
-
-       palmbus@10000000 {
-               spi@b00 {
-                       status = "okay";
-
-                       m25p80@0 {
-                               compatible = "macronix,mx25l12805d";
-                               spi-max-frequency = <25000000>;
-                               reg = <0>;
-                               #address-cells = <1>;
-                               #size-cells = <1>;
-
-                               partition@0 {
-                                       reg = <0x0 0x0030000>;
-                                       label = "u-boot";
-                                       read-only;
-                               };
-
-                               partition@30000 {
-                                       reg = <0x00030000 0x00010000>;
-                                       label = "config";
-                                       read-only;
-                               };
-
-                               factory: partition@40000 {
-                                       reg = <0x00040000 0x00010000>;
-                                       label = "factory";
-                                       read-only;
-                               };
-
-                               partition@50000 {
-                                       reg = <0x00050000 0x00fb0000>;
-                                       label = "firmware";
-                               };
-                       };
-               };
-       };
-
-       pinctrl {
-               state_default: pinctrl0 {
-                       gpio {
-                               ralink,group = "i2c", "jtag", "uartf";
-                               ralink,function = "gpio";
-                       };
-               };
-       };
-
-       ethernet@10100000 {
-               phy-handle = <&phy0>;
-               phy-mode = "rgmii";
-               mtd-mac-address = <&factory 0x28>;
-
-               mdio-bus {
-                       status = "okay";
-
-                       phy0: ethernet-phy@4 {
-                               reg = <4>;
-                       };
-               };
-       };
-
-       wmac@10180000 {
-               ralink,mtd-eeprom = <&factory 0>;
-       };
-
-       ehci@101c0000 {
-               status = "okay";
-       };
-
-       ohci@101c1000 {
-               status = "okay";
-       };
-
-       gpio-keys-polled {
-               compatible = "gpio-keys-polled";
-               #address-cells = <1>;
-               #size-cells = <0>;
-               poll-interval = <100>;
-
-               reset {
-                       label = "reset";
-                       gpios = <&gpio0 14 0>;
-                       linux,code = <0x198>;
-               };
-       };
-
-       gpio-leds {
-               compatible = "gpio-leds";
-
-               power {
-                       label = "emb:orange:power";
-                       gpios = <&gpio0 7 1>;
-               };
-
-               status {
-                       label = "emb:green:status";
-                       gpios = <&gpio0 21 1>;
-               };
-
-               eth {
-                       label = "emb:green:eth";
-                       gpios = <&gpio0 20 1>;
-               };
-
-               eth2 {
-                       label = "emb:red:eth";
-                       gpios = <&gpio0 18 1>;
-               };
-
-               wifi {
-                       label = "emb:green:wifi";
-                       gpios = <&gpio0 17 1>;
-               };
-
-               wifi2 {
-                       label = "emb:red:wifi";
-                       gpios = <&gpio0 19 1>;
-               };
-       };
-
-       gpio_export {
-               compatible = "gpio-export";
-               #size-cells = <0>;
-               /* gpio 12 and 13 handle the OC input */
-
-               usb0 {
-                       gpio-export,name = "usb0";
-                       gpio-export,output = <1>;
-                       gpios = <&gpio0 2 0>;
-               };
-
-               usb1 {
-                       gpio-export,name = "usb1";
-                       gpio-export,output = <1>;
-                       gpios = <&gpio0 1 0>;
-               };
-       };
-};
diff --git a/target/linux/ramips/dts/OMNI-EMB.dts b/target/linux/ramips/dts/OMNI-EMB.dts
deleted file mode 100644 (file)
index aa3ddc4..0000000
+++ /dev/null
@@ -1,92 +0,0 @@
-/dts-v1/;
-
-/include/ "rt3050.dtsi"
-
-/ {
-       compatible = "OMNI-EMB", "ralink,rt3052-soc";
-       model = "Omnima MiniEMBWiFi";
-
-       pinctrl {
-               state_default: pinctrl0 {
-                       gpio {
-                               ralink,group = "spi", "i2c", "jtag", "rgmii", "mdio", "uartf";
-                               ralink,function = "gpio";
-                       };
-               };
-       };
-
-       gpio-leds {
-               compatible = "gpio-leds";
-
-               status {
-                       label = "emb:green:status";
-                       gpios = <&gpio0 9 1>;
-               };
-
-               wlan {
-                       label = "emb:green:wlan";
-                       gpios = <&gpio0 14 1>;
-               };
-       };
-
-       gpio-keys-polled {
-               compatible = "gpio-keys-polled";
-               #address-cells = <1>;
-               #size-cells = <0>;
-               poll-interval = <20>;
-
-               reset {
-                       label = "reset";
-                       gpios = <&gpio0 12 1>;
-                       linux,code = <0x198>;
-               };
-       };
-
-       cfi@1f000000 {
-               compatible = "cfi-flash";
-               reg = <0x1f000000 0x800000>;
-               bank-width = <2>;
-               device-width = <2>;
-               #address-cells = <1>;
-               #size-cells = <1>;
-
-               partition@0 {
-                       label = "u-boot";
-                       reg = <0x0 0x30000>;
-                       read-only;
-               };
-
-               partition@30000 {
-                       label = "u-boot-env";
-                       reg = <0x30000 0x10000>;
-                       read-only;
-               };
-
-               factory: partition@40000 {
-                       label = "factory";
-                       reg = <0x40000 0x10000>;
-                       read-only;
-               };
-
-               partition@50000 {
-                       label = "firmware";
-                       reg = <0x50000 0x7b0000>;
-               };
-       };
-
-       ethernet@10100000 {
-               mtd-mac-address = <&factory 0x28>;
-       };
-
-       esw@10110000 {
-               ralink,portmap = <0x2f>;
-       };
-
-       wmac@10180000 {
-               ralink,mtd-eeprom = <&factory 0>;
-       };
-
-       otg@101c0000 {
-               status = "okay";
-       };
-};
diff --git a/target/linux/ramips/dts/OMNI-PLUG.dts b/target/linux/ramips/dts/OMNI-PLUG.dts
deleted file mode 100644 (file)
index 25f5bca..0000000
+++ /dev/null
@@ -1,120 +0,0 @@
-/dts-v1/;
-
-/include/ "rt5350.dtsi"
-
-/ {
-       compatible = "OMNI-PLUG", "ralink,rt5350-soc";
-       model = "Omnima MiniPlug";
-
-       pinctrl {
-               state_default: pinctrl0 {
-                       gpio {
-                               ralink,group = "i2c", "jtag", "uartf";
-                               ralink,function = "gpio";
-                       };
-               };
-       };
-
-       gpio-leds {
-               compatible = "gpio-leds";
-
-               wlan {
-                       label = "miniplug:red:wlan";
-                       gpios = <&gpio0 9 0>;
-               };
-
-               mobile {
-                       label = "miniplug:green:mobile";
-                       gpios = <&gpio0 13 1>;
-               };
-       };
-
-       gpio-keys-polled {
-               compatible = "gpio-keys-polled";
-               #address-cells = <1>;
-               #size-cells = <0>;
-               poll-interval = <20>;
-
-               wps {
-                       label = "wps";
-                       gpios = <&gpio0 0 1>;
-                       linux,code = <0x211>;
-               };
-
-               reset {
-                       label = "reset";
-                       gpios = <&gpio0 10 1>;
-                       linux,code = <0x211>;
-               };
-
-               mode-one {
-                       label = "mode1";
-                       gpios = <&gpio0 11 1>;
-                       linux,code = <0x211>;
-               };
-
-               mode-two {
-                       label = "mode2";
-                       gpios = <&gpio0 12 1>;
-                       linux,code = <0x211>;
-               };
-       };
-
-       palmbus@10000000 {
-               gpio0: gpio@600 {
-                       status = "okay";
-               };
-
-               spi@b00 {
-                       status = "okay";
-
-                       m25p80@0 {
-                               #address-cells = <1>;
-                               #size-cells = <1>;
-                               compatible = "mx25l6405d";
-                               reg = <0 0>;
-                               linux,modalias = "m25p80", "mx25l6405d";
-                               spi-max-frequency = <10000000>;
-
-                               partition@0 {
-                                       label = "u-boot";
-                                       reg = <0x0 0x30000>;
-                                       read-only;
-                               };
-
-                               partition@30000 {
-                                       label = "u-boot-env";
-                                       reg = <0x30000 0x10000>;
-                                       read-only;
-                               };
-
-                               factory: partition@40000 {
-                                       label = "factory";
-                                       reg = <0x40000 0x10000>;
-                                       read-only;
-                               };
-
-                               partition@50000 {
-                                       label = "firmware";
-                                       reg = <0x50000 0x7b0000>;
-                               };
-                       };
-               };
-       };
-
-       ethernet@10100000 {
-               mtd-mac-address = <&factory 0x4>;
-       };
-
-       esw@10110000 {
-               ralink,portmap = <0x2f>;
-       };
-
-       wmac@10180000 {
-               ralink,mtd-eeprom = <&factory 0>;
-       };
-
-       otg@101c0000 {
-               status = "okay";
-       };
-};
index ae89d6ccabcf3d5e42a6c3b78c7b74f003cf1bd5..f3f40eb790abff2b3be91a7de5b4a870fddc1608 100644 (file)
@@ -574,9 +574,9 @@ Image/Build/Profile/NW718=$(call BuildFirmware/CustomFlashFactory/$(1),$(1),nw71
 
 Image/Build/Profile/M2M=$(call BuildFirmware/Default8M/$(1),$(1),m2m,M2M,Linux Kernel Image)
 
-Image/Build/Profile/OMNI-EMB=$(call BuildFirmware/Default8M/$(1),$(1),omni-emb,OMNI-EMB)
+Image/Build/Profile/MINIEMBPLUG=$(call BuildFirmware/Default8M/$(1),$(1),miniembplug,MINIEMBPLUG)
 
-Image/Build/Profile/OMNI-PLUG=$(call BuildFirmware/Default8M/$(1),$(1),omni-plug,OMNI-PLUG)
+Image/Build/Profile/MINIEMBWIFI=$(call BuildFirmware/Default8M/$(1),$(1),miniembwifi,MINIEMBWIFI)
 
 Image/Build/Profile/PSR-680W=$(call BuildFirmware/Default4M/$(1),$(1),psr-680w,PSR-680W)
 
@@ -742,8 +742,8 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/NBG-419N,$(1))
        $(call Image/Build/Profile/NCS601W,$(1))
        $(call Image/Build/Profile/NW718,$(1))
-       $(call Image/Build/Profile/OMNI-EMB,$(1))
-       $(call Image/Build/Profile/OMNI-PLUG,$(1))
+       $(call Image/Build/Profile/MINIEMBWIFI,$(1))
+       $(call Image/Build/Profile/MINIEMBPLUG,$(1))
        $(call Image/Build/Profile/PSR-680W,$(1))
        $(call Image/Build/Profile/PWH2004,$(1))
        $(call Image/Build/Profile/PX4885,$(1))
@@ -815,8 +815,8 @@ Image/Build/Profile/CYSWR1100=$(call BuildFirmware/Seama/$(1),$(1),cy-swr1100,CY
 
 Image/Build/Profile/DIR645=$(call BuildFirmware/Seama/$(1),$(1),dir-645,DIR-645,wrgn39_dlob.hans_dir645,$(ralink_default_fw_size_8M))
 
-omniembhpm_mtd_size=16449536
-Image/Build/Profile/OMNIEMBHPM=$(call BuildFirmware/CustomFlash/$(1),$(1),omni-emb-hpm,OMNI-EMB-HPM,$(omniembhpm_mtd_size))
+hpm_mtd_size=16449536
+Image/Build/Profile/HPM=$(call BuildFirmware/CustomFlash/$(1),$(1),hpm,HPM,$(hpm_mtd_size))
 
 define BuildFirmware/RTN56U/squashfs
        $(call BuildFirmware/Default8M/$(1),$(1),rt-n56u,RT-N56U)
@@ -838,7 +838,7 @@ ifeq ($(SUBTARGET),rt3883)
 define Image/Build/Profile/Default
        $(call Image/Build/Profile/CYSWR1100,$(1))
        $(call Image/Build/Profile/DIR645,$(1))
-       $(call Image/Build/Profile/OMNIEMBHPM,$(1))
+       $(call Image/Build/Profile/HPM,$(1))
        $(call Image/Build/Profile/RTN56U,$(1))
        $(call Image/Build/Profile/BR6475ND,$(1))
        $(call Image/Build/Profile/TEW691GR,$(1))
index 2f31715277263b98aa2812ce74a17e1fe8d31c54..ce25999b52d275ac27be94e5e0dcb777c9743d1b 100644 (file)
@@ -5,12 +5,12 @@
 # See /LICENSE for more information.
 #
 
-define Profile/OMNIEMBHPM
-       NAME:=Omnima EMB-HPM board
+define Profile/HPM
+       NAME:=Omnima HPM
        PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2
 endef
 
-define Profile/OMNIEMBHPM/Description
-       Package set compatible with the Omnima EMB-HPM board.
+define Profile/HPM/Description
+       Package set compatible with the Omnima HPM board.
 endef
-$(eval $(call Profile,OMNIEMBHPM))
+$(eval $(call Profile,HPM))