at91: add SAMA5D3 subtarget
authorFlorian Fainelli <florian@openwrt.org>
Wed, 3 Sep 2014 03:11:11 +0000 (03:11 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Wed, 3 Sep 2014 03:11:11 +0000 (03:11 +0000)
Add a subtarget for Atmel's SAMA5D3 Cortex-A5 based SoCs.

Signed-off-by: Florian Fainelli <florian@openwrt.org>
SVN-Revision: 42417

target/linux/at91/sama5d3/config-default [new file with mode: 0644]
target/linux/at91/sama5d3/target.mk [new file with mode: 0644]

diff --git a/target/linux/at91/sama5d3/config-default b/target/linux/at91/sama5d3/config-default
new file mode 100644 (file)
index 0000000..2cdd381
--- /dev/null
@@ -0,0 +1,12 @@
+CONFIG_SOC_SAMA5=y
+# CONFIG_SOC_SAM_V4_V5 is not set
+CONFIG_SOC_SAM_V7=y
+CONFIG_SOC_SAMA5D3=y
+CONFIG_MACH_SAMA5_DT=y
+# CONFIG_ARM_LPAE is not set
+# CONFIG_ARM_THUMBEE is not set
+# CONFIG_SWP_EMULATE is not set
+# CONFIG_CPU_ICACHE_DISABLE is not set
+# CONFIG_CPU_BPREDICT_DISABLE is not set
+# CONFIG_THUMB2_KERNEL is not set
+# CONFIG_XEN is not set
diff --git a/target/linux/at91/sama5d3/target.mk b/target/linux/at91/sama5d3/target.mk
new file mode 100644 (file)
index 0000000..d88e895
--- /dev/null
@@ -0,0 +1,7 @@
+BOARDNAME:=SAMA5D3 (Cortex-A5)
+CPU_TYPE:=cortex-a5
+
+define Target/Description
+       Build generic firmware for SAMA5D3 AT91 platforms
+       using the ARMv7 instruction set.
+endef