gcc: gcc 4.9.x disable libsanitize
authorFelix Fietkau <nbd@openwrt.org>
Sun, 5 Oct 2014 14:59:45 +0000 (14:59 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 5 Oct 2014 14:59:45 +0000 (14:59 +0000)
gcc 4.9.x enables building of libsanitize

- libsanitize needs some headers that are not available
  in uclibc (netrom/netrom.h)

according to buildroot project:
- build fail with musl
- need wordexp with uclibc which increases uclibc size
http://git.buildroot.net/buildroot/commit/?id=5f4d658d888b539de9a6247ae5b1a0999de5d4ec
http://git.buildroot.net/buildroot/commit/?id=554e29e267e6b36a0fd78c82cbad2c82d939eb7f

Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de>
SVN-Revision: 42767

toolchain/gcc/final/Makefile
toolchain/gcc/minimal/Makefile

index 3529616fd54ef0f751aaa307d4b29d7095495e4b..3fb5ccf83fe63466617c6045001284c0af354155 100644 (file)
@@ -4,6 +4,7 @@ include ../common.mk
 
 GCC_CONFIGURE += \
        --with-headers=$(TOOLCHAIN_DIR)/include \
+       --disable-libsanitizer \
        --enable-languages=$(TARGET_LANGUAGES) \
        --enable-shared \
        --enable-threads \
index a2564a18ee8a208cd72ef28f19ad52eef8aee2c4..0344e1a7eca3571005e9879f73711c06f1db88e8 100644 (file)
@@ -6,6 +6,7 @@ GCC_CONFIGURE += \
        --with-newlib \
        --without-headers \
        --enable-languages=c \
+       --disable-libsanitizer \
        --disable-libssp \
        --disable-shared \
        --disable-threads