use the Download/ macro to get ACX firmwares
authorNicolas Thill <nico@openwrt.org>
Mon, 15 Sep 2008 10:17:13 +0000 (10:17 +0000)
committerNicolas Thill <nico@openwrt.org>
Mon, 15 Sep 2008 10:17:13 +0000 (10:17 +0000)
SVN-Revision: 12612

package/acx-mac80211/Makefile
package/acx/Makefile

index ad498824ea984178effb209765dbc7750835e918..865719160a6cae5ad84b68ec9abe1fdb671dad81 100644 (file)
@@ -20,15 +20,6 @@ PKG_SOURCE_PROTO:=git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE_VERSION:=$(PKG_REV)
 
-PKG_FW_C16_NAME:=tiacx111c16
-PKG_FW_C16_URL:=http://teknoraver.net/software/acx-mac80211/
-#PKG_FW_C16_MD5SUM:=fcd07de4b25e1d2aaf3b78b27c5b7ee9   #version 1.2.1.34
-PKG_FW_C16_MD5SUM:=7026826460376f6b174f9225bd7781b9    #version 2.3.1.31
-
-PKG_FW_C19_NAME:=tiacx111c19
-PKG_FW_C19_URL:=http://ipkg.k1k2.de/files/
-PKG_FW_C19_MD5SUM:=a1fa9681e297b4e36e257090fc12265a
-
 include $(INCLUDE_DIR)/package.mk
 
 define KernelPackage/acx-mac80211
@@ -43,13 +34,24 @@ define KernelPackage/acx-mac80211/description
        Driver for acx111 cards (Mac80211 version)
 endef
 
-$(STAMP_BUILT): $(DL_DIR)/$(PKG_FW_C16_NAME) $(DL_DIR)/$(PKG_FW_C19_NAME)
 
-$(DL_DIR)/$(PKG_FW_C16_NAME):
-       $(SCRIPT_DIR)/download.pl "$(DL_DIR)" "$(PKG_FW_C16_NAME)" "$(PKG_FW_C16_MD5SUM)" $(PKG_FW_C16_URL)
+C16_FW:=tiacx111c16
+C19_FW:=tiacx111c19
+
+define Download/tiacx111c16
+  FILE:=$(C16_FW)
+  URL:=http://teknoraver.net/software/acx-mac80211/
+  MD5SUM:=7026826460376f6b174f9225bd7781b9
+endef
+$(eval $(call Download,tiacx111c16))
+
+define Download/tiacx111c19
+  FILE:=$(C19_FW)
+  URL:=http://ipkg.k1k2.de/files/
+  MD5SUM:=a1fa9681e297b4e36e257090fc12265a
+endef
+$(eval $(call Download,tiacx111c19))
 
-$(DL_DIR)/$(PKG_FW_C19_NAME):
-       $(SCRIPT_DIR)/download.pl "$(DL_DIR)" "$(PKG_FW_C19_NAME)" "$(PKG_FW_C19_MD5SUM)" $(PKG_FW_C19_URL)
 
 PKG_EXTRA_KCONFIG:= \
        CONFIG_ACX_MAC80211=m \
@@ -77,8 +79,8 @@ endef
 
 define KernelPackage/acx-mac80211/install
        $(INSTALL_DIR) $(1)/lib/firmware
-       $(INSTALL_DATA) $(DL_DIR)/$(PKG_FW_C16_NAME) $(1)/lib/firmware/
-       $(INSTALL_DATA) $(DL_DIR)/$(PKG_FW_C19_NAME) $(1)/lib/firmware/
+       $(INSTALL_DATA) $(DL_DIR)/$(C16_FW) $(1)/lib/firmware/
+       $(INSTALL_DATA) $(DL_DIR)/$(C19_FW) $(1)/lib/firmware/
 endef
 
 $(eval $(call KernelPackage,acx-mac80211))
index a15da698737ac185eb62c120823fd2cdd1e0655a..7db3f511523c42420cc5c9d658e5c0ee5e6eae41 100644 (file)
@@ -17,14 +17,6 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@SF/acx100
 PKG_MD5SUM:=7d5ce3215708e4e9f95cf567a9ee3a12
 
-PKG_FW_C16_NAME:=tiacx111c16
-PKG_FW_C16_URL:=http://teknoraver.net/software/acx-mac80211/
-PKG_FW_C16_MD5SUM:=7026826460376f6b174f9225bd7781b9
-
-PKG_FW_C19_NAME:=tiacx111c19
-PKG_FW_C19_URL:=http://ipkg.k1k2.de/files/
-PKG_FW_C19_MD5SUM:=a1fa9681e297b4e36e257090fc12265a
-
 PKG_UNPACK:= \
        bzcat $(DL_DIR)/$(PKG_SOURCE) | \
        $(TAR) -C $(KERNEL_BUILD_DIR) $(TAR_OPTIONS); \
@@ -45,13 +37,23 @@ define KernelPackage/acx/description
  This package contains a driver for TI ACX1xx 802.11a/b/g chipsets.
 endef
 
-$(STAMP_BUILT): $(DL_DIR)/$(PKG_FW_C16_NAME) $(DL_DIR)/$(PKG_FW_C19_NAME)
+C16_FW:=tiacx111c16
+C19_FW:=tiacx111c19
 
-$(DL_DIR)/$(PKG_FW_C16_NAME):
-       $(SCRIPT_DIR)/download.pl "$(DL_DIR)" "$(PKG_FW_C16_NAME)" "$(PKG_FW_C16_MD5SUM)" $(PKG_FW_C16_URL)
+define Download/tiacx111c16
+  FILE:=$(C16_FW)
+  URL:=http://teknoraver.net/software/acx-mac80211/
+  MD5SUM:=7026826460376f6b174f9225bd7781b9
+endef
+$(eval $(call Download,tiacx111c16))
+
+define Download/tiacx111c19
+  FILE:=$(C19_FW)
+  URL:=http://ipkg.k1k2.de/files/
+  MD5SUM:=a1fa9681e297b4e36e257090fc12265a
+endef
+$(eval $(call Download,tiacx111c19))
 
-$(DL_DIR)/$(PKG_FW_C19_NAME):
-       $(SCRIPT_DIR)/download.pl "$(DL_DIR)" "$(PKG_FW_C19_NAME)" "$(PKG_FW_C19_MD5SUM)" $(PKG_FW_C19_URL)
 
 define Build/Compile
        $(MAKE) -C $(LINUX_DIR) \
@@ -71,8 +73,8 @@ endef
 
 define KernelPackage/acx/install
        $(INSTALL_DIR) $(1)/lib/firmware
-       $(INSTALL_DATA) $(DL_DIR)/$(PKG_FW_C16_NAME) $(1)/lib/firmware/
-       $(INSTALL_DATA) $(DL_DIR)/$(PKG_FW_C19_NAME) $(1)/lib/firmware/
+       $(INSTALL_DATA) $(DL_DIR)/$(C16_FW) $(1)/lib/firmware/
+       $(INSTALL_DATA) $(DL_DIR)/$(C19_FW) $(1)/lib/firmware/
 endef
 
 $(eval $(call KernelPackage,acx))