uClibc: set the toolchain info at install time instead of prepare time, fixes staging...
authorFelix Fietkau <nbd@openwrt.org>
Tue, 1 Mar 2011 05:41:02 +0000 (05:41 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Tue, 1 Mar 2011 05:41:02 +0000 (05:41 +0000)
SVN-Revision: 25803

toolchain/uClibc/Makefile

index 0ce9554e78d568e8df6cfe002bfeb2f2126b8976..642f7fba4cdf516b27c0a8fd9a2a23d6e86870c3 100644 (file)
@@ -62,7 +62,6 @@ GEN_CONFIG=$(SCRIPT_DIR)/kconfig.pl -n \
        $(CONFIG_DIR)/$(ARCH)$(if $(wildcard $(CONFIG_DIR)/$(ARCH).$(BOARD)),.$(BOARD))
 
 define Host/Prepare
        $(CONFIG_DIR)/$(ARCH)$(if $(wildcard $(CONFIG_DIR)/$(ARCH).$(BOARD)),.$(BOARD))
 
 define Host/Prepare
-       $(call Host/SetToolchainInfo)
        $(call Host/Prepare/Default)
        $(if $(strip $(QUILT)), \
                cd $(HOST_BUILD_DIR); \
        $(call Host/Prepare/Default)
        $(if $(strip $(QUILT)), \
                cd $(HOST_BUILD_DIR); \
@@ -132,6 +131,7 @@ define Host/Compile
 endef
 
 define Host/Install
 endef
 
 define Host/Install
+       $(call Host/SetToolchainInfo)
        $(UCLIBC_MAKE) PREFIX= utils
        $(INSTALL_DIR) $(TOOLCHAIN_DIR)/bin
        $(INSTALL_BIN) \
        $(UCLIBC_MAKE) PREFIX= utils
        $(INSTALL_DIR) $(TOOLCHAIN_DIR)/bin
        $(INSTALL_BIN) \