ar71xx: create profile and build image for the TL-WDR4300 board
authorGabor Juhos <juhosg@openwrt.org>
Tue, 19 Jun 2012 11:51:20 +0000 (11:51 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Tue, 19 Jun 2012 11:51:20 +0000 (11:51 +0000)
SVN-Revision: 32461

target/linux/ar71xx/generic/profiles/tp-link.mk
target/linux/ar71xx/image/Makefile

index 9a0d2ffa1cb6ab2150cac28f0b292f0cb5fc226b..23e6b96e2e540c295c899fe2f453b19b22fa85db 100644 (file)
@@ -94,6 +94,17 @@ endef
 $(eval $(call Profile,TLWA901))
 
 
+define Profile/TLWDR4300
+       NAME:=TP-LINK TL-WDR4300
+       PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/TLWDR4300/Description
+       Package set optimized for the TP-LINK TL-WDR4300.
+endef
+$(eval $(call Profile,TLWDR4300))
+
+
 define Profile/TLWR740
        NAME:=TP-LINK TL-WR740N/ND
        PACKAGES:=
index 0a7d75a3dfa2d0c3cc2513f9e273391bfa5db046..06e39561d74791868a81a86a0971d14074f203ac 100644 (file)
@@ -974,6 +974,11 @@ define Image/Build/Profile/TLWR2543
        $(call Image/Build/Template/$(fs_64kraw)/$(1),TPLINK-LZMA,tl-wr2543n-v1,$(tlwr2543_cmdline),0x25430001,1,8Mlzma)
 endef
 
+tlwdr4300_cmdline=board=TL-WDR4300 console=ttyS0,115200
+define Image/Build/Profile/TLWDR4300
+       $(call Image/Build/Template/$(fs_64kraw)/$(1),TPLINK-LZMA,tl-wdr4300-v1,$(tlwdr4300_cmdline),0x43000001,1,8Mlzma)
+endef
+
 wndr3700_cmdline=board=WNDR3700 console=ttyS0,115200
 wndr3700_mtdlayout=mtdparts=spi0.0:320k(u-boot)ro,128k(u-boot-env)ro,1024k(kernel),6656k(rootfs),64k(art)ro,7680k@0x70000(firmware)
 wndr3700v2_mtdlayout=mtdparts=spi0.0:320k(u-boot)ro,128k(u-boot-env)ro,1024k(kernel),14848k(rootfs),64k(art)ro,15872k@0x70000(firmware)
@@ -1098,6 +1103,7 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/TLMR3420,$(1))
        $(call Image/Build/Profile/TLWA701,$(1))
        $(call Image/Build/Profile/TLWA901,$(1))
+       $(call Image/Build/Profile/TLWDR4300,$(1))
        $(call Image/Build/Profile/TLWR703,$(1))
        $(call Image/Build/Profile/TLWR740,$(1))
        $(call Image/Build/Profile/TLWR741,$(1))