Toto, we don't support Linux 2.4 anymore..
authorImre Kaloz <kaloz@openwrt.org>
Tue, 5 Oct 2010 14:15:46 +0000 (14:15 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Tue, 5 Oct 2010 14:15:46 +0000 (14:15 +0000)
SVN-Revision: 23245

package/broadcom-diag/src/diag.h
target/Config.in
tools/Makefile

index eae5872..698c376 100644 (file)
@@ -95,13 +95,8 @@ static struct platform_t platform;
 static void register_buttons(struct button_t *b);
 static void unregister_buttons(struct button_t *b);
 
-#ifndef LINUX_2_4
 static void hotplug_button(struct work_struct *work);
 static irqreturn_t button_handler(int irq, void *dev_id);
-#else
-static void hotplug_button(struct event_t *event);
-static irqreturn_t button_handler(int irq, void *dev_id, struct pt_regs *regs);
-#endif
 
 /* leds */
 
index 21cc3a4..6e45b64 100644 (file)
@@ -2,9 +2,6 @@ source "tmp/.config-target.in"
 
 # Kernel/Hardware features
 
-config LINUX_2_4
-       bool
-
 config LINUX_2_6
        bool
 
index ac4d62c..5c6a499 100644 (file)
@@ -19,7 +19,7 @@ tools-y += sstrip ipkg-utils genext2fs libuuid mtd-utils mkimage
 tools-y += firmware-utils patch-cmdline quilt yaffs2
 tools-$(CONFIG_TARGET_orion) += wrt350nv2-builder upslug2
 tools-$(CONFIG_TARGET_x86) += qemu
-ifneq ($(CONFIG_LINUX_2_4)$(CONFIG_LINUX_2_6_25)$(CONFIG_TARGET_ar71xx),)
+ifneq ($(CONFIG_LINUX_2_6_25)$(CONFIG_TARGET_ar71xx),)
 tools-y += squashfs lzma-old
 else
 tools-y += squashfs4 lzma