fix for GREP_OPTIONS
authorFlorian Fainelli <florian@openwrt.org>
Sat, 31 Jul 2010 22:32:21 +0000 (22:32 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 31 Jul 2010 22:32:21 +0000 (22:32 +0000)
When using GREP_OPTIONS to supply default options to grep, the buildsystem might get broken (For example adding --color=always breaks it)
This patch will empty the GREP_OPTIONS to prevent the described (and any other) problems related to GREP_OPTIONS

Signed-off-by: Maarten Bezemer <m.m.bezemer@utwente.nl>
SVN-Revision: 22443

Makefile
rules.mk

index db79274c9af0e2f1b9666841a780fb5bc154854f..31042b2e09cf267ba65d24e44acd641ea821ea81 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -24,6 +24,8 @@ ifneq ($(OPENWRT_BUILD),1)
 
   override OPENWRT_BUILD=1
   export OPENWRT_BUILD
+  GREP_OPTIONS=
+  export GREP_OPTIONS
   include $(TOPDIR)/include/debug.mk
   include $(TOPDIR)/include/depends.mk
   include $(TOPDIR)/include/toplevel.mk
index 0cb72ac6bcb8d36ace9ce0385f8385c8fcfc324d..2add087133eb0dfe982267ba707543674d39256d 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -18,6 +18,9 @@ TMP_DIR:=$(TOPDIR)/tmp
 
 export SHELL=/usr/bin/env bash -c '. $(TOPDIR)/include/shell.sh; eval "$$2"' --
 
+GREP_OPTIONS=
+export GREP_OPTIONS
+
 qstrip=$(strip $(subst ",,$(1)))
 #"))