generic/4.0: upgrade to 4.0-rc7
authorImre Kaloz <kaloz@openwrt.org>
Tue, 7 Apr 2015 21:34:38 +0000 (21:34 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Tue, 7 Apr 2015 21:34:38 +0000 (21:34 +0000)
Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
SVN-Revision: 45305

include/kernel-version.mk
target/linux/generic/patches-4.0/680-NET-skip-GRO-for-foreign-MAC-addresses.patch
target/linux/generic/patches-4.0/834-ledtrig-libata.patch
target/linux/generic/patches-4.0/863-gpiommc.patch
target/linux/generic/patches-4.0/902-debloat_proc.patch
target/linux/generic/patches-4.0/903-debloat_direct_io.patch

index 522c2f3a2cf55f5de92847bc125dd30d8b1d212c..c07171c6f771dc04231ae22b1380168bc44602af 100644 (file)
@@ -7,14 +7,14 @@ LINUX_VERSION-3.10 = .58
 LINUX_VERSION-3.13 = .7
 LINUX_VERSION-3.14 = .35
 LINUX_VERSION-3.18 = .11
-LINUX_VERSION-4.0 = -rc6
+LINUX_VERSION-4.0 = -rc7
 
 LINUX_KERNEL_MD5SUM-3.8.13  = 2af19d06cd47ec459519159cdd10542d
 LINUX_KERNEL_MD5SUM-3.10.58 = 3ff3478b6351143cef22d4b81cf48b01
 LINUX_KERNEL_MD5SUM-3.13.7  = 370adced5e5c1cb1d0d621c2dae2723f
 LINUX_KERNEL_MD5SUM-3.14.35 = e5e92c40d14bc8ae9a8701db4e1cbb27
 LINUX_KERNEL_MD5SUM-3.18.11 = 2def91951c9cedf7896efb864e0c090c
-LINUX_KERNEL_MD5SUM-4.0-rc6 = bec0aeeacab2852d9a17ccbfa7e280f8
+LINUX_KERNEL_MD5SUM-4.0-rc7 = 26db663899b1a54397b4f184ca05f213
 
 ifdef KERNEL_PATCHVER
   LINUX_VERSION:=$(KERNEL_PATCHVER)$(strip $(LINUX_VERSION-$(KERNEL_PATCHVER)))
index 48d73d1301e3c6250ff34f08842b66497a9d0c18..f0d5b4715eb9fd5240f50d0cb3c882e2967065ae 100644 (file)
@@ -17,7 +17,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
 
 --- a/net/core/dev.c
 +++ b/net/core/dev.c
-@@ -4005,6 +4005,9 @@ static enum gro_result dev_gro_receive(s
+@@ -4007,6 +4007,9 @@ static enum gro_result dev_gro_receive(s
        enum gro_result ret;
        int grow;
  
@@ -27,7 +27,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
        if (!(skb->dev->features & NETIF_F_GRO))
                goto normal;
  
-@@ -5152,6 +5155,48 @@ static void __netdev_adjacent_dev_unlink
+@@ -5154,6 +5157,48 @@ static void __netdev_adjacent_dev_unlink
                                           &upper_dev->adj_list.lower);
  }
  
@@ -76,7 +76,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
  static int __netdev_upper_dev_link(struct net_device *dev,
                                   struct net_device *upper_dev, bool master,
                                   void *private)
-@@ -5212,6 +5257,7 @@ static int __netdev_upper_dev_link(struc
+@@ -5214,6 +5259,7 @@ static int __netdev_upper_dev_link(struc
                        goto rollback_lower_mesh;
        }
  
@@ -84,7 +84,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
        call_netdevice_notifiers(NETDEV_CHANGEUPPER, dev);
        return 0;
  
-@@ -5329,6 +5375,7 @@ void netdev_upper_dev_unlink(struct net_
+@@ -5331,6 +5377,7 @@ void netdev_upper_dev_unlink(struct net_
        list_for_each_entry(i, &upper_dev->all_adj_list.upper, list)
                __netdev_adjacent_dev_unlink(dev, i->dev);
  
@@ -92,7 +92,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
        call_netdevice_notifiers(NETDEV_CHANGEUPPER, dev);
  }
  EXPORT_SYMBOL(netdev_upper_dev_unlink);
-@@ -5868,6 +5915,7 @@ int dev_set_mac_address(struct net_devic
+@@ -5870,6 +5917,7 @@ int dev_set_mac_address(struct net_devic
        if (err)
                return err;
        dev->addr_assign_type = NET_ADDR_SET;
index b59483ec2515db5f5aa15d3d74246d6d674be7ef..a3a606275e1c921ab68a245a66a69e30cda99258 100644 (file)
@@ -69,7 +69,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
  /**
   *    ata_build_rw_tf - Build ATA taskfile for given read/write request
   *    @tf: Target ATA taskfile
-@@ -4742,6 +4755,9 @@ struct ata_queued_cmd *ata_qc_new_init(s
+@@ -4753,6 +4766,9 @@ struct ata_queued_cmd *ata_qc_new_init(s
                if (tag < 0)
                        return NULL;
        }
@@ -79,7 +79,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
  
        qc = __ata_qc_from_tag(ap, tag);
        qc->tag = tag;
-@@ -5636,6 +5652,9 @@ struct ata_port *ata_port_alloc(struct a
+@@ -5647,6 +5663,9 @@ struct ata_port *ata_port_alloc(struct a
        ap->stats.unhandled_irq = 1;
        ap->stats.idle_irq = 1;
  #endif
@@ -89,7 +89,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
        ata_sff_port_init(ap);
  
        return ap;
-@@ -5657,6 +5676,12 @@ static void ata_host_release(struct devi
+@@ -5668,6 +5687,12 @@ static void ata_host_release(struct devi
  
                kfree(ap->pmp_link);
                kfree(ap->slave_link);
@@ -102,7 +102,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
                kfree(ap);
                host->ports[i] = NULL;
        }
-@@ -6103,7 +6128,23 @@ int ata_host_register(struct ata_host *h
+@@ -6114,7 +6139,23 @@ int ata_host_register(struct ata_host *h
                host->ports[i]->print_id = atomic_inc_return(&ata_print_id);
                host->ports[i]->local_port_no = i + 1;
        }
index b46f8766783fef2a0a18b0ae104d4255a516931f..3433e200199045a36c6cc0a40d7f8279678f6571 100644 (file)
 +be done automatically.
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -4482,6 +4482,11 @@ T:      git git://linuxtv.org/anttip/media_tr
+@@ -4481,6 +4481,11 @@ T:      git git://linuxtv.org/anttip/media_tr
  S:    Maintained
  F:    drivers/media/usb/hackrf/
  
index 26a217553befb2fca344d0f3b5dc0983c2783fba..ca9fd91efce5974b24c7ca3f216970a6efd5afe1 100644 (file)
@@ -1,6 +1,6 @@
 --- a/fs/locks.c
 +++ b/fs/locks.c
-@@ -2641,6 +2641,8 @@ static const struct file_operations proc
+@@ -2640,6 +2640,8 @@ static const struct file_operations proc
  
  static int __init proc_locks_init(void)
  {
                goto err;
 --- a/net/core/sock.c
 +++ b/net/core/sock.c
-@@ -2956,6 +2956,8 @@ static __net_initdata struct pernet_oper
+@@ -2975,6 +2975,8 @@ static __net_initdata struct pernet_oper
  
  static int __init proto_init(void)
  {
index cb32df20944c97b45dc6760645b32c4429dd9c3e..1b5453bc2b4512ed55a66e295e30ebf7157b1af2 100644 (file)
@@ -26,7 +26,7 @@
  endif
 --- a/include/linux/fs.h
 +++ b/include/linux/fs.h
-@@ -2614,12 +2614,25 @@ enum {
+@@ -2615,12 +2615,25 @@ enum {
        DIO_ASYNC_EXTEND = 0x04,
  };