tools/cmake: remove HOST_CONFIGURE_CMD and re-distribute the args & vars
authorAlexandru Ardelean <ardeleanalex@gmail.com>
Thu, 12 Jan 2017 13:31:13 +0000 (15:31 +0200)
committerJo-Philipp Wich <jo@mein.io>
Wed, 1 Feb 2017 15:03:56 +0000 (16:03 +0100)
The final semantic is the same, but this is a bit more correct.

Build tested on Windows 10 (yes, there is some
Ubuntu mode for Windows 10, and I've been also building LEDE
on it for a few weeks).

Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
tools/cmake/Makefile

index f3712391a6acf1127ceaffa4590b86f77a3a54dd..d6f03e42089264838c7cc202e42c8fe6294ab451 100644 (file)
@@ -19,15 +19,12 @@ HOST_CONFIGURE_PARALLEL:=1
 
 include $(INCLUDE_DIR)/host-build.mk
 
-HOST_CONFIGURE_CMD := \
-       MAKEFLAGS="$(HOST_JOBS)" \
-       $(BASH) ./configure \
-               $(if $(MAKE_JOBSERVER),--parallel="$(MAKE_JOBSERVER)")
-
 HOST_CONFIGURE_VARS += \
+       MAKEFLAGS="$(HOST_JOBS)" \
        CXXFLAGS="$(HOST_CFLAGS)"
 
 HOST_CONFIGURE_ARGS := \
+       $(if $(MAKE_JOBSERVER),--parallel="$(MAKE_JOBSERVER)") \
        --prefix=$(STAGING_DIR_HOST)
 
 ifneq ($(findstring c,$(OPENWRT_VERBOSE)),)