lantiq: only call Image/Prepare/Profile for defined profiles
authorFelix Fietkau <nbd@nbd.name>
Tue, 7 Jun 2016 07:35:18 +0000 (09:35 +0200)
committerFelix Fietkau <nbd@nbd.name>
Tue, 7 Jun 2016 07:35:18 +0000 (09:35 +0200)
Signed-off-by: Felix Fietkau <nbd@nbd.name>
target/linux/lantiq/image/Makefile

index a601d38c11861f8cc9588d50f514cc9813c31235..b31ea77257472e98d59639bb1a2c66d4ee4b37aa 100644 (file)
@@ -715,7 +715,7 @@ endef
 TARGET_DEVICES += VGV7519BRN
 
 define Image/Prepare
-       $(call Image/Prepare/Profile,$(PROFILE))
+       $(if $(Image/Build/Profile/$(PROFILE)),$(call Image/Prepare/Profile,$(PROFILE)))
 endef
 
 endif