ramips: rt305x: add support for the Petatel PSR-680W Wireless CDMA Router
authorGabor Juhos <juhosg@openwrt.org>
Tue, 19 Jun 2012 09:52:15 +0000 (09:52 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Tue, 19 Jun 2012 09:52:15 +0000 (09:52 +0000)
This patch adds support for the Korean made Petatel PSR-680W Wireless CDMA Router.
The platform is based on Ralink RT3052.
http://wiki.openwrt.org/toh/petatel/psr-680w

Signed-off-by: Dmitry Shmygov <shmygov at rambler.ru>
SVN-Revision: 32450

12 files changed:
target/linux/ramips/base-files/etc/diag.sh
target/linux/ramips/base-files/etc/hotplug.d/firmware/10-rt2x00-eeprom
target/linux/ramips/base-files/etc/uci-defaults/network
target/linux/ramips/base-files/lib/preinit/06_set_iface_mac
target/linux/ramips/base-files/lib/ramips.sh
target/linux/ramips/base-files/lib/upgrade/platform.sh
target/linux/ramips/files/arch/mips/include/asm/mach-ralink/machine.h
target/linux/ramips/files/arch/mips/ralink/rt305x/Kconfig
target/linux/ramips/files/arch/mips/ralink/rt305x/Makefile
target/linux/ramips/files/arch/mips/ralink/rt305x/mach-psr-680w.c [new file with mode: 0644]
target/linux/ramips/image/Makefile
target/linux/ramips/rt305x/config-3.3

index 78c9e945b33b25528896ff91ffb090fac63b48b1..95e504f1da3207b950fba3f3495704b7e3f3897f 100755 (executable)
@@ -60,6 +60,9 @@ get_status_led() {
        omni-emb)
                status_led="emb:green:status"
                ;;
+       psr-680w)
+               status_led="psr-680w:red:wan"
+               ;;
        pwh2004)
                status_led="pwh2004:green:power"
                ;;
index d93e60a9a6fb0cef2a8417a8f5e72b7ea51fa6fe..c5d0d6978b45ea75d5f6b9746028270fec1613e3 100644 (file)
@@ -60,6 +60,7 @@ case "$FIRMWARE" in
        nbg-419n | \
        nw718 | \
        omni-emb | \
+       psr-680w | \
        rt-n15 | \
        rt-n56u | \
        sl-r7205 | \
index 43d572692102074bbb1eab5f5e990df4acc14fdb..bbf03344370e648bc2a60eede67acbf0489cef73 100755 (executable)
@@ -24,6 +24,7 @@ ramips_setup_interfaces()
        argus-atp52b | \
        b2c | \
        nw718 | \
+       psr-680w | \
        sl-r7205 | \
        w502u | \
        wr6202)
@@ -93,6 +94,7 @@ ramips_setup_macs()
        b2c | \
        f5d8235-v1 | \
        nw718 | \
+       psr-680w | \
        rt-n15 | \
        sl-r7205 | \
        wl-351)
index b02dfab8131c8b61be4c1e01bb3e7c894fbcf9b6..69d1b8cb20274af1f316c4b7a11c462c9c2a2329 100644 (file)
@@ -12,6 +12,7 @@ preinit_set_mac_address() {
        esr-9753 |\
        freestation5 |\
        nw718 |\
+       psr-680w |\
        rt-n56u |\
        sl-r7205)
                mac=$(ramips_get_mac_binary factory 4)
index 486d1372982b1e9edfb41dd8f3f9244446ec9233..a5a173436e11b1f705f7e126fdeb18396b02a1a3 100755 (executable)
@@ -101,6 +101,9 @@ ramips_board_name() {
        *"Omnima MiniEMBWiFi")
                name="omni-emb"
                ;;
+       *"Petatel PSR-680W"*)
+               name="psr-680w"
+               ;;
        *"PWH2004")
                name="pwh2004"
                ;;
index 229cbe5435022a35ceff987787f8c6caf6c4cf32..1292b83e79ce7d517e6e433a45c0f1513ef0c8e1 100755 (executable)
@@ -27,6 +27,7 @@ platform_check_image() {
        nbg-419n | \
        nw718 | \
        omni-emb | \
+       psr-680w | \
        rt-g32-b1 | \
        rt-n10-plus | \
        rt-n15 | \
index 84986805213bbcb1587ad696f3a3bc2b81ffdc07..d0476f59ba2fadfc06cb45cb9782fa701f0eb840 100644 (file)
@@ -43,6 +43,7 @@ enum ramips_mach_type {
        RAMIPS_MACH_MOFI3500_3GN,       /* MoFi Network MOFI3500-3GN */
        RAMIPS_MACH_NBG_419N,           /* ZyXEL NBG-419N */
        RAMIPS_MACH_OMNI_EMB,           /* Omnima MiniEMBWiFi */
+       RAMIPS_MACH_PSR_680W,           /* Petatel PSR-680W Wireless 3G Router*/
        RAMIPS_MACH_PWH2004,            /* Prolink 2004H / Abocom 5205 */
        RAMIPS_MACH_SL_R7205,           /* Skylink SL-R7205 Wireless 3G Router*/
        RAMIPS_MACH_V22RW_2X2,          /* Ralink AP-RT3052-V22RW-2X2 */
index f2a7d848706c155c32385241305f4e3657a6e12d..15d3a4c2912f1f3d168c7802e100746602565cc2 100644 (file)
@@ -104,6 +104,11 @@ config RT305X_MACH_OMNI_EMB
        select RALINK_DEV_GPIO_BUTTONS
        select RALINK_DEV_GPIO_LEDS
 
+config RT305X_MACH_PSR_680W
+       bool "Petatel PSR-680W Wireless 3G Router support"
+       select RALINK_DEV_GPIO_BUTTONS
+       select RALINK_DEV_GPIO_LEDS
+
 config RT305X_MACH_PWH2004
        bool "Prolink PWH2004 / Abocom WR5205 support (32M RAM, 8M flash)"
        select RALINK_DEV_GPIO_BUTTONS
index 9cbd04dda98c4d9470671367382da1099cf3ec02..9fe1991fc309496ef7fadfbe3ee87b658be72fad 100644 (file)
@@ -24,6 +24,7 @@ obj-$(CONFIG_RT305X_MACH_MOFI3500_3GN)        += mach-mofi3500-3gn.o
 obj-$(CONFIG_RT305X_MACH_NBG_419N)     += mach-nbg-419n.o
 obj-$(CONFIG_RT305X_MACH_NW718)                += mach-nw718.o
 obj-$(CONFIG_RT305X_MACH_OMNI_EMB)     += mach-omni-emb.o
+obj-$(CONFIG_RT305X_MACH_PSR_680W)     += mach-psr-680w.o
 obj-$(CONFIG_RT305X_MACH_PWH2004)      += mach-pwh2004.o
 obj-$(CONFIG_RT305X_MACH_RT_G32_REVB)  += mach-rt-g32-revb.o
 obj-$(CONFIG_RT305X_MACH_RT_N10_PLUS)  += mach-rt-n10-plus.o
diff --git a/target/linux/ramips/files/arch/mips/ralink/rt305x/mach-psr-680w.c b/target/linux/ramips/files/arch/mips/ralink/rt305x/mach-psr-680w.c
new file mode 100644 (file)
index 0000000..a6d10f7
--- /dev/null
@@ -0,0 +1,73 @@
+/*
+ *  Petatel PSR-680W Wireless 3G Router support
+ *
+ *  Copyright (C) 2012 Dmitry Shmygov <shmygov@rambler.ru>
+ *
+ *  This program is free software; you can redistribute it and/or modify it
+ *  under the terms of the GNU General Public License version 2 as published
+ *  by the Free Software Foundation.
+ */
+
+#include <linux/init.h>
+#include <linux/platform_device.h>
+
+#include <asm/mach-ralink/machine.h>
+#include <asm/mach-ralink/dev-gpio-buttons.h>
+#include <asm/mach-ralink/dev-gpio-leds.h>
+#include <asm/mach-ralink/rt305x.h>
+#include <asm/mach-ralink/rt305x_regs.h>
+
+#include "devices.h"
+
+#define PSR_680W_GPIO_BUTTON_RESET     0       /* active low */
+
+#define PSR_680W_GPIO_LED_STATUS       19
+
+#define PSR_680W_KEYS_POLL_INTERVAL    20
+#define PSR_680W_KEYS_DEBOUNCE_INTERVAL        (3 * PSR_680W_KEYS_POLL_INTERVAL)
+
+
+static struct gpio_led psr_680w_leds_gpio[] __initdata = {
+       {
+               .name           = "psr-680w:red:wan",
+               .gpio           = PSR_680W_GPIO_LED_STATUS,
+               .active_low     = 1,
+       }
+};
+
+static struct gpio_keys_button psr_680w_gpio_buttons[] __initdata = {
+       {
+               .desc           = "reset",
+               .type           = EV_KEY,
+               .code           = KEY_RESTART,
+               .debounce_interval = PSR_680W_KEYS_DEBOUNCE_INTERVAL,
+               .gpio           = PSR_680W_GPIO_BUTTON_RESET,
+               .active_low     = 1,
+       }
+};
+
+static void __init psr_680w_init(void)
+{
+       rt305x_gpio_init((RT305X_GPIO_MODE_I2S_UARTF << RT305X_GPIO_MODE_UART0_SHIFT) |
+                               RT305X_GPIO_MODE_SPI |
+                               RT305X_GPIO_MODE_JTAG |
+                               RT305X_GPIO_MODE_MDIO |
+                               RT305X_GPIO_MODE_RGMII);
+
+       rt305x_register_flash(0);
+
+       rt305x_esw_data.vlan_config = RT305X_ESW_VLAN_CONFIG_WLLLL;
+       rt305x_register_ethernet();
+       ramips_register_gpio_leds(-1, ARRAY_SIZE(psr_680w_leds_gpio),
+                                 psr_680w_leds_gpio);
+       ramips_register_gpio_buttons(-1, PSR_680W_KEYS_POLL_INTERVAL,
+                                    ARRAY_SIZE(psr_680w_gpio_buttons),
+                                    psr_680w_gpio_buttons);
+       rt305x_register_wifi();
+       rt305x_register_wdt();
+       rt305x_register_usb();
+}
+
+MIPS_MACHINE(RAMIPS_MACH_PSR_680W, "PSR-680W",
+            "Petatel PSR-680W Wireless 3G Router",
+            psr_680w_init);
index ebbc4b22450cb78d33437771df0b2e61c648fe4a..bf86134267f6324c9bf950413c9ef43ba764b91e 100644 (file)
@@ -367,6 +367,10 @@ define Image/Build/Profile/OMNIEMB
        $(call Image/Build/Template/$(fs_squash)/$(1),GENERIC_8M,omni-emb,OMNI-EMB,ttyS1,57600,phys)
 endef
 
+define Image/Build/Profile/PSR680W
+       $(call Image/Build/Template/$(fs_squash)/$(1),GENERIC_4M,psr-680w,PSR-680W,ttyS1,115200,phys)
+endef
+
 define Image/Build/Profile/PWH2004
        $(call Image/Build/Template/$(fs_squash)/$(1),GENERIC_8M,pwh2004,PWH2004,ttyS1,57600,phys)
 endef
@@ -454,6 +458,7 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/NBG419N,$(1))
        $(call Image/Build/Profile/NW718,$(1))
        $(call Image/Build/Profile/OMNIEMB,$(1))
+       $(call Image/Build/Profile/PSR680W,$(1))
        $(call Image/Build/Profile/PWH2004,$(1))
        $(call Image/Build/Profile/RTG32B1,$(1))
        $(call Image/Build/Profile/SLR7205,$(1))
index 6a546ef05dc2c23cb19c586357cd0e9e7d4840cf..019f899301603f7934a5c3fe4832ba19e8d88c3f 100644 (file)
@@ -100,6 +100,7 @@ CONFIG_RT305X_MACH_MOFI3500_3GN=y
 CONFIG_RT305X_MACH_NBG_419N=y
 CONFIG_RT305X_MACH_NW718=y
 CONFIG_RT305X_MACH_OMNI_EMB=y
+CONFIG_RT305X_MACH_PSR_680W=y
 CONFIG_RT305X_MACH_PWH2004=y
 CONFIG_RT305X_MACH_RT_G32_REVB=y
 CONFIG_RT305X_MACH_RT_N10_PLUS=y