build: fix kernel_*config targets on 4.19
authorPetr Štetiar <ynezz@true.cz>
Tue, 18 Jun 2019 21:45:37 +0000 (21:45 +0000)
committerPetr Štetiar <ynezz@true.cz>
Fri, 21 Jun 2019 13:23:49 +0000 (15:23 +0200)
Recent kernel versions need toolchain in order to properly configure
kernel, for example to set CC_HAS_ASM_GOTO config symbol, so missing
toolchain leads to the following error while running `make
kernel_oldconfig` on ath79 target with 4.19 kernel in the clean tree:

 init/Kconfig:17: syntax error
 init/Kconfig:16: invalid option
 ./scripts/clang-version.sh: line 15: mips-openwrt-linux-musl-gcc: command not found
 ./scripts/gcc-plugin.sh: line 11: mips-openwrt-linux-musl-gcc: command not found
 net/sched/Kconfig:44: warning: menuconfig statement without prompt
 make[4]: *** [scripts/kconfig/Makefile:69: oldconfig] Error 1

So in order to support this new kernel versions, this patch adds
toolchain as a hard dependency to the kernel_*config targets.

Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
Signed-off-by: Petr Štetiar <ynezz@true.cz>
include/toplevel.mk

index 36f790f8072a5fb9bf3f6f15adf26ca3e6896f43..133da9d830b5534ca39cc863b5be487252c635fb 100644 (file)
@@ -145,7 +145,7 @@ xconfig: scripts/config/qconf prepare-tmpinfo FORCE
        fi
        $< Config.in
 
-prepare_kernel_conf: .config FORCE
+prepare_kernel_conf: .config toolchain/install FORCE
 
 ifeq ($(wildcard staging_dir/host/bin/quilt),)
   prepare_kernel_conf: