libunwind: update to version 1.2.1
authorYousong Zhou <yszhou4tech@gmail.com>
Mon, 19 Jun 2017 06:41:47 +0000 (14:41 +0800)
committerJo-Philipp Wich <jo@mein.io>
Wed, 13 Dec 2017 15:02:24 +0000 (16:02 +0100)
Changes since 1.2

    a77b0cd Bump version to v1.2.1
    5f354cb mips/tilegx: Add missing unwind_i.h header file
    620d1c3 Add aarch64 getcontext functionality.

Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
(cherry picked from commit 77dc6a2ae7c94ac3d496ebab589d4574ac7169d0)

package/libs/libunwind/Makefile
package/libs/libunwind/patches/004-add-missing-unwind_i.h.patch [deleted file]

index ba22664b2875a9af6f139ac68bd67581d3013ea5..913d616234dd6bea002ff261a6d5b9202327d100 100644 (file)
@@ -9,12 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libunwind
-PKG_VERSION:=1.2
+PKG_VERSION:=1.2.1
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SAVANNAH/$(PKG_NAME)
-PKG_HASH:=1de38ffbdc88bd694d10081865871cd2bfbb02ad8ef9e1606aee18d65532b992
+PKG_HASH:=3f3ecb90e28cbe53fba7a4a27ccce7aad188d3210bb1964a923a731a27a75acb
 PKG_FIXUP:=autoreconf
 PKG_INSTALL:=1
 
diff --git a/package/libs/libunwind/patches/004-add-missing-unwind_i.h.patch b/package/libs/libunwind/patches/004-add-missing-unwind_i.h.patch
deleted file mode 100644 (file)
index 55a6849..0000000
+++ /dev/null
@@ -1,46 +0,0 @@
---- /dev/null  2017-05-16 16:52:50.220000000 +0800
-+++ b/src/mips/unwind_i.h      2016-06-13 11:43:06.310153501 +0800
-@@ -0,0 +1,43 @@
-+/* libunwind - a platform-independent unwind library
-+   Copyright (C) 2008 CodeSourcery
-+
-+This file is part of libunwind.
-+
-+Permission is hereby granted, free of charge, to any person obtaining
-+a copy of this software and associated documentation files (the
-+"Software"), to deal in the Software without restriction, including
-+without limitation the rights to use, copy, modify, merge, publish,
-+distribute, sublicense, and/or sell copies of the Software, and to
-+permit persons to whom the Software is furnished to do so, subject to
-+the following conditions:
-+
-+The above copyright notice and this permission notice shall be
-+included in all copies or substantial portions of the Software.
-+
-+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
-+EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
-+MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
-+NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE
-+LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION
-+OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION
-+WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.  */
-+
-+#ifndef unwind_i_h
-+#define unwind_i_h
-+
-+#include <stdint.h>
-+
-+#include <libunwind-mips.h>
-+
-+#include "libunwind_i.h"
-+
-+#define mips_lock                       UNW_OBJ(lock)
-+#define mips_local_resume               UNW_OBJ(local_resume)
-+#define mips_local_addr_space_init      UNW_OBJ(local_addr_space_init)
-+
-+extern int mips_local_resume (unw_addr_space_t as, unw_cursor_t *cursor,
-+                             void *arg);
-+
-+extern void mips_local_addr_space_init (void);
-+
-+#endif /* unwind_i_h */