ipq806x: add support for OpenMesh A42
authorSven Eckelmann <sven.eckelmann@open-mesh.com>
Thu, 30 Nov 2017 13:30:06 +0000 (14:30 +0100)
committerMathias Kresin <dev@kresin.me>
Sat, 13 Jan 2018 07:00:14 +0000 (08:00 +0100)
* QCA IPQ401x
* 256 MB of RAM
* 32 MB of SPI NOR flash (s25fl256s1)
  - 2x 15 MB available; but one of the 15 MB regions is the recovery image
* 2T2R 2.4 GHz
  - QCA4019 hw1.0 (SoC)
  - requires special BDF in QCA4019/hw1.0/board-2.bin with
    bus=ahb,bmi-chip-id=0,bmi-board-id=16,variant=OM-A42
* 2T2R 5 GHz
  - QCA4019 hw1.0 (SoC)
  - requires special BDF in QCA4019/hw1.0/board-2.bin with
    bus=ahb,bmi-chip-id=0,bmi-board-id=17,variant=OM-A42
* multi-color LED (controlled via red/green/blue GPIOs)
* 1x button (reset; kmod-input-gpio-keys compatible)
* external watchdog
  - triggered GPIO
* 1x USB (xHCI)
* TTL pins are on board (arrow points to VCC, then follows: GND, TX, RX)
* 2x gigabit ethernet
* powered only via POE
  - 802.3af POE on Ethernet 1
  - 18-24v passive POE (mode B) on Ethernet 2

The tool ap51-flash (https://github.com/ap51-flash/ap51-flash) should be
used to transfer the factory image to the u-boot when the device boots up.

Signed-off-by: Sven Eckelmann <sven.eckelmann@open-mesh.com>
target/linux/ipq806x/base-files/etc/board.d/02_network
target/linux/ipq806x/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
target/linux/ipq806x/base-files/lib/upgrade/openmesh.sh [new file with mode: 0644]
target/linux/ipq806x/base-files/lib/upgrade/platform.sh
target/linux/ipq806x/files-4.9/arch/arm/boot/dts/qcom-ipq4019-a42.dts [new file with mode: 0644]
target/linux/ipq806x/image/Makefile
target/linux/ipq806x/patches-4.9/0069-arm-boot-add-dts-files.patch

index 74a38eece6d5e800865fced1fbe3d9277a2bdc00..7d1d2ccc3ce224181248e8ffa63f83e0f07cd3a1 100755 (executable)
@@ -33,6 +33,9 @@ tplink,vr2600v)
        ucidef_add_switch "switch0" \
                "1:lan" "2:lan" "3:lan" "4:lan" "6@eth1" "5:wan" "0@eth0"
        ;;
+openmesh,a42)
+       ucidef_set_interfaces_lan_wan "eth1" "eth0"
+       ;;
 qcom,ipq8064-db149)
        ucidef_set_interface_lan "eth1 eth2 eth3"
        ucidef_add_switch "switch0" \
index 4aaa92305ba6964180101846fef5d3aa1aa4d312..61b7403160e6ac31e86d7b6fb66554f52aae8960 100644 (file)
@@ -50,6 +50,9 @@ case "$FIRMWARE" in
        avm,fritzbox-4040)
                /usr/bin/fritz_cal_extract -i 1 -s 0x400 -e 0x207 -l 12064 -o /lib/firmware/$FIRMWARE $(find_mtd_chardev "urlader_config")
                ;;
+       openmesh,a42)
+               ath10kcal_extract "0:ART" 4096 12064
+               ;;
        qcom,ap-dk01.1-c1)
                ath10kcal_extract "ART" 4096 12064
                ;;
@@ -60,6 +63,9 @@ case "$FIRMWARE" in
        avm,fritzbox-4040)
                /usr/bin/fritz_cal_extract -i 1 -s 0x400 -e 0x208 -l 12064 -o /lib/firmware/$FIRMWARE $(find_mtd_chardev "urlader_config")
                ;;
+       openmesh,a42)
+               ath10kcal_extract "0:ART" 20480 12064
+               ;;
        qcom,ap-dk01.1-c1)
                ath10kcal_extract "ART" 20480 12064
                ;;
diff --git a/target/linux/ipq806x/base-files/lib/upgrade/openmesh.sh b/target/linux/ipq806x/base-files/lib/upgrade/openmesh.sh
new file mode 100644 (file)
index 0000000..a2c79d9
--- /dev/null
@@ -0,0 +1,110 @@
+# The U-Boot loader of the OpenMesh devices requires image sizes and
+# checksums to be provided in the U-Boot environment.
+# The OpenMesh devices come with 2 main partitions - while one is active
+# sysupgrade will flash the other. The boot order is changed to boot the
+# newly flashed partition. If the new partition can't be booted due to
+# upgrade failures the previously used partition is loaded.
+
+platform_do_upgrade_openmesh() {
+       local tar_file="$1"
+       local restore_backup
+       local primary_kernel_mtd
+
+       local setenv_script="/tmp/fw_env_upgrade"
+
+       local kernel_mtd="$(find_mtd_index $PART_NAME)"
+       local kernel_offset="$(cat /sys/class/mtd/mtd${kernel_mtd}/offset)"
+       local total_size="$(cat /sys/class/mtd/mtd${kernel_mtd}/size)"
+
+       # detect to which flash region the new image is written to.
+       #
+       # 1. check what is the mtd index for the first flash region on this
+       #    device
+       # 2. check if the target partition ("inactive") has the mtd index of
+       #    the first flash region
+       #
+       #    - when it is: the new bootseq will be 1,2 and the first region is
+       #      modified
+       #    - when it isnt: bootseq will be 2,1 and the second region is
+       #      modified
+       #
+       # The detection has to be done via the hardcoded mtd partition because
+       # the current boot might be done with the fallback region. Let us
+       # assume that the current bootseq is 1,2. The bootloader detected that
+       # the image in flash region 1 is corrupt and thus switches to flash
+       # region 2. The bootseq in the u-boot-env is now still the same and
+       # the sysupgrade code can now only rely on the actual mtd indexes and
+       # not the bootseq variable to detect the currently booted flash
+       # region/image.
+       #
+       # In the above example, an implementation which uses bootseq ("1,2") to
+       # detect the currently booted image would assume that region 1 is booted
+       # and then overwrite the variables for the wrong flash region (aka the
+       # one which isn't modified). This could result in a device which doesn't
+       # boot anymore to Linux until it was reflashed with ap51-flash.
+       local next_boot_part="1"
+       case "$(board_name)" in
+       openmesh,a42)
+               primary_kernel_mtd=8
+               ;;
+       *)
+               echo "failed to detect primary kernel mtd partition for board"
+               return 1
+               ;;
+       esac
+       [ "$kernel_mtd" = "$primary_kernel_mtd" ] || next_boot_part="2"
+
+       local board_dir=$(tar tf $tar_file | grep -m 1 '^sysupgrade-.*/$')
+       board_dir=${board_dir%/}
+
+       local kernel_length=$(tar xf $tar_file ${board_dir}/kernel -O | wc -c)
+       local rootfs_length=$(tar xf $tar_file ${board_dir}/root -O | wc -c)
+       # rootfs without EOF marker
+       rootfs_length=$((rootfs_length-4))
+
+       local kernel_md5=$(tar xf $tar_file ${board_dir}/kernel -O | md5sum); kernel_md5="${kernel_md5%% *}"
+       # md5 checksum of rootfs with EOF marker
+       local rootfs_md5=$(tar xf $tar_file ${board_dir}/root -O | dd bs=1 count=$rootfs_length | md5sum); rootfs_md5="${rootfs_md5%% *}"
+
+       #
+       # add tar support to get_image() to use default_do_upgrade() instead?
+       #
+
+       # take care of restoring a saved config
+       [ "$SAVE_CONFIG" -eq 1 ] && restore_backup="${MTD_CONFIG_ARGS} -j ${CONF_TAR}"
+
+       # write concatinated kernel + rootfs to flash
+       tar xf $tar_file ${board_dir}/kernel ${board_dir}/root -O | \
+               mtd $restore_backup write - $PART_NAME
+
+       # prepare new u-boot env
+       if [ "$next_boot_part" = "1" ]; then
+               echo "bootseq 1,2" > $setenv_script
+       else
+               echo "bootseq 2,1" > $setenv_script
+       fi
+
+       printf "kernel_size_%i 0x%08x\n" $next_boot_part $kernel_length >> $setenv_script
+       printf "vmlinux_start_addr 0x%08x\n" ${kernel_offset} >> $setenv_script
+       printf "vmlinux_size 0x%08x\n" ${kernel_length} >> $setenv_script
+       printf "vmlinux_checksum %s\n" ${kernel_md5} >> $setenv_script
+
+       printf "rootfs_size_%i 0x%08x\n" $next_boot_part $((total_size-kernel_length)) >> $setenv_script
+       printf "rootfs_start_addr 0x%08x\n" $((kernel_offset+kernel_length)) >> $setenv_script
+       printf "rootfs_size 0x%08x\n" ${rootfs_length} >> $setenv_script
+       printf "rootfs_checksum %s\n" ${rootfs_md5} >> $setenv_script
+
+       # store u-boot env changes
+       fw_setenv -s $setenv_script || {
+               echo "failed to update U-Boot environment"
+               return 1
+       }
+}
+
+# create /var/lock for the lock "fw_setenv.lock" of fw_setenv
+# the rest is copied using ipq806x's RAMFS_COPY_BIN and RAMFS_COPY_DATA
+platform_add_ramfs_ubootenv()
+{
+        mkdir -p $RAM_ROOT/var/lock
+}
+append sysupgrade_pre_upgrade platform_add_ramfs_ubootenv
index f71ee37d9937a004a7a83df19f2eff2ad33a21dd..5561dd538c56157983151a4f1e5ae41d521e379c 100644 (file)
@@ -22,6 +22,10 @@ platform_do_upgrade() {
        zyxel,nbg6817)
                nand_do_upgrade "$ARGV"
                ;;
+       openmesh,a42)
+               PART_NAME="inactive"
+               platform_do_upgrade_openmesh "$ARGV"
+               ;;
        tplink,c2600)
                PART_NAME="os-image:rootfs"
                MTD_CONFIG_ARGS="-s 0x200000"
diff --git a/target/linux/ipq806x/files-4.9/arch/arm/boot/dts/qcom-ipq4019-a42.dts b/target/linux/ipq806x/files-4.9/arch/arm/boot/dts/qcom-ipq4019-a42.dts
new file mode 100644 (file)
index 0000000..887be99
--- /dev/null
@@ -0,0 +1,244 @@
+/* Copyright (c) 2015, The Linux Foundation. All rights reserved.
+ * Copyright (c) 2017, Sven Eckelmann <sven.eckelmann@openmesh.com>
+ *
+ * Permission to use, copy, modify, and/or distribute this software for any
+ * purpose with or without fee is hereby granted, provided that the above
+ * copyright notice and this permission notice appear in all copies.
+ *
+ * THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHOR DISCLAIMS ALL WARRANTIES
+ * WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF
+ * MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR
+ * ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES
+ * WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN
+ * ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF
+ * OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
+ *
+ */
+
+#include "qcom-ipq4019.dtsi"
+#include "qcom-ipq4019-bus.dtsi"
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+#include <dt-bindings/soc/qcom,tcsr.h>
+
+/ {
+       model = "OpenMesh A42";
+       compatible = "openmesh,a42", "qcom,ipq4019";
+
+       reserved-memory {
+               #address-cells = <0x1>;
+               #size-cells = <0x1>;
+               ranges;
+
+               rsvd1@87000000 {
+                       reg = <0x87000000 0x500000>;
+                       no-map;
+               };
+
+               wifi_dump@87500000 {
+                       reg = <0x87500000 0x600000>;
+                       no-map;
+               };
+
+               rsvd2@87B00000 {
+                       reg = <0x87b00000 0x500000>;
+                       no-map;
+               };
+       };
+
+       soc {
+               tcsr@194b000 {
+                       /* select hostmode */
+                       compatible = "qcom,tcsr";
+                       reg = <0x194b000 0x100>;
+                       qcom,usb-hsphy-mode-select = <TCSR_USB_HSPHY_HOST_MODE>;
+                       status = "ok";
+               };
+
+               ess_tcsr@1953000 {
+                       compatible = "qcom,tcsr";
+                       reg = <0x1953000 0x1000>;
+                       qcom,ess-interface-select = <TCSR_ESS_PSGMII>;
+               };
+
+               tcsr@1949000 {
+                       compatible = "qcom,tcsr";
+                       reg = <0x1949000 0x100>;
+                       qcom,wifi_glb_cfg = <TCSR_WIFI_GLB_CFG>;
+               };
+
+               tcsr@1957000 {
+                       compatible = "qcom,tcsr";
+                       reg = <0x1957000 0x100>;
+                       qcom,wifi_noc_memtype_m0_m2 = <TCSR_WIFI_NOC_MEMTYPE_M0_M2>;
+               };
+
+               pinctrl@1000000 {
+                       serial_pins: serial_pinmux {
+                               mux {
+                                       pins = "gpio60", "gpio61";
+                                       function = "blsp_uart0";
+                                       bias-disable;
+                               };
+                       };
+
+                       spi_0_pins: spi_0_pinmux {
+                               pinmux {
+                                       function = "blsp_spi0";
+                                       pins = "gpio55", "gpio56", "gpio57";
+                               };
+                               pinmux_cs {
+                                       function = "gpio";
+                                       pins = "gpio54";
+                               };
+                               pinconf {
+                                       pins = "gpio55", "gpio56", "gpio57";
+                                       drive-strength = <12>;
+                                       bias-disable;
+                               };
+                               pinconf_cs {
+                                       pins = "gpio54";
+                                       drive-strength = <2>;
+                                       bias-disable;
+                                       output-high;
+                               };
+                       };
+               };
+
+               blsp_dma: dma@7884000 {
+                       status = "ok";
+               };
+
+               spi_0: spi@78b5000 {
+                       pinctrl-0 = <&spi_0_pins>;
+                       pinctrl-names = "default";
+                       status = "ok";
+                       cs-gpios = <&tlmm 54 0>;
+
+                       m25p80@0 {
+                               #address-cells = <1>;
+                               #size-cells = <1>;
+                               compatible = "jedec,spi-nor";
+                               reg = <0>;
+                               spi-max-frequency = <24000000>;
+
+                               /* partitions are passed via bootloader */
+                       };
+               };
+
+               serial@78af000 {
+                       pinctrl-0 = <&serial_pins>;
+                       pinctrl-names = "default";
+                       status = "ok";
+               };
+
+               cryptobam: dma@8e04000 {
+                       status = "ok";
+               };
+
+               crypto@8e3a000 {
+                       status = "ok";
+               };
+
+               watchdog@b017000 {
+                       status = "ok";
+               };
+
+               usb2_hs_phy: hsphy@a8000 {
+                       status = "ok";
+               };
+
+               usb2: usb2@60f8800 {
+                       status = "ok";
+               };
+
+               mdio@90000 {
+                       status = "okay";
+               };
+
+               ess-switch@c000000 {
+                       status = "okay";
+               };
+
+               ess-psgmii@98000 {
+                       status = "okay";
+               };
+
+               edma@c080000 {
+                       status = "okay";
+               };
+
+               wifi@a000000 {
+                       status = "okay";
+                       qcom,ath10k-calibration-variant = "OM-A42";
+               };
+
+               wifi@a800000 {
+                       status = "okay";
+                       qcom,ath10k-calibration-variant = "OM-A42";
+               };
+       };
+
+       gpio-keys {
+               compatible = "gpio-keys";
+
+               reset {
+                       label = "reset";
+                       gpios = <&tlmm 59 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_RESTART>;
+               };
+       };
+
+       aliases {
+               led-boot = &power;
+               led-failsafe = &power;
+               led-running = &power;
+               led-upgrade = &power;
+       };
+
+       gpio-leds {
+               compatible = "gpio-leds";
+
+               red {
+                       label = "a42:red:status";
+                       gpios = <&tlmm 0 GPIO_ACTIVE_HIGH>;
+                       linux,default-trigger = "default-off";
+               };
+
+               power: green {
+                       label = "a42:green:status";
+                       gpios = <&tlmm 1 GPIO_ACTIVE_HIGH>;
+               };
+
+               blue {
+                       label = "a42:blue:status";
+                       gpios = <&tlmm 2 GPIO_ACTIVE_HIGH>;
+                       linux,default-trigger = "default-off";
+               };
+       };
+
+       watchdog {
+               compatible = "linux,wdt-gpio";
+               gpios = <&tlmm 5 GPIO_ACTIVE_LOW>;
+               hw_algo = "toggle";
+               /* hw_margin_ms is actually 300s but driver limits it to 60s */
+               hw_margin_ms = <60000>;
+               always-running;
+       };
+};
+
+&gmac0 {
+       qcom,phy_mdio_addr = <4>;
+       qcom,poll_required = <1>;
+       qcom,forced_speed = <1000>;
+       qcom,forced_duplex = <1>;
+       vlan_tag = <2 0x20>;
+};
+
+&gmac1 {
+       qcom,phy_mdio_addr = <3>;
+       qcom,poll_required = <1>;
+       qcom,forced_speed = <1000>;
+       qcom,forced_duplex = <1>;
+       vlan_tag = <1 0x10>;
+};
index e8182e858f3d201c0c9048264b674a488a616b6b..708150521e75e72c3753c483e97db37bc750c1b6 100644 (file)
@@ -192,6 +192,23 @@ define Device/netgear_r7800
 endef
 TARGET_DEVICES += netgear_r7800
 
+define Device/openmesh_a42
+       $(call Device/FitImageLzma)
+       FILESYSTEMS := squashfs
+       DEVICE_DTS := qcom-ipq4019-a42
+       KERNEL_LOADADDR := 0x80208000
+       BLOCKSIZE := 64k
+       SUPPORTED_DEVICES := openmesh,a42
+       DEVICE_TITLE := OpenMesh A42
+       KERNEL = kernel-bin | lzma | fit lzma $$(DTS_DIR)/$$(DEVICE_DTS).dtb | pad-to $$(BLOCKSIZE)
+       IMAGE_SIZE := 15616k
+       IMAGES = factory.bin sysupgrade.bin
+       IMAGE/factory.bin/squashfs := append-rootfs | pad-rootfs | openmesh-image ce_type=A42
+       IMAGE/sysupgrade.bin/squashfs := append-rootfs | pad-rootfs | sysupgrade-tar rootfs=$$$$@ | append-metadata
+       DEVICE_PACKAGES := ath10k-firmware-qca4019 uboot-envtools ipq-wifi-openmesh_a42
+endef
+TARGET_DEVICES += openmesh_a42
+
 define Device/qcom_ap-dk01.1-c1
        PROFILES += $$(DEVICE_NAME)
        DEVICE_TITLE := QCA AP-DK01.1-C1
index a6c66d703cd88b1d3e6aa90d4b5ad7e3a1c2815b..faabc240027264f7b30de2cdc0356b953e45a37a 100644 (file)
@@ -10,8 +10,11 @@ Signed-off-by: John Crispin <john@phrozen.org>
 
 --- a/arch/arm/boot/dts/Makefile
 +++ b/arch/arm/boot/dts/Makefile
-@@ -618,7 +618,16 @@ dtb-$(CONFIG_ARCH_QCOM) += \
+@@ -616,9 +616,19 @@ dtb-$(CONFIG_ARCH_QCOM) += \
+       qcom-apq8074-dragonboard.dtb \
+       qcom-apq8084-ifc6540.dtb \
        qcom-apq8084-mtp.dtb \
++      qcom-ipq4019-a42.dtb \
        qcom-ipq4019-ap.dk01.1-c1.dtb \
        qcom-ipq4019-ap.dk04.1-c1.dtb \
 +      qcom-ipq4019-fritz4040.dtb \